KDE 5 is not able to customize the short date representation to ISO. This was already so since it started (it was simple configurable in KDE 4 and earlier), but feeling urged to move to it from KDE 4 I revisited this show-stopping issue.

The KDE bug is here: https://bugs.kde.org/show_bug.cgi?id=340982

According to other sources on the internet, choosing Denmark-English (en_DK) should help in at least showing a correct ISO formatted short date (though not my local Dutch names for monthes and days). I tried it, but it gave 02/06/2018. Well at least it shows clearly what the year is and thus the rest can be concluded. I decided to live with this for the time being.

But reading the last post of the KDE bug:
not a solution at all, but an ugly workaround.

on fedora 27 (plasma 5.10.5):

add "LC_TIME=en_DK.UTF-8" to /etc/locale.conf
in kde, set "System Settings" -> "Regional Settings" -> "Formats" -> "Time" to "Sweden - English (en_SE)"

for some reason, the en_DK definition in qt/kde5 has the wrong date order, but en_SE (which i've never heard of and doesn't exist in the system locale database) has the correct one.

this will give you:

english long date
iso short date (YYYY-MM-DD)
24-hour clock
I tried Sweden-English (en_SE) and indeed I got 2018-06-02 for today!

Now that it is proven that KDE CAN create the correct date specification, I wonder where that is defined in KDE. Somewhere there must be a table that defines what to do with which LC_TIME definition. And IMHO there is an error there for en_DK, but when one can compare what is there for en_SE a correction might be possible. Not that I want to correct for en_DK, but I want of course correct nl_NL (which is utterly wrong.

Or is it not a configuration table somewhere, but is it hard-coded in some library?