Results 1 to 6 of 6

Thread: RTL8812AU install errors

  1. #1
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default RTL8812AU install errors

    updated from Leap 42.3 to 15.0 today and all seemed to go well.
    Of course I need to reinstall the drivers for my rtl8812AU wifi adapter because of the new kernel . . . but I'm not having much luck.

    dkms install gives me the error message . . .
    Code:
    dkms install rtl8812AU/1
    .0
    
    Kernel preparation unnecessary for this kernel.  Skipping...
    
    Building module:
    cleaning build area...
    'make'....(bad exit status: 2)
    Error! Bad return status for module build on kernel: 4.12.14-lp150.12.4-default (x
    86_64)
    Consult /var/lib/dkms/rtl8812AU/1.0/build/make.log for more information.
    
    and the log file contains this info . . .

    DKMS make.log for rtl8812AU-1.0 for kernel 4.12.14-lp150.12.4-default (x86_64)
    Sat Jun 2 18:45:02 NZST 2018
    make ARCH=x86_64 CROSS_COMPILE= -C /lib/modules/4.12.14-lp150.12.4-default/build M=/var/lib/dkms/rtl8812AU/1.0/build modules
    make[1]: Entering directory '/usr/src/linux-4.12.14-lp150.12.4-obj/x86_64/default'
    CC [M] /var/lib/dkms/rtl8812AU/1.0/build/core/rtw_cmd.o
    In file included from /var/lib/dkms/rtl8812AU/1.0/build/include/drv_types.h:32:0,
    from /var/lib/dkms/rtl8812AU/1.0/build/core/rtw_cmd.c:22:
    /var/lib/dkms/rtl8812AU/1.0/build/include/osdep_service.h: In function ‘thread_enter’:
    /var/lib/dkms/rtl8812AU/1.0/build/include/osdep_service.h:343:2: error: implicit declaration of function ‘allow_signal’; did you mean ‘do_signal’? [-Werror=implicit-function-declaration]
    allow_signal(SIGTERM);
    ^~~~~~~~~~~~
    do_signal
    /var/lib/dkms/rtl8812AU/1.0/build/include/osdep_service.h: In function ‘flush_signals_thread’:
    /var/lib/dkms/rtl8812AU/1.0/build/include/osdep_service.h:353:6: error: implicit declaration of function ‘signal_pending’; did you mean ‘timer_pending’? [-Werror=implicit-function-declaration]
    if (signal_pending (current))
    ^~~~~~~~~~~~~~
    timer_pending
    /var/lib/dkms/rtl8812AU/1.0/build/include/osdep_service.h:355:3: error: implicit declaration of function ‘flush_signals’; did you mean ‘do_signal’? [-Werror=implicit-function-declaration]
    flush_signals(current);
    ^~~~~~~~~~~~~
    do_signal
    cc1: some warnings being treated as errors
    make[4]: *** [/usr/src/linux-4.12.14-lp150.12.4/scripts/Makefile.build:328: /var/lib/dkms/rtl8812AU/1.0/build/core/rtw_cmd.o] Error 1
    make[3]: *** [/usr/src/linux-4.12.14-lp150.12.4/Makefile:1549: _module_/var/lib/dkms/rtl8812AU/1.0/build] Error 2
    make[2]: *** [Makefile:152: sub-make] Error 2
    make[1]: *** [Makefile:24: __sub-make] Error 2
    make[1]: Leaving directory '/usr/src/linux-4.12.14-lp150.12.4-obj/x86_64/default'
    make: *** [Makefile:1680: modules] Error 2

    is anybody able to point me in the right direction to get this driver installed?
    Or is there an rpm in a repo somewhere that is available for this wifi driver?

  2. #2

    Default Re: RTL8812AU install errors

    I don’t have anything to hide, but I don’t have anything I want to show you either.

  3. #3
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,732

    Default AW: RTL8812AU install errors

    Thats an error from last year, so I think your source is not up to date......

    Or try the driver from my /home Repo.

  4. #4
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: AW: RTL8812AU install errors

    Quote Originally Posted by Sauerland View Post
    Thats an error from last year, so I think your source is not up to date......Or try the driver from my /home Repo.
    Thanks . . . I was able to install the version I had (4.3.20) using "make" just not using dkms.However, I've now installed the version from your Home repo so that should take the headache out of future kernel updates.Interestingly, the version I was using in network manager showed a signal strength of 89% while the one from your repo shows a strength of only 56%.
    What would account for the difference?

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,732

    Default AW: RTL8812AU install errors

    I use different sources.

    And you have to use my Leap15.0-Update Repo to get the Updates.

  6. #6
    Join Date
    Jun 2008
    Location
    NZ
    Posts
    1,664

    Default Re: RTL8812AU install errors

    it turns out that DKMS must have gotten messed up in the update (along with a few other things).
    I've done a clean / fresh install of leap 15 and now dkms installs my source fine.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •