Results 1 to 8 of 8

Thread: Which repositories are necessary for Tumbleweed and how to tell compatibility?

  1. #1

    Default Which repositories are necessary for Tumbleweed and how to tell compatibility?

    I'm running Tumbleweed and every time I do a zypper dup, I get a warning to make sure that my repositories are compatible before proceeding. I'm not sure how to tell if repositories are compatible or not.

    Which repositories are necessary for Tumbleweed? (I will disable the others.)

    I also have what looks to be two different Tumbleweed Packman repositories. I don't know if openSUSE repositories are compatible with Packman repositories or not.

    Thanks in advance for your help.

    EDIT: Several of these repositories were added for multimedia codecs, etc. I also have a Skype repository, but I don't think that conflicts with anything. However, when trying to install xfce, I get conflicts which tell me that there are incompatibilities somewhere.
    Last edited by zeusdeuce; 01-Jun-2018 at 20:10. Reason: Additional information

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,201
    Blog Entries
    15

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    Quote Originally Posted by zeusdeuce View Post
    I'm running Tumbleweed and every time I do a zypper dup, I get a warning to make sure that my repositories are compatible before proceeding. I'm not sure how to tell if repositories are compatible or not.

    Which repositories are necessary for Tumbleweed? (I will disable the others.)

    I also have what looks to be two different Tumbleweed Packman repositories. I don't know if openSUSE repositories are compatible with Packman repositories or not.

    Thanks in advance for your help.

    EDIT: Several of these repositories were added for multimedia codecs, etc. I also have a Skype repository, but I don't think that conflicts with anything. However, when trying to install xfce, I get conflicts which tell me that there are incompatibilities somewhere.
    Hi
    Please post the output of your repositories from the following command in code tags so we can see what you have
    Code:
    zypper lr -d
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    Quote Originally Posted by malcolmlewis View Post
    Hi
    Please post the output of your repositories from the following command in code tags so we can see what you have
    Code:
    zypper lr -d

    Code:
     ~> zypper lr -d
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    #  | Alias                            | Name                        | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                   | Service
    ---+----------------------------------+-----------------------------+---------+-----------+---------+----------+--------+---------------------------------------------------------------------------------------+--------
     1 | http-ftp.gwdg.de-622c217d        | Packman Repository          | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/packman/suse/openSUSE_Tumbleweed/                        |        
     2 | http-opensuse-guide.org-884d6d10 | libdvdcss repository        | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                   |        
     3 | libdvdcss                        | libdvdcss                   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://opensuse-guide.org/repo/openSUSE_Tumbleweed/                                   |        
     4 | openSUSE-20180516-0              | openSUSE-20180516-0         | Yes     | (r ) Yes  | No      |   99     | rpm-md | cd:///?devices=/dev/disk/by-id/ata-HL-DT-ST_DVDRAM_GUE0N_KZ4I1VJ4118                  |        
     5 | openSUSE_Tumbleweed              | X11:Cinnamon:Current,       | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/repositories/X11:/Cinnamon:/Current/openSUSE_Tumbleweed/ |        
     6 | packman                          | packman                     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://ftp.gwdg.de/pub/linux/misc/packman/suse/openSUSE_Tumbleweed/                   |        
     7 | repo-debug                       | openSUSE-Tumbleweed-Debug   | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/debug/tumbleweed/repo/oss/                               |        
     8 | repo-non-oss                     | openSUSE-Tumbleweed-Non-Oss | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/non-oss/                                 |        
     9 | repo-oss                         | openSUSE-Tumbleweed-Oss     | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/tumbleweed/repo/oss/                                     |        
    10 | repo-source                      | openSUSE-Tumbleweed-Source  | No      | ----      | ----    |   99     | NONE   | http://download.opensuse.org/source/tumbleweed/repo/oss/                              |        
    11 | repo-update                      | openSUSE-Tumbleweed-Update  | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://download.opensuse.org/update/tumbleweed/                                       |        
    12 | skype-stable                     | skype (stable)              | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | https://repo.skype.com/rpm/stable/

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,378

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    As you can see yourself, #2 and #3 are the same, thus you can remove one of them. he other one can then be disabled, because once you have installed the only package there is there, you do not need it any more.

    Packman misc (#6) is a subset of Packman (#1). Thus remove #6.

    #5 and #12 or not necessary for Tumbleweed, but when you want to use them, that is OK.

    #4 is the installation medium. Disable it, else YaST Software/zypper will ask for it every time you start them.

    Take care, as soon as you remove one, the numbering will change, thus check and re-check before every action if you use the correct number. Or use YaST > Software > Repository Management, which might be easier to use.
    Last edited by hcvv; 02-Jun-2018 at 01:00.
    Henk van Velden

  5. #5
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,038
    Blog Entries
    14

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    FWIW, you can do that in one go:
    Code:
    zypper rr 2 6
    and so on

    Here's how it works on Tw: If you cannot find a package in the Tw distribution repos, and someone is already building it, you can ask the packager to have it added to the distribution. If you use home:/ repos, be aware that those are repos where packagers/devs build their stuff and where they break things every once in a while, since that is what these repos are for.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  6. #6

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    Thanks, guys. I really appreciate the help because I had no idea what to do.

  7. #7

    Exclamation Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    I'm still getting conflicts when trying to install xfce, and I can't figure out where they are coming from:

    Code:
    5 Problems:
    Problem: xfce4-notifyd-branding-upstream-0.4.2-1.1.noarch conflicts with namespace:otherproviders(xfce4-notifyd-branding) provided by xfce4-notifyd-branding-openSUSE-4.12.0-9.2.noarch
    Problem: xfce4-panel-branding-upstream-4.12.2-2.1.noarch conflicts with namespace:otherproviders(xfce4-panel-branding) provided by xfce4-panel-branding-openSUSE-4.12.0-9.2.noarch
    Problem: xfce4-power-manager-branding-upstream-1.6.1-2.1.noarch conflicts with namespace:otherproviders(xfce4-power-manager-branding) provided by xfce4-power-manager-branding-openSUSE-4.12.0-9.2.noarch
    Problem: xfce4-session-branding-upstream-4.12.1-7.2.noarch conflicts with namespace:otherproviders(xfce4-session-branding) provided by xfce4-session-branding-openSUSE-4.12.0-9.2.noarch
    Problem: xfce4-settings-branding-upstream-4.12.3-1.1.noarch conflicts with namespace:otherproviders(xfce4-settings-branding) provided by xfce4-settings-branding-openSUSE-4.12.0-9.2.noarch
    
    Problem: xfce4-notifyd-branding-upstream-0.4.2-1.1.noarch conflicts with namespace:otherproviders(xfce4-notifyd-branding) provided by xfce4-notifyd-branding-openSUSE-4.12.0-9.2.noarch
     Solution 1: do not install xfce4-notifyd-branding-upstream-0.4.2-1.1.noarch
     Solution 2: do not install xfce4-notifyd-branding-openSUSE-4.12.0-9.2.noarch
    
    Choose from above solutions by number or skip, retry or cancel [1/2/s/r/c] (c):

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Which repositories are necessary for Tumbleweed and how to tell compatibility?

    Which method did you use to try installing XFCE?
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •