Results 1 to 6 of 6

Thread: laptop not connected to network all the time Tumbleweeds latest greatest.

  1. #1
    Join Date
    May 2015
    Location
    Michigan/Florida
    Posts
    65

    Default laptop not connected to network all the time Tumbleweeds latest greatest.

    This may be a unique problem but it is my problem.

    My laptop is rarely connected to a internet connection and the software updates is throwing a connection error quite often.

    How can i make the software updater only active when connected so i don't get the errors constantly?

    I only use the updater to see theres updates when the internet connection is active but use zypper in a konsole to do the actuall updateing.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: laptop not connected to network all the time Tumbleweeds latest greatest.

    Quote Originally Posted by GDixon View Post
    This may be a unique problem but it is my problem.

    My laptop is rarely connected to a internet connection and the software updates is throwing a connection error quite often.

    How can i make the software updater only active when connected so i don't get the errors constantly?

    I only use the updater to see theres updates when the internet connection is active but use zypper in a konsole to do the actuall updateing.
    Your post includes your probable issue: as per documentation you should not use the updater or YaST, but only 'zypper dup' to update Tumbleweed. This due to Tw's nature, it gets released over and over again. Running anything but 'zypper dup' will definitely bork your system one way or another.
    So, first run 'zypper dup' and disable the updater.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: laptop not connected to network all the time Tumbleweeds latest greatest.

    If you are using gnome:
    Disables notifications
    gsettings set org.gnome.software download-updates false
    Disables the use of package updater
    gsettings set org.gnome.software allow-updates false
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  4. #4
    Join Date
    May 2015
    Location
    Michigan/Florida
    Posts
    65

    Default Re: laptop not connected to network all the time Tumbleweeds latest greatest.

    I agree zypper dup is the best way to update and is how i do so.

    Just how can i disable the updater that gets placed in the sys tray? There is no obvious way to do so.

  5. #5
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: laptop not connected to network all the time Tumbleweeds latest greatest.

    Quote Originally Posted by GDixon View Post
    I agree zypper dup is the best way to update and is how i do so.

    Just how can i disable the updater that gets placed in the sys tray? There is no obvious way to do so.
    Right click on the system tray (bottom right of your screen) and remove it (software update).

  6. #6
    Join Date
    May 2015
    Location
    Michigan/Florida
    Posts
    65

    Default Re: laptop not connected to network all the time Tumbleweeds latest greatest. SOLVED!

    Doh, it's as simple as that lol and here i was searching for a box to check and turn it off!

    Thanks now to mark this as solved

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •