Results 1 to 6 of 6

Thread: YaST fails to open 'Boot Loader' section

  1. #1
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    596

    Default YaST fails to open 'Boot Loader' section

    Where do I report this error?
    Image at this link.
    HTML Code:
    http://susepaste.org/11094109
    I have the log tar.xz, just need to know where to put it.

    Or can I install YaST2 again, or parts of it?

  2. #2
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    596

    Default Re: YaST fails to open 'Boot Loader' section FIXED I HOPE!

    OK, found the problem. I put "ACPI=OFF" at the end of the cmdline in /etc/default/grub instead of in /boot/grub2/grub.cfg.
    YaST Boot Loader Section now opens as it should. Dumb neophyte mistake.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,643
    Blog Entries
    3

    Default Re: YaST fails to open 'Boot Loader' section FIXED I HOPE!

    Quote Originally Posted by BillLyte View Post
    OK, found the problem. I put "ACPI=OFF" at the end of the cmdline in /etc/default/grub instead of in /boot/grub2/grub.cfg.
    What you put in "/boot/grub2/grub.cfg" is what will be used in the next boot.

    What you put in "/etc/default/grub" is what will be put into that "grub.cfg" when it is next automatically updated.

    In short, you need it in both places.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    25,171

    Default Re: YaST fails to open 'Boot Loader' section

    And a forum technical hint.

    You used the HTML tags around the URL in post #1 above. But an URL is not HTML. Next time better use the Link button, that is the one with the globe. Then others can simply click on it.
    Henk van Velden

  5. #5

    Default Re: YaST fails to open 'Boot Loader' section FIXED I HOPE!

    Quote Originally Posted by nrickert View Post
    What you put in "/boot/grub2/grub.cfg" is what will be used in the next boot.

    What you put in "/etc/default/grub" is what will be put into that "grub.cfg" when it is next automatically updated.

    In short, you need it in both places.
    Correct, you should run "grub2-mkconfig -o /boot/grub2/grub.cfg" after you change /etc/default/grub (as instructed in that file), to regenerate the grub.cfg for the change to have effect.
    That's also what YaST does btw, change /etc/default/grub and then run grub2-mkconfig.

    Regarding the error message: YaST seems to have problems parsing your /etc/default/grub.
    You probably have corrupted it somehow when adding the "ACPI=OFF".

    Btw, did you really add "ACPI=OFF" (in all upper case)?
    It should rather be "acpi=off".
    But it's probably not a good idea to disable ACPI completely anyway, that likely will break accelerated graphics display e.g. and other stuff.

    And if you want to try out some option, you can also press 'e' at the boot menu and modify the entry on the fly. That only affects the current boot then, and won't get saved (i.e. you can't break your system with that... ).
    Last edited by wolfi323; 30-May-2018 at 02:56.

  6. #6
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    596

    Default Re: YaST fails to open 'Boot Loader' section

    @hcvv, OK, I will use the globe for URLs, thank you for pointing that out. My bad, and I can’t garantee I won’t make more mistakes like that. I WILL read the new user guide soon.

    @others, I took any form of ‘acpi=off’ or ‘ACPI=OFF’ out of both scripts mentioned. It wasn’t stopping the acpi error on boot any. I don’t recall if it was capital or not.

    Anyway, YaST Boot Loader loads normally now, once the acpi=off was removed from the end of the cmdline.

    @all responders, thanks for the help and instructive comments.

    I will make mistakes, I will learn from them.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •