I was using Leap 42.3 on a ThinkPad X1 Carbon connected to the ThinkPad Thunderbolt 3 Dock. The network interface and everything else of that dock was working out of the box (well except hot-plugging/unplugging).

Surprisingly after reinstalling from scratch with Leap 15 the network interface of that dock is not working anymore. USB, DP, charging all is working, only the ethernet intreface does not.

Network is managed by NetworkManager which shows in Overview tab of KDE (translated from German, so don't stick to the letter ;-)
Ethernet Connection (4) I219-LM; DHCP;eth0 (comment: internal LAN adapter connected currently for writing this post)
Sierra Wireless EM7455 Qualcomm Snapdragon X7 LTE-A;not configured (comment: wwan-adapter without SIM)
ThinkPad TBT3 LAN;not configured (comment: this seams to be the ethernet adapter in the dock)
Wirelss 8265 / 8275;not configured (wlan disabled currently)

I tried switching to wicked (and back) for manually addressing the interface. I tried with or without wlan, with or without built in eth0 connected, no success. One further message told, that there is no kernel device for that interface, and I could look in dmesg

In dmesg the device shows up with the following lines
[ 4.392134] usb 6-1: new SuperSpeed USB device number 2 using xhci_hcd
[ 4.412886] usb 6-1: New USB device found, idVendor=17ef, idProduct=3069
[ 4.412887] usb 6-1: New USB device strings: Mfr=1, Product=2, SerialNumber=6
[ 4.412888] usb 6-1: Product: ThinkPad TBT3 LAN
[ 4.412888] usb 6-1: Manufacturer: Lenovo
[ 4.412889] usb 6-1: SerialNumber: 301000001

Any hint on where to look next?