Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

  1. #1

    Default Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    It's been a few days since I upgraded to Leap 15;
    I've noted something that was not present in Leap 42.3
    Frequently when I access an application which uses or might use the built-in audio hardware
    there is a loud startup click from the output speakers.
    Playing audio is very good - all normal apart from the initial click.
    If I select say a USB device as output often I get the same click from the onboard speaker connection
    but again with the click over and done with the rest of the playback is excellent.

    Starting an application like "test speakers" will sometimes produce the click right before the test starts;
    not after the app was recently used, but almost certainly if the app has not been in use for a while.

    -----

    A second observation is that there is no longer a "pulse" item in various device lists
    (example in Skype or Audacity) to select the audio device according to the pulse selection.
    All the devices are listed individually along with default and sysdefault and work fine
    but no "pulse" option.

    I guess I must have missed the memo on these items. Anyone else seeing the same differences?
    I have checked that all the alsa plugin libraries are loaded, as they were in 42.3.

  2. #2
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    387

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Yes same here, and I can't tell if it is coming from the Radeon HD5400 (HDMI) series PCI card, the HP DC7700 CMT built in speaker, or if it is the disk drive that Leap 15 is on that is clicking.

    Not only opening some apps, but I get it when putting things in the trash bin, going from directory to directory, and occasionally copying from my windows drives to my Leap drive.

    Getting to be annoying, and I can't find a way to stop it. And it needs to be stopped, especially if it is the HDD that is clicking.

    If I open Firefox, no click, If I open Chrome it clicks. I will keep an ear on it to see if there are other things that cause it.

  3. #3
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    387

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    On my system it is not the card, nor the drive. It is the same ‘click’ that occurs when I shut my HP Compaq down. So it is the machines built in sound/speaker.

    Still it is annoying to have it click when opening multimedia apps, the browser, and the clicks manipulating files around( to trash, clearing trash, copy from/to, etc. fairly constant at times.

    I’m about to unplug the wire going to the hardware speaker!

  4. #4

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Looks like the system is putting your sound hardware to sleep- in an effort to provide additional power savings when you're not using it to play any sound for a while. When it needs to play sounds, it wakes up the sound hardware, which in turn causes the pop.
    Perhaps you should try this:-

    Yast-->Sound (make sure all the sound cards listed are configured. If it says "Not configured", run a quick configuration)-->Select your sound card from the list-->Click "Edit"-->Select "Enable power management blacklist"-->Click "Edit"-->Select "1" from the drop-down menu-->Click "OK" to save the selection and close the dialog box-->Click "Next"-->Click "Ok".
    Close Yast.
    Restart computer.
    Check if the problem is still present.

    Last edited by johnwinchester; 30-May-2018 at 21:16. Reason: Add screenshot

  5. #5
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    387

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Thanks John, If that doen't work, I can disable disable both the 'onboard' audio and speaker in the BIOS.
    Probably should have looked here first.

  6. #6
    Join Date
    Apr 2018
    Location
    U.S Midwest just West of the Mississippi River
    Posts
    387

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Quote Originally Posted by BillLyte View Post
    Thanks John, If that doesn't work, I can disable disable both the 'onboard' audio and speaker in the BIOS.
    Probably should have looked here first.
    Didn't work for my machine. Looks like I will have to disable it in the BIOS, and hope the next major update/upgrade takes care of this very annoying 'feature'!
    Every time something calls for a sound, whether within Leap system, or on the web, it is there. YouTube especially annoying when changing videos.
    And with earphones on, it is worse. Oh well.

    Also, for boxes that have a beginning and an end, using the cursor keys drives the thing nuts with multiple loud beeps before I can take my finger off the key.

    Still gotta wonder what changed between 42.3 and 15.0 to cause this, or if it was caused by the upgrade while 42.3 was active?

  7. #7

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    The suggestion to look into Yast configuration of sound cards seems to have resolved this for me, thankyou.
    In Yast I had three cards listed, all "not configured", so I went through each one and with edit produced an integer 0..2 for each.
    The Yast "test" for volume is not very helpful in that it will send the test sound through whatever the default device is, not the one you are testing in Yast.
    However all of this done and it seems to be what I experienced in 42.3:
    a slight dull bump when I open Audacity, nothing like the heavy click previously
    but other applications do not at this point produce any sound on opening.
    Much improved.

    My second point about "pulse" option missing is still open, but default is working for now.

  8. #8

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Quote Originally Posted by colbec View Post
    The suggestion to look into Yast configuration of sound cards seems to have resolved this for me, thankyou.
    Unfortunately I was wrong. The more I play with options and restart the more things stay the same.
    For a short while things seem to be quiet again, but then the speakers surprise me with another huge click which can be quite disturbing.
    The clicks mostly come from Firefox, followed by Audacity. FF will start without a click, and web pages can begin to load,
    but while loading advertising of various sorts the loud click can happen.
    I've been trying to relate the click to the output while following journalctl but so far not been able to correlate.

  9. #9

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    The folks on the pulseaudio mailing list were helpful on this issue.
    The suggestion is to suspend pulseaudio and then use alsa directly on the hardware device.
    If the click is still there, then it must be ALSA and not pulseaudio that is causing the clicking.
    A test is:
    Code:
    pasuspend -- bash
    aplay -f cd -D hw:(your speakers) /dev/zero
    exit
    First line suspends pulseaudio and puts you in a new shell, transparently
    second line triggers silent audio in the speakers with alsa bypassing pulseaudio, stop play with ctrl+c
    Last line closes the second shell and puts you back in the first shell.
    In my case the sound persists when PA is suspended, so the clicking seems to be alsa related.

  10. #10
    Join Date
    Mar 2008
    Location
    Europe
    Posts
    26,391
    Blog Entries
    34

    Default Re: Built-in audio sound device clicking; new in Leap 15 Pulseaudio

    Interesting that it may be alsa.

    I don't know if relevant, but some modules (e.g. snd_ac97_codec and snd_hda_intel) can power off your sound card when not in use. This can make an audible noise (like a crack/pop/scratch) when turning on/off your sound card. Sometimes even when move the slider volume, or open and close windows (KDE4).

    According to an arch linux wiki,
    if you find this annoying try modinfo snd_MY_MODULE, and look for a module option that adjusts or disables this feature.

    Example: disable the power saving mode and solve cracking sound trough speakers problem, using snd_hda_intel add in /etc/modprobe.d/modprobe.conf:

    options snd_hda_intel power_save=0

    The power_save_controller option if set to 'Y' will switch the audio card controller off to conserve power, but it can cause issues when the controller resumes. Setting it to N may reduce the severity of other issues as well.

    options snd_hda_intel power_save=0 power_save_controller=N

    You can also try it with modprobe snd_hda_intel power_save=0 before.

    You may also have to unmute the 'Line' ALSA channel for this to work. Any value will do (other than '0' or something too high).


    I don't know if this relevant to you - but it may be a line of investigation you could pursue.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •