Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Keyboard

  1. #1

    Default Keyboard

    Not to sure if this is the correct area but, here goes.

    I have done a full install of leap 15, I came from Leap 42.3 which worked as expected.

    I have a Xonar DGX sound card, got that working

    I have a Nvidia GTX 1070 card, all now working as it should

    I have an Apple aluminium keyboard that has been set up the same as 42.3 which worked then but the shortcuts within firefox and thunderbird do not work. Not to sure if it is throughout Suse or just specific to these two.

  2. #2

    Default Re: Keyboard

    I have tried midori as both a user and as root, same result as firefox.

    I have checked and changed permissions, same problems

  3. #3
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,552

    Question Re: Keyboard

    You haven't mentioned which GUI you're using: KDE, GNOME, whatever?

    Please post the output of the following CLI command executed in Terminal window: 'localectl status'.

  4. #4

    Default Re: Keyboard

    Before I respond, my comparisons to the issues I have had with Leap 15.

    My Xonar DGX soundcard and alsamixer. In 42.3 I run alsamixer in a terminal presse F6 to change soundcard, set the levels and then use the alsactl set of commands to save the asound.state file and reload it as a .desktop file. The function key F6 to select the soundcard does not work, not active.

    Nvidia driver for my GTX107 works fine in both apart from the Nvidia Settings file, in 42,3 it under section settings. In 15.0 I had to change the permissions from root to myself, make an entry in the KDE menu and then it will work.

    Firefox, Midori, Thunderbird, in 42.3 the keyboard short cuts work fine, the function keys, in 15.0 they do not work. For example F5 to refresh web pages works in 42.3 not in 15.0

    I am using an apple aluminium keyboard with, you have guessed it, the same settings as 42.3.

    I was running KDE from the disc, in my opinion there is something not right when, again in my opinion, it is not working as it should do.

    Notice I said was as I have succumbed to the dark side of windows

  5. #5

    Default Re: Keyboard

    Quote Originally Posted by dcurtisfra View Post
    You haven't mentioned which GUI you're using: KDE, GNOME, whatever?

    Please post the output of the following CLI command executed in Terminal window: 'localectl status'.
    localectl status
    System Locale: LANG=en_GB.UTF-8
    VC Keymap: mac-uk
    X11 Layout: us

    And it is supposed to be set for UK. I have set it to UK in Settings and in YAST


    Using KDE

    I give up on W10 as the fonts were blurred and I tried to get it working. I just have to get used to leap 15 now. I am getting there

  6. #6

    Default Re: Keyboard

    Managed to get the keyboard changed to UK now, all that needs sorting out is the refresh settings for the web

  7. #7
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    4,552

    Default Re: Keyboard

    Quote Originally Posted by littletaff69 View Post
    And it is supposed to be set for UK. I have set it to UK in Settings and in YAST
    Please check the contents of:
    • "/etc/X11/xorg.conf.d/00-keyboard.conf"

    Pay particular attention the values of the following X11 options:
    "XkbLayout"
    "XkbModel"
    "XkbVariant"
    "/etc/X11/xdm/Keyboard.map" has the following values for a "mac-uk" keyboard:
    Code:
    # /.../
    # Mapping table for console -> X11 mapping
    #==================================================================================
    # CONSOLE       | MODEL | LAYOUT       | VARIANT    | KEYCODE | LA| RA| SL| RC| OPT
    #---------------|-------|--------------|------------|---------|---|---|---|---|----
    mac-uk          : macintosh : gb       : x            : xfree86 : x : x : x : x : altwin:swap_lalt_lwin,lv3:alt_switch
    • "/etc/sysconfig/keyboard"

    Pay attention to the value of "KEYTABLE" -- in '/usr/share/kbd/keymaps/xkb/' there are 2 "GB" Apple keymaps:
    * gb-mac_intl.map.gz
    * gb-mac.map.gz

    Please choose the one which applies to your Apple keyboard. Please be aware that, the value used by "KEYBOARD=" does not include the string ".map.gz" which is part of the Keyboard Map's filename.


    Please be aware that, the value of "YAST_KEYBOARD=" should use the string "pc104" despite your keyboard possibly being a 'PC-105' variant.

    Given that "localectl status" is reporting "System Locale: LANG=en_GB.UTF-8" the chance are that, the contents of "/etc/sysconfig/language" are correct but, you'll need to check the contents of that file as well.

    In your output of "localectl status", the following values have not been reported by you:
    • X11 Model:
    • X11 Variant:
    • X11 Options:

  8. #8

    Default Re: Keyboard

    sorry for the delay.

    System Locale: LANG=en_GB.UTF-8
    VC Keymap: UK
    X11 Layout: gb
    X11 Model: microsoftpro
    X11 Options: terminate:ctrl_alt_bksp


    I did have it working before but now the function keys do not work in Firefox and Thunderbird

    EDIT: The keys are in the correct place now. As I just said the function keys might as well not be there as they do not work.

  9. #9

    Default Re: Keyboard

    Now changed to:

    System Locale: LANG=en_GB.UTF-8
    VC Keymap: uk
    X11 Layout: gb
    X11 Model: pc105
    X11 Options: terminate:ctrl_alt_bksp

  10. #10

    Default Re: Keyboard

    As I may have said in the first message of this thread.


    This is a fresh install of 15.

    The order after the installation has finished.

    Configure desktop/tweaks unclick the options there
    Load dolphin add menu, settings/services click on delete. Delete the 2 icons on the desktop
    KDE menu click on system settings. Do a little bit of configuring. Under hardware/Input Devices/keyboard/Keyboard Model I have, Apple | Apple Aluminium (JIS)

    Next job, get the sound card working. Open a terminal and enter alsamixer and press F6 to change the sound card to Xonar DGX set the levels. I have script to autoload sound settings at boot.

    That all works under 42.3 but not in 15.0 as the function keys are not there.

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •