Page 1 of 3 123 LastLast
Results 1 to 10 of 29

Thread: .xsession-errors-:0 file very large

  1. #1

    Default .xsession-errors-:0 file very large

    This is regarding Machine #1 which has been recently updated to Leap 42.3.

    I keep getting a msg that states my HOME file is very full. When I run df -h in terminal it show home as being 99% used.
    Home is 50GB in size and I do not store any large files [[i.e.] - videos or movies] in it.
    I looked through the Home folder and discovered a file called ".xsession-errors-:0" and it is 45.1 GB in size.
    When I try to open the file by double clicking I get this msg "KDEInit could not launch '/usr/bin/kate'", so i went thru System>File Manager - Super User mode and the file opened , but did not show anything.
    The properties of this file show 0 B but in Dolphin it shows as 45.1 GB.
    All other files in home show reasonable sizes.
    Can I delete this file or how to disable or get rid of it.
    Thank You
    Machine # 1 - Asus Prime Z390A, i7-9700k 3.6GHz, 32.0 GB ram, openSUSE Leap 15.0 64-bit, KDE Plasma 5.12.8
    Machine # 2 - Asus P8Z77-V Deluxe, i7-3770k 3.5GHz, 16.0 GB ram, Debian 10 Buster 64-bit, LXDE

  2. #2
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: .xsession-errors-:0 file very large

    Yes, just delete it and see if the problem goes away.

    Watch for it in the future to see if it starts growing "too much, too quickly" and come back and report if it is.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: .xsession-errors-:0 file very large

    Quote Originally Posted by LaQuirrELL View Post
    Can I delete this file or how to disable or get rid of it.
    No, you can't.

    More accurately -- yes, you can delete it. But your "/home" will still be nearly full.

    How long have you been logged in?

    That file picks up the error messages that you usually don't want to know about. And it is re-created whenever you logout and then login again.

    My suggestion:

    • Logout, then login again.
    • Monitor that file for size.
    • If it is growing rapidly look at the content. The "tail" command will show the last 10 lines.
    • You probably are running some software on your desktop, that is misbehaving and filling that file.


    For comparison:
    Code:
    -rw------- 1 rickert users 52199 May 26 16:08 .xsession-errors-:0
    That's my file from 42.3. As best I recall, that was from my login on Thursday evening until I logged out on Saturday afternoon -- that's when I switched over to Leap 15.0

    Hmm, more worrying -- that file does not seem to exist in my Leap 15.0 session. I wonder where those error messages are going?
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: .xsession-errors-:0 file very large

    I should add a bit more information here.

    If you delete that file, that only removes the directory entry. The file still exists, without a directory entry. And it still takes up all of that space.

    The file will eventually disappear. It should disappear when no running program has the file open. In this case, it is opened by your login Xwindows session. So logout is what will close the file, and allow it to disappear if you have deleted it.

    For very large files like this:
    Code:
    tail filename
    will show the last 10 lines.

    And
    Code:
    less filename
    should allow you to browse through the file. But with such a large file, that might be slow.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  5. #5
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: .xsession-errors-:0 file very large

    Thanks for jumping in with better information, Neil. Appreciated.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  6. #6
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,514

    Question Re: .xsession-errors-:0 file very large

    Quote Originally Posted by nrickert View Post
    Hmm, more worrying -- that file does not seem to exist in my Leap 15.0 session. I wonder where those error messages are going?
    Is Wayland a possibility?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: .xsession-errors-:0 file very large

    Quote Originally Posted by dcurtisfra View Post
    Is Wayland a possibility?
    I'm currently running X, with KDE Plasma 5. I try Wayland from time to time, but for Plasma it is still missing some features.

    I guessing that "systemd" is somehow eating the error messages. Using "lsof", I see that file descriptor 2 (stderr) is a stream, but I don't know where the stream goes. Maybe I can find that, too, with "lsof", but I didn't try.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  8. #8

    Default Re: .xsession-errors-:0 file very large

    Quote Originally Posted by nrickert View Post
    Hmm, more worrying -- that file does not seem to exist in my Leap 15.0 session. I wonder where those error messages are going?
    I assume you are using SDDM as displaymanager? (the default on a KDE installation)

    The error messages (or rather all console output, it's not necessarily error messages only) go to ~/.local/share/sddm/xorg-session.log instead then (or ~/.local/share/sddm/xwayland-session.log if you login to a Wayland session).
    That's fully configurable by the SessionLogFile= option ("[X11]" or "[Wayland]" section respectively) in /etc/sddm.conf though.

    OTOH, Qt5 is being built with systemd-journal support since a couple of months, so all messages printed via the debug facilities of Qt5 go directly to the journal (only) now, unless you run the application in a real console.

  9. #9
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,481
    Blog Entries
    3

    Default Re: .xsession-errors-:0 file very large

    Quote Originally Posted by wolfi323 View Post
    I assume you are using SDDM as displaymanager? (the default on a KDE installation)
    I'm actually using "GDM". I don't much like GDM, but I dislike SDDM even more.

    I have Gnome installed for occasional testing. And Gnome works best with GDM.

    The error messages (or rather all console output, it's not necessarily error messages only) go to ~/.local/share/sddm/xorg-session.log instead then (or ~/.local/share/sddm/xwayland-session.log if you login to a Wayland session).
    That's fully configurable by the SessionLogFile= option ("[X11]" or "[Wayland]" section respectively) in /etc/sddm.conf though.
    The move to using ".config" and ".local" is generally a good one. But I think it's a mistake for these session error files. They need to be where they are easy to find (but also easy to ignore if you are not looking for something).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  10. #10

    Default Re: .xsession-errors-:0 file very large

    Quote Originally Posted by nrickert View Post
    I'm actually using "GDM". I don't much like GDM, but I dislike SDDM even more.
    Well, GDM redirects the whole session output (that would go into .xsession-errors normally) to systemd's journal since quite a long time already...

    The Xorg.0.log goes to .local/share/gdm/ as well I think (or somewhere similar), maybe a "copy" of .xsession-errors is there as well but I'm not sure.

    I don't use GDM myself though so I cannot check.

    The move to using ".config" and ".local" is generally a good one. But I think it's a mistake for these session error files. They need to be where they are easy to find (but also easy to ignore if you are not looking for something).
    Feel free to file a bug report (about GDM in your case), but I somehow doubt that will be changed.
    They moved to using systemd's journal for that on purpose.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •