Page 1 of 2 12 LastLast
Results 1 to 10 of 16

Thread: Slow boot dumps me at console

  1. #1
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Slow boot dumps me at console

    My LEAP 15 Desktop was update from 42.3 using zypper dup procedure.
    Nothing seemed unusual as the update proceeded.

    The boot process takes a very long time buy openSUSE standards, something fails and I am dumped to a level 3 console.
    I login as root, issue init 5 and system immediately displays a Greeter and login from there as user proceeds normally.
    Once up, system seems very responsive and all functionality tried so far is fine.

    I did pull this info after hacking about in various Forum items

    Code:
    systemd-analyze
    Startup finished in 3min 31.590s (firmware) + 41.794s (loader) + 1.129s (kernel) + 1.385s (initrd) + 3min 39.368s (userspace) = 7min 55.268s
    I have no idea where else to look for info on what is going on during boot.
    Is there a way to monitor the console during boot, i.e. un-hide it from behind the "bouncing diamond above down carot" screen?

    Sorry, not much to go on, but I am unsure what would be useful information.

    I am running from the KF5 and QT5 repos,
    Desk: Ryzen5 Leap 15.1
    Lap: HPDV7T i7 Leap 15.2

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: Slow boot dumps me at console

    Quote Originally Posted by cmcgrath5035 View Post
    Is there a way to monitor the console during boot, i.e. un-hide it from behind the "bouncing diamond above down carot" screen?
    The easiest way is to hit the ESC key as soon as you see that graphic.

    However: I had a similar problem for one of my installs. And hitting ESC did not reveal the problem.

    Another option: On the boot menu, hit the 'e' key. That gets you into an editor window to edit the boot commands.
    Scroll down until you find a line starting "linux" (or might be "linuxefi"). Perhaps hit the END key to get to the end of that line. But then back up a little. Find the string "splash=silent" and remove that string. Then continue booting (CTRL-X).

    That should give more detail. That's how I found the problem on my one system that had difficulties. (It was doing a 90 second delay waiting for a file system that was never going to show up -- essentially the same problem as in bug 1071354).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Slow boot dumps me at console

    Quote Originally Posted by nrickert View Post
    Find the string "splash=silent" and remove that string.
    ... in my case, I just change it to "splash=verbose".
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  4. #4

    Default Re: Slow boot dumps me at console

    Maybe Plymouth hangs once in a while. I added at the end of the boot line
    Code:
    plymouth.enable=0
    and booted (hit ctrl-x or F10). Result: booted in less than 10 seconds. I'll put this line into the kernel parameters of the bootloader gui of Yast2.

  5. #5
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: Slow boot dumps me at console

    Thanks for the suggestions.
    I'll give them a try
    Desk: Ryzen5 Leap 15.1
    Lap: HPDV7T i7 Leap 15.2

  6. #6
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: Slow boot dumps me at console

    Well, that was interesting.
    I went the splash=verbose route.

    The time from entering my HDD crypto password to Greeter screen was maybe 3 seconds.
    Fast enough for me.

    I guess that says my problem was a Plymouth hang, ...?
    BTW, ESC was not working, likely because it was already hung when I tried it.
    Thanks for your help
    Desk: Ryzen5 Leap 15.1
    Lap: HPDV7T i7 Leap 15.2

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,670
    Blog Entries
    3

    Default Re: Slow boot dumps me at console

    Quote Originally Posted by cmcgrath5035 View Post
    I went the splash=verbose route.
    You can make that permanent by editing "/etc/default/grub" and then regenerating the grub menu (as described at the top of "/etc/default/grub").
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Slow boot dumps me at console

    Quote Originally Posted by cookie170 View Post
    Maybe Plymouth hangs once in a while. I added at the end of the boot line
    Code:
    plymouth.enable=0
    and booted (hit ctrl-x or F10). Result: booted in less than 10 seconds. I'll put this line into the kernel parameters of the bootloader gui of Yast2.
    Plymouth can be a PIA at times. I have long since quit using it.

    Instead, on each install, I remove Plymouth entirely and taboo it.

    However, I do that less for the Plymouth problems and more for the sense of "awesome" watching the scrolling lines to see what openSUSE is doing during those seconds of boot time.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  9. #9
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    4,029

    Default Re: Slow boot dumps me at console

    Quote Originally Posted by nrickert View Post
    You can make that permanent by editing "/etc/default/grub" and then regenerating the grub menu (as described at the top of "/etc/default/grub").
    ... or by using the Yast=>Boot Loader module and changing the line in there for the kernel parameters.
    "Take a Walk on a Sunny Day, Greet everyone along the way, and Make Somebody Smile, Today"
    Gerry Jack Macks"Walk On A Sunny Day" GerryJackMacks.net

  10. #10
    Join Date
    Jun 2008
    Location
    Florida, USA
    Posts
    982

    Default Re: Slow boot dumps me at console

    Does setting splash=verbose kill Plymouth, or just modify its behavior a bit?
    Desk: Ryzen5 Leap 15.1
    Lap: HPDV7T i7 Leap 15.2

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •