Results 1 to 4 of 4

Thread: Where is libgnuradio-pmt ?

Hybrid View

  1. #1
    Join Date
    Sep 2008
    Location
    France
    Posts
    22

    Default Where is libgnuradio-pmt ?

    Hello,

    From https://download.opensuse.org/reposi...p_42.3/x86_64/ I downloaded the following RPMs

    gr-osmosdr-0.1.4+git.20170611-10.7.x86_64.rpm
    python-gr-osmosdr-0.1.4+git.20170611-10.7.x86_64.rpm
    libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64.rpm
    gnuradio-3.7.12.0-22.13.x86_64.rpm

    then I do
    zypper in gr-osmosdr-0.1.4+git.20170611-10.7.x86_64.rpm python-gr-osmosdr-0.1.4+git.20170611-10.7.x86_64.rpm libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64.rpm gnuradio-3.7.12.0-22.13.x86_64.rpm libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64.rpm


    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    3 Problems:
    Problem: nothing provides libgnuradio-pmt-3.7.12.0.so.0.0.0()(64bit) needed by libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64
    Problem: nothing provides libgnuradio-pmt-3.7.12.0.so.0.0.0()(64bit) needed by python-gr-osmosdr-0.1.4+git.20170611-10.7.x86_64
    Problem: nothing provides libgnuradio-pmt-3.7.12.0.so.0.0.0()(64bit) needed by python-gr-osmosdr-0.1.4+git.20170611-10.7.x86_64

    Problem: nothing provides libgnuradio-pmt-3.7.12.0.so.0.0.0()(64bit) needed by libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64
    Solution 1: do not install libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64
    Solution 2: break libgnuradio-osmosdr-0_1_5git0_0_0-0.1.4+git.20170611-10.7.x86_64 by ignoring some of its dependencies


    Where can I find libgnuradio-pmt ?

    Best regards

  2. #2

    Default Re: Where is libgnuradio-pmt ?

    From that same site download libgnuradio-3_7_12-0_0_0-3.7.12.0-22.13.x86_64.rpm

    Perform:

    Code:
    d3vnull@kvm:~/Downloads> rpm -qlp libgnuradio-3_7_12-0_0_0-3.7.12.0-22.13.x86_64.rpm |grep libgnuradio-pmt-3.7.12.0.so.0.0.0
    warning: libgnuradio-3_7_12-0_0_0-3.7.12.0-22.13.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID ec77fd83: NOKEY
    /usr/lib64/libgnuradio-pmt-3.7.12.0.so.0.0.0
    d3vnull@kvm:~/Downloads>
    Leap 42.3 by default:

    Code:
    kvm:~ # zypper search --provides libgnuradio
    Loading repository data...
    Reading installed packages...
    
    S  | Name                     | Summary                 | Type   
    ---+--------------------------+-------------------------+--------
       | libgnuradio-3_7_10-0_0_0 | Libraries for GNU Radio | package
    i+ | openSUSE-release         | openSUSE Leap 42.3      | package
    kvm:~ #
    I don’t have anything to hide, but I don’t have anything I want to show you either.

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Where is libgnuradio-pmt ?

    you should have added the repository and installed gnuradio with zypper not rpm
    as there is an older version provided in the OSS repo I guess you want the latest
    there are 2 community repo's providing gnuradio the hamradio and hardware:sdr repo's unless you have a good reason I'd avoid user repo's
    try (for hardware:sdr repo)
    Code:
    zypper ar -f http://download.opensuse.org/repositories/hardware:/sdr/openSUSE_Leap_42.3/hardware:sdr.repo
    zypper in gnuradio
    the above will download the latest version of gnuradio if it's not installed if you already have an earlier version installed you need to use the version tab from yast or the --from switch with zypper or use the version number in the zypper in (zypper in gnuradio-3.7.12.0)
    no need to download separate packages and hustle with rpm dependencies

  4. #4
    Join Date
    Sep 2008
    Location
    France
    Posts
    22

    Default Re: Where is libgnuradio-pmt ?

    Hello,


    Thanks for the feedback. I tried your suggestions and all is OK
    Thanks again.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •