Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Left-hand Mouse Setting

  1. #1

    Thumbs down Left-hand Mouse Setting

    My SSD drive died exactly the day the Leap 15 was release. (What are the odds?) So, I installed a new SSD and downloaded and installed the ISO for Leap 15. No problems at all until I used Leap 15 to swap my mouse buttons to Left-Handed. It swapped about half of the buttons/action to left-handed, but left the other half right handed. So, I'm never sure what button to push for any action. (No, I have mapped it yet.) It's too frustrating to use. I never know what button to push. I don't see any forum messages that anyone else is having the same problem, so I'm not sure anyone will be looking into it. That pretty much leaves me with finding a real left-handed mouse - which isn't easy.

    Anyone else having this problem? Any idea of a temporary or long-term fix for it?

    Thanks,
    Clyde

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Left-hand Mouse Setting

    Which desktop environment? I've only ever owned basic mice and although I'm left-handed I only use them right-handed, but I've never had a problem with the KDE utility for switching (testing purposes only). If you have an 'exotic' mouse, probably only button mapping is going to help here.

    This thread might be helpful to you....
    https://forums.opensuse.org/showthre...-mouse-buttons
    Last edited by deano_ferrari; 27-May-2018 at 18:40.
    openSUSE Leap 15.3; KDE Plasma 5

  3. #3

    Default Re: Left-hand Mouse Setting

    My left-handed mouse worked fine until Leap 15. I have a right-handed mouse for my wife's login and a left-handed mouse configuration for my login. No problems until Leap 15. Absolutely nothing "exotic" about our ROCCAT Kova (setup as left-handed) or the Logitech (setup as right-handed). I have no idea what changed moving up to 15, but it's broken.

  4. #4
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Left-hand Mouse Setting

    Again, which desktop?
    openSUSE Leap 15.3; KDE Plasma 5

  5. #5
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Left-hand Mouse Setting

    What does the following report about your mouse configuration?
    Code:
    libinput list-devices
    openSUSE Leap 15.3; KDE Plasma 5

  6. #6

    Default Re: Left-hand Mouse Setting

    What does the following report about your mouse configuration?
    libinput list-devices

    Device: ROCCAT ROCCAT Kova
    Kernel: /dev/input/event4
    Group: 5
    Seat: seat0, default
    Capabilities: keyboard pointer
    Tap-to-click: n/a
    Tap-and-drag: n/a
    Tap drag lock: n/a
    Left-handed: disabled
    Nat.scrolling: disabled
    Middle emulation: disabled
    Calibration: n/a
    Scroll methods: button
    Click methods: none
    Disable-w-typing: n/a
    Accel profiles: flat *adaptive
    Rotation: n/a

    Device: ROCCAT ROCCAT Kova
    Kernel: /dev/input/event5
    Group: 5
    Seat: seat0, default
    Capabilities: keyboard
    Tap-to-click: n/a
    Tap-and-drag: n/a
    Tap drag lock: n/a
    Left-handed: n/a
    Nat.scrolling: n/a
    Middle emulation: n/a
    Calibration: n/a
    Scroll methods: none
    Click methods: none
    Disable-w-typing: n/a
    Accel profiles: n/a
    Rotation: n/a

    Device: Logitech USB Gaming Mouse
    Kernel: /dev/input/event18
    Group: 6
    Seat: seat0, default
    Capabilities: pointer
    Tap-to-click: n/a
    Tap-and-drag: n/a
    Tap drag lock: n/a
    Left-handed: disabled
    Nat.scrolling: disabled
    Middle emulation: disabled
    Calibration: n/a
    Scroll methods: button
    Click methods: none
    Disable-w-typing: n/a
    Accel profiles: flat *adaptive
    Rotation: n/a


    The ROCCAT Kova is the one I'm trying to switch the keys to make left handed. It worked before on previous versions of Leap.

    Thanks,
    Clyde


  7. #7
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Left-hand Mouse Setting

    Try setting the mouse to left-handed operation with xinput like this....
    Code:
    xinput set-prop "ROCCAT ROCCAT Kova" "libinput Left Handed Enabled" 1
    Does that do the trick?

    ....and please as already requested tell us which desktop environment you are using!
    openSUSE Leap 15.3; KDE Plasma 5

  8. #8

    Default Re: Left-hand Mouse Setting

    Leap 15 KDE Plasma (Wayland)

  9. #9

    Default Re: Left-hand Mouse Setting

    Result:

    unable to find device ROCCAT ROCCAT Kova



  10. #10
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Left-hand Mouse Setting

    Quote Originally Posted by Lugh1 View Post
    Leap 15 KDE Plasma (Wayland)
    The use of Wayland is probably the cause of the issue here. Wayland is still work in progress, and you may need to switch back to Xorg ( perhaps.

    Wayland experience installed by default. It will just be a matter of selecting “Plasma (Wayland)” in the session list of the display manager before logging in.
    https://news.opensuse.org/2018/02/08...yland-to-leap/

    It can also be changed using 'update-alternatives' as explained in the release notes
    https://doc.opensuse.org/release-not...anager-session
    openSUSE Leap 15.3; KDE Plasma 5

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •