Page 5 of 5 FirstFirst ... 345
Results 41 to 42 of 42

Thread: Brother printer driver installs but can't print

  1. #41
    Join Date
    Jan 2014
    Location
    Erlangen
    Posts
    528

    Default Re: Brother printer driver installs but can't print

    Quote Originally Posted by jwhitmor View Post
    Thanks here also! I think this is odd, because I have run OpenSuse (Leap 42.2 / 42.3) for several years, and the Brother printer installer worked as provided. I always installed the X86_64 biit version. Now I use Tumbleweed, because I had an issue with Leap 15.0, I could not solve (video display tearing).
    I also will ask Brother to provide an installation advisory, because the more they hear it, the more likely they will respond. Brother should know by now that the reason many people buy Brother printers, is their support for Linux O.S. I think that is lost on Brother USA, but the parent company in Nagoya, Japan seems to understand.
    By the way I own a Brother MFC 255-CW. I added their packages to a local repository. Install is done by zypper and reliably works on any openSUSE without further tinkering (the i386 packages are running on x86_64 too):

    Code:
    erlangen:~ # zypper if brother-udev-rule-type1 mfc255cwcupswrapper mfc255cwlpr
    Loading repository data...
    Reading installed packages...
    
    
    Information for package brother-udev-rule-type1:
    ------------------------------------------------
    Repository     : myrepo                             
    Name           : brother-udev-rule-type1            
    Version        : 1.0.0-1                            
    Arch           : noarch                             
    Vendor         : Brother Industries, Ltd.           
    Installed Size : 2.1 KiB                            
    Installed      : Yes                                
    Status         : up-to-date                         
    Source package : brother-udev-rule-type1-1.0.0-1.src
    Summary        : Brother udev rule type 1           
    Description    :                                    
        udev rule for brother scanner type1
    
    
    Information for package mfc255cwcupswrapper:
    --------------------------------------------
    Repository     : myrepo                                 
    Name           : mfc255cwcupswrapper                    
    Version        : 1.1.3-1                                
    Arch           : i386                                   
    Vendor         : Brother Industries, Ltd.               
    Installed Size : 47.1 KiB                               
    Installed      : Yes                                    
    Status         : up-to-date                             
    Source package : mfc255cwcupswrapper-1.1.3-1.src        
    Summary        : Brother CUPS Inkjet Printer Definitions
    Description    :                                        
        Brother Inkjet printer CUPS Driver
    
    
    Information for package mfc255cwlpr:
    ------------------------------------
    Repository     : myrepo                                
    Name           : mfc255cwlpr                           
    Version        : 1.1.3-1                               
    Arch           : i386                                  
    Vendor         : Brother Industries, Ltd.              
    Installed Size : 3.1 MiB                               
    Installed      : Yes (automatically)                   
    Status         : up-to-date                            
    Source package : mfc255cwlpr-1.1.3-1.src               
    Summary        : Brother lpr Inkjet Printer Definitions
    Description    :                                       
        Brother inkjet printer Driver
    
    erlangen:~ #
    AMD Athlon 4850e (2009), openSUSE 13.1, KDE 4, Intel i3-4130 (2014), i7-6700K (2016), i5-8250U (2018), openSUSE Tumbleweed, KDE Plasma 5

  2. #42

    Default Troubleshoot works for DCP-J562DW also.

    Quote Originally Posted by deano_ferrari View Post
    Strange. Do you have glibc-32bit installed? FWIW, on my fully updated Leap 15 install glibc-32bit-2.26-lp150.10.13.x86_64, so perhaps you need to check the version installed.
    Thank you very much for this, indeed!

    After upgrading to Leap 15 my very device, the printer/scanner Brother DCP-J562DW I was facing the same problem with both printing and scanning:

    1. Confirmation: Installing glibc-32bit resolved the printing problem.

    2. New Information: Installing sane-backends-32bit in my case solved the scanning problem (I tried this very naively as an analogue to your native advice).

    Thanks, have a good week's start
    Christian

Page 5 of 5 FirstFirst ... 345

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •