Page 2 of 3 FirstFirst 123 LastLast
Results 11 to 20 of 29

Thread: 2 possible problems: DNS resolution and "Networking disabled"

  1. #11

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Fixed!!! I edited /etc/resolv.conf to add the following line

    Code:
    nameserver XXX.XXX.X.X
    where XXX.XXX.X.X represent the router IP (the address you use to enter its configuration). Reboot and that's it!

  2. #12

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by RGBsuse View Post
    Fixed!!! I edited /etc/resolv.conf to add the following line

    Code:
    nameserver XXX.XXX.X.X
    where XXX.XXX.X.X represent the router IP (the address you use to enter its configuration). Reboot and that's it!
    Better delete the file and reboot, or run "netconfig -f update", and it should get re-created correctly.
    If you modify it manually, it won't ever be updated by the system again.

    Btw, this is likely http://bugzilla.opensuse.org/show_bug.cgi?id=1092352, NetworkManager seems to overwrite /etc/resolv.conf with a broken one under certain circumstances (not only when upgrading from 42.3 to 15.0!).
    The exact reasons have not been found yet though, and it also seems to be not easily reprodicable.

  3. #13
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,309

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by RGBsuse View Post
    Fixed!!! I edited /etc/resolv.conf to add the following line

    Code:
    nameserver XXX.XXX.X.X
    where XXX.XXX.X.X represent the router IP (the address you use to enter its configuration). Reboot and that's it!
    IMHO it's better to edit "/etc/sysconfig/network/config":
    Code:
    ## Type:        string
    ## Default:     ""
    #
    # List of DNS domain names used for host-name lookup.
    # It is written as search list into the /etc/resolv.conf file.
    #
    NETCONFIG_DNS_STATIC_SEARCHLIST=" «The domain name of your LAN/WLAN supplied by your DNS server box» "
    Then, at boot time, with DHCP, "/etc/resolv.conf" will be auto-magically written with the appropriate IPv6 and IPv4 addresses for the Name Server.

    Alternatively, you can use the following "/etc/sysconfig/network/config" value:
    Code:
    ## Type:        string
    ## Default:     ""
    #
    # List of DNS nameserver IP addresses to use for host-name lookup.
    # When the NETCONFIG_DNS_FORWARDER variable is set to "resolver",
    # the name servers are written directly to /etc/resolv.conf.
    # Otherwise, the nameserver are written into a forwarder specific
    # configuration file and the /etc/resolv.conf does not contain any
    # nameservers causing the glibc to use the name server on the local
    # machine (the forwarder). See also netconfig(8) manual page.
    #
    NETCONFIG_DNS_STATIC_SERVERS=""

  4. #14
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    10,425
    Blog Entries
    1

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by 2009Newbie View Post
    Thanks to all of you who kindly took some time to post postings in this “thread” of postings. I found that my computer software was set to use the so-called “wicked” method via YaST Contol Center, System, Network Settings, under Network Setup Method on the Global Options tab. Accordingly in https://bugzilla.opensuse.org/show_bug.cgi?id=1080832 I saw that Nimroy Das suggested making a file /etc/wicked/local.xml with the contents

    Code:
    <config>
       <addrconf>
           <dhcp4>
              <create-cid>rfc2132</create-cid>
           </dhcp4>
       </addrconf>
    </config>
    on the hunch that the DHCP server didn’t “like” rfc4361 client-id. Neil Rickert followed that advice and had good results after entering “systemctrl restart wickedd” or else “systemctrl restart wicked” and “rebooting” into openSUSE Tumbleweed. The version of openSUSE there on February 2, 2018 was reported as “Current.” Perhaps “Current” meant the currently tested version of openSUSE Tumbleweed, so maybe version 15.0 on February 2, 2018.

    Given Neil Rickert’s reported success, I did what he did, namely making local.xml, entering both “systemctrl restart wickedd” and “systemctrl restart wicked”, and then rebooting into Leap 15.0. I entered the command “ip a” and obtained the following results (But later “systemctrl” was not “recognized” in my installation of Leap 15.):

    newbie@linux-hdi0:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
    link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
    inet 127.0.0.1/8 scope host lo
    valid_lft forever preferred_lft forever
    inet6 ::1/128 scope host
    valid_lft forever preferred_lft forever
    2: eth1: <BROADCAST,MULTICAST> mtu 1500 qdisc noop state DOWN group default qlen 1000
    link/ether 08:00:27:24:85:7d brd ff:ff:ff:ff:ff:ff
    newbie@linux-hdi0:~>

    I still saw “Networking disabled” in a context-sensitive menu when my computer’s touchpad arrow was placed over an icon looking like two computer monitors on the lower-right side of my Leap-15 computer screen. I compared the above output with the first example output under “Show IP Addresses” on https://www.rootusers.com/11-ip-comm...les-for-linux/. Afterward I decided that for the Internet connection eth1 no Internet Protocol (IP) version-4 (IPv4) or version-6 address had been assigned to it! And I wonder if the word “DOWN” could mean that eth1 was not active at the time the above output was produced.

    Below are my results for some experiments with the command “nslookup”.

    newbie@linux-hdi0:~> nslookup
    > server 8.8.8.8
    Default server: 8.8.8.8
    Address: 8.8.8.8#53
    > server 64.4.11.37
    Default server: 64.4.11.37
    Address: 64.4.11.37#53
    > exit

    newbie@linux-hdi0:~>

    The IP address 64.4.11.37 is one of the IP addresses for microsoft.com. These nslookup results look good to me.

    On the other hand,

    newbie@linux-hdi0:~> nslookup
    > server www.google.com
    nslookup: couldn't get address for 'www.google.com': not found
    newbie@linux-hdi0:~> nslookup www.google.com
    ;; connection timed out; no servers could be reached

    newbie@linux-hdi0:~>
    .
    So a summary of today’s results in my installation of Leap 15.0 is that

    1) a Web site appears to be reachable via its IP address, but not via its Uniform Resource Locator (URL), for example, www.google.com.

    2) While online my so-called "ethernet" connection eth1 in Leap 15.0 has no IP address within VirtualBox.

    3) In Leap 15.0 I continued to see “Networking disabled.”

    Consider me ignorant concerning the details of the relevant computer software. What should I do or try next?

    Further question: If I see “RESOLVED FIXED” on the top of a https://bugzilla.opensuse.org/ posting for openSUSE Tumbleweed or Leap, is it safe for me to assume that that matter has been fixed in the next or current release of openSUSE Leap so that I can ignore such a bugzilla posting?
    Although you posted later (after this post) that you were able to resolve your problem, I consider your fix temporary and your fix itself could turn out to be problematic.

    So, a quick rundown of what is in <this> post...

    If your system was set up to be a DHCP client,
    Your machine wasn't assigned a working IPv4 address... And that needs to be looked into.
    That you say you were able to run nslookup and ping remote Internet IP addresses using IPv4 addresses is curious... I would have thought that you'd only have IPv6 working.
    So, there is something odd happening at your Internet router besides its iPv4 DHCP service.

    And,
    It follows that your temporary fix to edit /etc/resolv.conf is again because of your DHCP issue... If you didn't obtain a DHCP IP address, then it also stands to reason that you didn't get your DNS Server configuration for the same reason.

    So,
    Figure out what is happening with DHCP on your network and you'll probably solve your problem properly and permanently without causing other problems you'll likely see with your current fix.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #15

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by dcurtisfra View Post
    IMHO it's better to edit "/etc/sysconfig/network/config":
    This won't help in the case that NetworkManager overwrote /etc/resolv.conf with a broken one without nameservers.
    That's unrelated to the config.

    And most users probably get the nameserver automatically via DHCP anyway, so no need to add one in /etc/sysconfig/network/config.

    Then, at boot time, with DHCP, "/etc/resolv.conf" will be auto-magically written with the appropriate IPv6 and IPv4 addresses for the Name Server.
    This will happen anyway (without changing /etc/sysconfig/network/config), but only if /etc/resolv.conf has not been modified manually.

    You should only have to modify
    /etc/sysconfig/network/config the way you wrote if you want to add an *additional*, static nameserver not provided by DHCP.

  6. #16
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,309

    Cool Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by wolfi323 View Post

    You should only have to modify
    /etc/sysconfig/network/config the way you wrote if you want to add an *additional*, static nameserver not provided by DHCP.
    True for everyone who doesn't have an AVM Fritz!Box as their DSL Router and DHCP server and DNS (cache) server (or, a DSL Router which does similar things … ).
    • If you have an AVM Fritz!Box DSL Router and, you've taken the default configuration that the Fritz!Box is your DHCP server and your DNS cache server, then:
    • For an acceptable DNS performance set the "/etc/sysconfig/network/config" token 'NETCONFIG_DNS_STATIC_SEARCHLIST' to the value of the domain name that an AVM Fritz!Box uses for your LAN and WLAN: "fritz.box" -- yes, really, AVM (a company in Berlin) have reserved the domain "fritz.box" within the ".box" TLD and, they've taken steps to ensure that, everything works as expected …

  7. #17

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by dcurtisfra View Post
    True for everyone who doesn't have an AVM Fritz!Box as their DSL Router and DHCP server and DNS (cache) server (or, a DSL Router which does similar things … ).
    And why do you assume RGBsuse has such a router, or present this as definitive thing to do?

    Actually he wrote that it worked *before* the upgrade, so manually adding DNS servers should not be necessary at all.

    Ok, his problem is probably different to the original one discussed here though, but I don't really see your comments related to this thread or his problem either.

    Again, there currently is a bug in NetworkManager that can make it overwrite /etc/resolv.conf with a broken one. Not really specific to Leap 15.0, but apparently more likely to happen if you upgrade to it using "zypper dup".
    The proper fix is to delete /etc/resolv.conf or run "sudo netconfig -f update" to let the system regenerate it correctly.

  8. #18
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,309

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by wolfi323 View Post
    And why do you assume RGBsuse has such a router, or present this as definitive thing to do?
    Because, my experience is, given a DSL Router with DHCP and DNS services which drops a "private" '.box' domain name onto the private LAN and WLAN, the current openSUSE network setup method gives more reliable and faster DNS results and, faster boot times, if the static search list is used to search for Name Servers within that domain.

    Please be aware that, AVM Fritz!Boxes suffered more than a few DNS issues when the '.box' TLD was made public but, those issues have now been addressed by AVM and, the additional setting with the static search list ensures that, the openSUSE boxes do not inadvertently pick up a DNS service which is not that supplied by the DSL Router …

  9. #19

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    Quote Originally Posted by dcurtisfra View Post
    Because, my experience is, given a DSL Router with DHCP and DNS services which drops a "private" '.box' domain name onto the private LAN and WLAN, the current openSUSE network setup method gives more reliable and faster DNS results and, faster boot times, if the static search list is used to search for Name Servers within that domain.
    That may well be (I don't know as I never had such a "problematic" device), but you proposed it to RGBsuse as the proper thing to do without mentioning any reasons or further explanations, and also without any indication that it would actually apply to his problem (which it likely doesn't IMHO).

    Anyway, things should be clearer now. (and continuing this "discussion" won't add anything... )

  10. #20

    Default Re: 2 possible problems: DNS resolution and "Networking disabled"

    I’m sorry. Earlier in this “thread” of postings I misspelling Nirmoy Das’s name as Nimroy Das.

    Gratefully May 28, 2018 was a better day than previous days for me to access Web sites through Leap 15.0 through Oracle Virtual Machine (VM) VirtualBox! (Hereafter in this posting I call this VirtualBox.) In short, one of my difficulties was likely caused by my experimenting on May 26, 2018 trying to gain such Web-site access, one day after I upgraded Leap 42.3 to Leap 15.0. That May 26th date was the date I found that a file with a name containing eth1 had been modified; eth0 had been produced in the year 2016 in an earlier version of openSUSE installed on my computer. I guess software problems may have occurred when I within YaST2’s (Yet another Setup Tool 2’s) System, Network Settings tried a simple replacement of Network Manager Service for the so-called Wicked Service as the “Network Setup Method,” and then returned to the Wicked Service. Compared to my May 27, 2018 failure, May 28, 2018’s success was at least in part due to configuring the Intel PRO MT/1000 MT, 82540EM virtual network “card” provided by VirtualBox 5.2.12r122591, which recently was not configured in my Leap-15.0 installation, possibly the renaming of my “ethernet” connection eth1 to eth0, and possibly due to my making local.xml, which I discussed earlier in this “thread” of postings.

    In recent years in openSUSE I have mostly been using the Lightweight X Windows System, version 11 (X11), Desktop Environment (LXDE). So my report here applies mostly to the LXDE.

    Something I did on May 26, 2018 may have caused my “ethernet” connection “eth0” to be renamed as “eth1.” To reverse that process, following the advice of “clrg” on http://ubuntuforums.org/showthread.php?t=1548254, as a “root” user, after making a backup of the file /etc/udev/rules.d/70-persistent-net.rules, within the original version of that file I changed “eth1” to “eth0”, saved that file, and then entered “init 6.”---From https://serverfault.com/questions/51...at-rhel-centos I understood that the command “init 6” is designed to execute K* scripts and then to “reboot” a Linux operating system.

    I began the process of configuring VirtualBox’s 82540EM virtual newtork “card” within YaST2 by clicking on the icon on the left-hand side of the LXDE taskbar, selecting “System, LXDE Control Center, YaST Control Center,” inputting my “root”-user password, selecting “System, Network Settings,” and, on the ensuing “Overview” tab with “82540EM Gigabit Ethernet Controller” selected and indicated as “Not configured,” clicking on “Edit.” I clicked on the “radio” button to the left of “Dynamic Address” to have a black disc placed within that “radio” button, selected “DHCP,” accepted “DHCP both version 4 and 6,” and clicked on “Next.” Afterward near the bottom of that “Overview” tab under “Name” I could see “82540 Gigabit Ethernet Controller” for the “Name,” “DHCP” for the “IP Address”, and “eth0” for the “Device”. And below “82540 Gigabit Ethernet Controller (Not connected)” I could see its MAC (Media Access Control) address in my installation of VirtualBox, its BusID, and

    • Device Name: eth0
    • Started automatically on cable connection
    • IP address assigned using DHCP

    .
    I clicked on “Add” and then “Cancel,” with no net effect due to those two clickings, and then clicked on “OK.” “Networking disabled” was still shown in the context-sensitive menu when I placed my computer’s touchpad arrow over the symbols of two computer monitors on the right-hand side of the LXDE taskbar. I shut down Leap 15.0 and VirtualBox and then restarted VirtualBox with my host, 64-bit Windows 10 Home Edition operating system connected to the Internet. In VirtualBox’s “Settings, Network,” and on the “Adapter 1” tab, clicking on the downward-pointing arrow beside “Advanced” displayed a check mark in the checkbox beside “Cable Connected.” With my openSUSE Virtual Machine (VM) highlighted in the left-hand pane of VirtualBox’s main window I clicked on “Start” near the top of that window.

    I logged into the LXDE in Leap 15.0. Still “Networking disabled” was shown in the context-sensitive menu for the two-monitor icon on the taskbar. But, similar to what is shown below, gratefully this time the command “ip a” gave a much better result than previously!

    Code:
    newbie@linux-hdi0:~> ip a
    1: lo: <LOOPBACK,UP,LOWER_UP> mtu 65536 qdisc noqueue state UNKNOWN group default qlen 1000
        link/loopback 00:00:00:00:00:00 brd 00:00:00:00:00:00
        inet 127.0.0.1/8 scope host lo
           valid_lft forever preferred_lft forever
        inet6 ::1/128 scope host 
           valid_lft forever preferred_lft forever
    2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc pfifo_fast state UP group default qlen 1000
        link/ether 08:00:27:24:85:7d brd ff:ff:ff:ff:ff:ff
        inet 10.0.2.15/24 brd 10.0.2.255 scope global eth0
           valid_lft forever preferred_lft forever
        inet6 fe80::a00:27ff:fe24:857d/64 scope link 
           valid_lft forever preferred_lft forever
    newbie@linux-hdi0:~>
    And, similar to what is shown below, the command host 8.8.8.8 gratefully gave me a better result than a similar command previously did!

    Code:
    newbie@linux-hdi0:~> host 8.8.8.8
    8.8.8.8.in-addr.arpa domain name pointer google-public-dns-a.google.com.
    newbie@linux-hdi0:~>
    But the results at first seemed to me not so good for the two microsoft.com Uniform Resource Locators (URLs) shown below:

    Code:
    newbie@linux-hdi0:~> host 64.4.11.37
    Host 37.11.4.64.in-addr.arpa. not found: 3(NXDOMAIN)
    newbie@linux-hdi0:~> 
    
    newbie@linux-hdi0:~> host 65.55.58.201
    Host 201.58.55.65.in-addr.arpa. not found: 3(NXDOMAIN)
    newbie@linux-hdi0:~>
    I wonder if this could be because google.com is set up for the host command from a “visitor,” but the above Microsoft Corporation Web sites with the Internet Protocol (IP) addresses 64.4.11.37 and 65.55.58.201 are not set up for host commands from “visitors.”

    Gratefully I could afterward have openSUSE’s home page displayed in a Mozilla Firefox Web browser in Leap 15.0! And finally I could obtain updates for Leap-15.0 software packages within YaST2!
    I noticed that a second icon looking like two computer monitors had appeared on the taskbar in the LXDE. Placing my computer’s touchpad arrow over that icon resulted in showing the numbers of bytes and packets received through my network connection eth0. The other taskbar icon looking like a pair of computer monitors still showed “Networking disabled.” Speculation: I wonder if that could be in effect “telling” me that the Network Manager Service was disabled because I was using the so-called Wicked Service as the Network Setup Method within Leap 15.0. In any case, with the other successes in accessing the Internet this result seemed ignorable.

    As another possible factor in my above successes, on my part there is considerable mystery concerning my inclusion of the file /etc/wicked/local.xml that I discussed earlier in this “thread” of postings. Again, as suggested by Nirmoy Das, Neil Rickert had success with that inclusion in obtaining IP, version-4 addresses (https://bugzilla.opensuse.org/show_bug.cgi?id=1080832). According to Nirmoy Das there that file’s purpose was apparently to substitute the use of a file named rfc2132 for the file named rfc4361, in case there was difficulty with rfc4361 using the so-called Wicked Service (instead of the Network Manager Service) in Leap 15.0. From the Internet I learned that in the context of computer software rfc can stand for either Request For Comments or Remote Function Call. So which of those definitions applies in this situation is one question of mine. Secondly, prior to my configuration of the 82540EM Gigabit Ethernet Controller on May 28, 2018 I did not find either “rfc2132” or “rfc4361” included in any active statement in either of my files dhclient-eth0.conf or dhclient-eth1.conf, both of which were in the directory /var/lib/NetworkManager; instead each of those files included active mentions of “rfc3442” and “rfc4833”. Also I did not find either of the files rfc2132 or rfc4361 on https://www.kernel.org/doc/rfc-linux.html. Aside from requesting help in explaining these mysteries, I am, at least for now, leaving /etc/wicked/local.xml in my Leap-15.0 installation, a file which has been considered a “workaround solution.” If Leap-15.0 code writers find what they consider a more preferred solution for https://bugzilla.opensuse.org/show_bug.cgi?id=1080832, kindly please inform me of it in this “thread” of postings.

    After being able to obtain updates or else new, compared to Leap 42.3, software packages in Leap 15.0, at first I had 14 of such updates downloaded and installed via YaST2, “Online Update”, and some Leap-15.0 online repositories. During the installations of those software packages, and after being notified I to the effect, I agreed to the replacement of some files with other files of the same names. Those files and the paths, maybe of the older files, were:

    /usr/share/terminfo/s/screen.linux,
    /usr/share/terminfo/s/screen.konsole,
    /usr/share/terminfo/s/screen.gnome, and
    /usr/share/doc/packages/kernel-syms/README.SUSE, which was replaced about 12 times.

    Later I had numerous other updates and/or software packages installed in my installation of Leap 15.0.

    I don’t have Internet access in my home. But I discovered a way to have numerous “texlive” software packages, or software packages needed by texlive, installed while offline that had been previously downloaded from Leap-15.0 repositories while online. In YaST2’s “Software Management” I suppose that a pair of blue-colored version numbers, with one of those version numbers between parentheses and one of them not between parentheses, might indicate that the installation file for the version surrounded by parentheses had been downloaded, but had yet to be executed to replace the then-installed version with the newer version of the relevant software package. The beginning of that process was to enter YaST2’s “Software Management”, and while offline to click on “Skip autorefresh,” or something similar to that, to enter “texlive” in the “Search” edit control, and afterward to click on the “Search” software “button.” After that I could click on the “Package” menu item, select “All in This list,” and then “Update if newer version available.” In this way while offline I could have 460 software packages related to TeX Live installed and 1,759 updates installed, the installation files for all of which had been previously downloaded from openSUSE repositories. I guess that the majority of TeX Live may not be included in an .iso (International Standards Organization) file for the installation of openSUSE in order to keep the total size of the files finalized on an openSUSE-installation Digital Video Disc (DVD) within the size 4.7-gigabyte size of a single-layer, Recordable DVD, or DVD-R.

    Another conceivable way to have a large number of TeX Live software packages installed while offline could be to have them dowloaded as a group from http://tug.org/texlive/acquire-netinstall.html or else within https://ctan.org/; to produce from them a TeX Live, installation DVD-R; and then while offline to install them in openSUSE using that DVD-R. I have not tried that process for a large number of TeX Live software packages. It also might be more complicated than obtaining and installing TeX Live software packages from openSUSE repositories. I thank Neil Rickert and all of you who kindly took some of your time to post some comments within this "thread" of postings.

Page 2 of 3 FirstFirst 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •