Results 1 to 10 of 10

Thread: Leap 15: Samba will not start

  1. #1

    Default Leap 15: Samba will not start

    After my upgrade to Leap 15, samba will not start.
    Code:
    May 26 14:02:52 jardell systemd[1]: Starting Samba SMB Daemon...-- Subject: Unit smb.service has begun start-up
    -- Defined-By: systemd
    -- Support: https://lists.freedesktop.org/mailman/listinfo/systemd-devel
    --
    -- Unit smb.service has begun starting up.
    May 26 14:02:52 jardell systemd[1]: smb.service: Main process exited, code=exited, status=1/FAILURE
    May 26 14:02:52 jardell systemd[1]: Failed to start Samba SMB Daemon.
    -- Subject: Unit smb.service has failed
    How do I figure out what is wrong?

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Leap 15: Samba will not start

    Samba service is working here.

    I realize that doesn't help you. But it indicates that it can work for some people in Leap 15.0
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: Leap 15: Samba will not start

    Did you do an upgrade? Did you have to do anything special?
    Thanks,
    Jim

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: Leap 15: Samba will not start

    This was a clean install.

    I did copy some of the samba configuration from 42.3.

    I also turned off the firewall, but not because of Samba (because of NFS).
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: Leap 15: Samba will not start

    It might be an issue with apparmor https://www.dropbox.com/s/kxk5yb6mx7...artup.png?dl=0
    Trying from the services manager gives more information.
    I also cannot start my squeezeboxserver.

  6. #6

    Default Re: Leap 15: Samba will not start

    I uninstalled smb using the Yast Software Manager, which also uninstalled a zillion (176!!) other things. Then I reinstalled it, and it starts.

  7. #7
    Join Date
    Jun 2008
    Location
    Düsseldorf/Germany
    Posts
    283

    Default Re: Leap 15: Samba will not start

    Actually I noticed the same issue after upgrade from 42.3 to 15.
    See: https://bugzilla.opensuse.org/show_bug.cgi?id=1094881
    No solution yet (except restarting smb manually)

  8. #8

    Default Re: Leap 15: Samba will not start

    In my case, it works.
    But Dolphin refuses to show the workgroup ...
    While you can navigate the samba network, by inserting the IP address or the name of the computers ...

  9. #9
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    23,710
    Blog Entries
    1

    Default Re: Leap 15: Samba will not start

    Quote Originally Posted by PiElle View Post
    In my case, it works.
    But Dolphin refuses to show the workgroup ...
    While you can navigate the samba network, by inserting the IP address or the name of the computers ...
    Firewall perhaps?
    openSUSE Leap 15.3; KDE Plasma 5

  10. #10

    Default Re: Leap 15: Samba will not start

    Quote Originally Posted by DocB View Post
    Actually I noticed the same issue after upgrade from 42.3 to 15.
    See: https://bugzilla.opensuse.org/show_bug.cgi?id=1094881
    No solution yet (except restarting smb manually)
    For anybody else experiencing this problem, the quick fix in Comment 2 of the above bug report did resolve the issue for me.

    YMMV, naturally.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •