Page 1 of 3 123 LastLast
Results 1 to 10 of 25

Thread: Upgrading to 15.0 from 42.3 while live?

  1. #1
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    293

    Default Upgrading to 15.0 from 42.3 while live?

    In the past I have upgraded my various openSuSE machines using zypper while the system was live.

    Is this still available for upgrading to 15.0? I could not find the page of instructions and that has always been easy before.

  2. #2

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by jpff View Post
    Is this still available for upgrading to 15.0?
    Sure.
    I upgraded that way.

    I could not find the page of instructions and that has always been easy before.
    It's the same as always. Change the repo URLs to point to the new version (i.e. replace 42.3 with 15.0) with YaST->Software Repositories or edit the files in /etc/zypp/repos.d/, and then run "zypper dup" to upgrade.

    https://en.opensuse.org/SDB:System_upgrade

  3. #3
    Join Date
    Nov 2008
    Location
    Bath UK
    Posts
    293

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Thank you; I found the instruction and am upgrading the first computer now.

    Memo to self: must improve my searching process!

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Upgrading to 15.0 from 42.3 while live?

    I did a live upgrade and had small issues
    the pinned launchers on the plasma 5 menubar had lost their icon (they still launched the appropriate applications) I just removed and re-added the apps I had pined
    I found that SuSEfirewall2 was still installed and active while firewalld was disabled it was my understanding that firewalld replaced SuSEfirewall2?
    I uninstalled SuSEfirewall2 and set the firewalld service to active
    if you have an nvidia graphic card you need to manually install vlc-vdpau
    there wore a few issues with intel users and vdpau I guess the devs decided to package it separately and not have it installed by default this might crash vlc
    I also found an issue with vlc and opengl
    https://forums.opensuse.org/showthre...1206-vlc-crash
    which might be related with the nvidia driver or it could be an internal vlc 3.0 issue as I've read other distro's have that same issue
    https://ubuntuforums.org/showthread.php?t=2388949

  5. #5

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by I_A View Post
    I did a live upgrade and had small issues

    I doubt that these issues are related to doing a live upgrade...

    I found that SuSEfirewall2 was still installed and active while firewalld was disabled it was my understanding that firewalld replaced SuSEfirewall2?
    It has.
    But an upgrade won't *replace* one with the other, to avoid surprises/disruptions.
    There's a tool to automatically migrate the config from SuSEfirewall2 to firewalld, but that doesn't work in (and cannot support) all cases AFAIK.

    PS: I had no problem with vlc here, using intel. (I don't have vlc-vdpau installed)

  6. #6
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by wolfi323 View Post
    [/FONT][/COLOR]I doubt that these issues are related to doing a live upgrade...


    It has.
    But an upgrade won't *replace* one with the other, to avoid surprises/disruptions.
    There's a tool to automatically migrate the config from SuSEfirewall2 to firewalld, but that doesn't work in (and cannot support) all cases AFAIK.

    PS: I had no problem with vlc here, using intel. (I don't have vlc-vdpau installed)
    yes but the broken vlc and missing icons are update related as I had no such issues with 42.3
    the opengl issue is probobly code from vlc 3.0 but the missing vdpau plugin was an opensuse decision

  7. #7

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by I_A View Post
    yes but the broken vlc and missing icons are update related as I had no such issues with 42.3
    Sure, but you'd probably have had the same issues when doing a fresh installation.

    the opengl issue is probobly code from vlc 3.0 but the missing vdpau plugin was an opensuse decision
    openSUSE doesn't even ship the vdpau plugin, and never did (it was part of vlc-codecs previously, which was/is only available on Packman and VideoLAN).

  8. #8

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Btw, vlc-vdpau does supplement vlc-noX, so it should get automatically installed when installing vlc.
    I don't know why that doesn't work, I remember that those supplements were missing in the Packman repo in the past because they use a (old) Debian version of createrepo to generate the repo metadata. I thought that would be fixed meanwhile, but probably not.

    I.e. this (that vlc-vdpau doesn't get installed automatically) is likely a "bug" in the Packman repo.

  9. #9
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by wolfi323 View Post
    Sure, but you'd probably have had the same issues when doing a fresh installation.


    openSUSE doesn't even ship the vdpau plugin, and never did (it was part of vlc-codecs previously, which was/is only available on Packman and VideoLAN).
    I thought the missing icons was related to the plasma 5 desktop update I wasn't sure if the plasma 5 menubar did something different to icons as they appeared fine in the start menu only pinned icons wore affected
    and yes it was the packman team that split the plugin but it will effect all nvidia users, strangely enough the vlc-codec-gstreamer got re-installed even tho I had it uninstalled this too is packman decision

  10. #10

    Default Re: Upgrading to 15.0 from 42.3 while live?

    Quote Originally Posted by I_A View Post
    I thought the missing icons was related to the plasma 5 desktop update I wasn't sure if the plasma 5 menubar did something different to icons as they appeared fine in the start menu only pinned icons wore affected
    Sure it's related to the Plasma update, it's probably a glitch in the config migration from 5.8 to 5.12.
    But the same would likely have happened if you had done a fresh installation with keeping your home partition/directory.

    Impossible to say what happened exactly without seeing your config files before and after though.

    I never had a problem with this either, but I'm always using the latest Plasma, i.e. I had 5.12.5 on 42.3 already.

    and yes it was the packman team that split the plugin but it will effect all nvidia users, strangely enough the vlc-codec-gstreamer got re-installed even tho I had it uninstalled this too is packman decision
    Well, actually there is only *one* vlc package and that is maintained in OBS. Packman and VideoLAN just link to it and builds with the codecs enabled.
    So it's not necessarily a decision by the Packman team actually.
    Last edited by wolfi323; 25-May-2018 at 12:18.

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •