Results 1 to 7 of 7

Thread: journaltcl error

  1. #1

    Default journaltcl error

    Hi, i'm new to opensuse . I'm running Solus in my dell xps 13 at home for surf, music, video and ,at work, i switch from apple osx to opensuse leap . I'm running leap on macbookpro retina 13" mid 2015 ( macbookpro 12,1 ).

    I've got this error message during the boot and during power off with my mbp .
    **************************************************************************
    mai 25 17:16:06 linux-2mk9 kernel: brcmfmac: brcmf_inetaddr_changed: fail to get arp ip table err:-23
    mai 25 17:15:28 linux-2mk9 bluetoothd[1255]: Failed to set mode: Blocked through rfkill (0x12)
    mai 25 17:15:26 linux-2mk9 bluetoothd[1255]: RFCOMM server failed for :1.50/Profile/HSPHSProfile/00001108-0000-1000-8000-00805f9b34fb: rfcomm_bind: Address already in use (98)
    mai 25 17:15:26 linux-2mk9 pulseaudio[1839]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono:
    org.freeesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
    mai 25 17:15:26 linux-2mk9 bluetoothd[1255]: RFCOMM server failed for Headset Voice gateway: rfcomm_bind: Address already in use (98)
    mai 25 17:15:20 linux-2mk9 bluetoothd[1255]: Failed to set mode: Blocked through rfkill (0x12)
    mai 25 17:15:18 linux-2mk9 pulseaudio[1555]: [pulseaudio] backend-ofono.c: Failed to register as a handsfree audio agent with ofono: org.freeesktop.DBus.Error.ServiceUnknown: The name org.ofono was not provided by any .service files
    mai 25 17:15:13 linux-2mk9 systemd[1]: Failed to start Setup Virtual Console.
    mai 25 17:15:12 linux-2mk9 kernel: ACPI Error: Method parse/execution failed [\_PR.CPU0._PDC] (Node ffff88019fd97190), AE_AML_OPERAND_TYPE (20170303/psparse-543)
    mai 25 17:15:12 linux-2mk9 kernel: ACPI Exception: AE_AML_OPERAND_TYPE, While resolving operands for [Store] (20170303/dswexec-461)
    mai 25 17:15:12 linux-2mk9 kernel: ACPI Error: Needed type [Reference], found [Integer] ffff88026ec4e090 (20170303/exresop-103)
    ***********************************************************************************************************************************************************************************

    Could you help me ?
    thanx seb
    PS my english is bad, i'm french

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: journaltcl error

    Your posted log suggests that the cause of your problems is that your machine is configured with the same address of some other existing device....

    So, either you have a rogue device on the network that needs to be identified and removed or re-configured or you need to acquire a new IP address by restarting your network service (assuming your machine is configured as a DHCP client). Note that running the following in an elevated console should fix more scenarios but probably won't if there is a rogue device.
    Code:
    systemctl restart network
    If you really can't find the rogue device that's causing the conflict, then
    I'd advise configuring your machine with a static address, but your static address should be
    - Outside the DHCP IP range (scope) while still remaining within the limits of the subnet you're on
    - If within the DHCP scope (eg Someone configured the scope to be the entire subnet range), then pick one of the highest IP addresses in the range. DHCP will typically assign addresses incrementing starting from the first available address, and re-use addresses when leases expire so unless the scope is tiny relative to the number of clients, a high address has the least chance of causing a conflict.

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3

    Default Re: journaltcl error

    Hello and thanx for the reply . I've did the "sudo systemctl restart network" but i've got the same error . I thinks it's a broadcom driver error ... dell computers, apple ans raspberry have got the same error with the same chipstet when they are running on linux : brcmfmac: brcmf_inetaddr_changed: fail to get arp ip table err:-23 with the linux broadcom driver. the wifi works fine but i don't like the errors messages on boot : it's purely aesthetic.
    I will google search for the acpi error...

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: journaltcl error

    Repeating...
    Your posted log says that another device already exists on your network with the same IP address assigned to your machine.
    When your system boots up and discovers this situation, it disabled your networking to avoid conflicts with this other device.
    That causes a domino effect that any services that rely on a network connection cannot start.

    So,
    Fix that "other device" issue and your system should boot up fine (unless some other problem occurs).

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  5. #5

    Default Re: journaltcl error

    Hello . This errors appears when i'm turn on the wifi. It appears at home and at works. When i'm using eth wire i haven't got this errors . Other dire even if this errors occurrs the wifi works fine . Google search give me that all the devices with this broadcom chips sort the same error . It's just disgracefull cause everything works fine ... But instead Of Plymouth animation i've got this message . I don't know why i haven't got the Plymouth theme during the boot...

  6. #6
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: journaltcl error

    Are you dualbooting osx and openSUSE?
    I'm looking more closely at your original post and I wonder what you mean by "switching from osx to openSUSE LEAP"

    If you're multi-booting, that may be the problem, but should be resolvable by the "systemctl restart network" I suggested earlier.
    Alternate better solution is to configure a different MAC address for your WiFi interface so that your machine looks different to your DHCP server...
    I assume you are using Network Manager for your WiFi connections management.
    Edit your WiFi connection at work and enter a different, made up MAC address in the "Clone address" field.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  7. #7

    Default Re: journaltcl error

    Ha... No just opensuse ... I kick OsX out of the mac

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •