Results 1 to 4 of 4

Thread: Can't update SUSE to Service Pack 3

  1. #1

    Question Can't update SUSE to Service Pack 3

    Hello! Recently I was trying to update my SUSE from SP1 to SP3, but in /etc/os-release is still SP1
    Code:
    NAME="SLES"
    VERSION="12-SP1"
    VERSION_ID="12.1"
    PRETTY_NAME="SUSE Linux Enterprise Server 12 SP1"
    ID="sles"
    ANSI_COLOR="0;32"
    CPE_NAME="cpe:/o:suse:sles:12:sp1"
    zypper lr -d


    Code:
    Repository priorities are without effect. All enabled repositories share the same priority.
    
    
    #  | Alias                                                         | Name                           | Enabled | GPG Check | Refresh | Priority | Type   | URI                                                                                               | Service
    ---+---------------------------------------------------------------+--------------------------------+---------+-----------+---------+----------+--------+-----------------------------------------------------------------------------------------------------------------------------------------+
     1 | SLES12-SP1-Debuginfo-Pool                                     | SLES12-SP1-Debuginfo-Pool      | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP1/x86_64/product_debug?credentials=SMT-HIDDEN   |
     2 | SLES12-SP1-Debuginfo-Updates                                  | SLES12-SP1-Debuginfo-Updates   | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update_debug?credentials=SMT-HIDDEN     |
     3 | SLES12-SP1-Pool                                               | SLES12-SP1-Pool                | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP1/x86_64/product?credentials=SMT-HIDDEN         |
     4 | SLES12-SP1-Updates                                            | SLES12-SP1-Updates             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update?credentials=SMT-HIDDEN           |
     5 | SMT-HIDDEN:SLES12-SP1-Debuginfo-Pool                           | SLES12-SP1-Debuginfo-Pool      | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP1/x86_64/product_debug?credentials=SMT-HIDDEN   | SMT-HIDDEN
     6 | SMT-HIDDEN:SLES12-SP1-Debuginfo-Updates                        | SLES12-SP1-Debuginfo-Updates   | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update_debug?credentials=SMT-HIDDEN     | SMT-HIDDEN
     7 | SMT-HIDDEN:SLES12-SP1-Pool                                     | SLES12-SP1-Pool                | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP1/x86_64/product?credentials=SMT-HIDDEN         | SMT-HIDDEN
     8 | SMT-HIDDEN:SLES12-SP1-Source-Pool                              | SLES12-SP1-Source-Pool         | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP1/x86_64/product_source?credentials=SMT-HIDDEN  | SMT-HIDDEN
     9 | SMT-HIDDEN:SLES12-SP1-Updates                                  | SLES12-SP1-Updates             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP1/x86_64/update?credentials=SMT-HIDDEN           | SMT-HIDDEN
    10 | SMT-HIDDEN:SLES12-SP2-Debuginfo-Pool                          | SLES12-SP2-Debuginfo-Pool      | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP2/x86_64/product_debug?credentials=SMT-HIDDEN   | SMT-HIDDEN
    11 | SMT-HIDDEN:SLES12-SP2-Debuginfo-Updates                       | SLES12-SP2-Debuginfo-Updates   | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP2/x86_64/update_debug?credentials=SMT-HIDDEN     | SMT-HIDDEN
    12 | SMT-HIDDEN:SLES12-SP2-Installer-Updates                       | SLES12-SP2-Installer-Updates   | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER-INSTALLER/12-SP2/x86_64/update?credentials=SMT-HIDDEN | SMT-HIDDEN
    13 | SMT-HIDDEN:SLES12-SP2-Pool                                    | SLES12-SP2-Pool                | No      | ----      | ----    |   99     | rpm-md | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP2/x86_64/product?credentials=SMT-HIDDEN         | SMT-HIDDEN
    14 | SMT-HIDDEN:SLES12-SP2-Source-Pool                             | SLES12-SP2-Source-Pool         | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP2/x86_64/product_source?credentials=SMT-HIDDEN  | SMT-HIDDEN
    15 | SMT-HIDDEN:SLES12-SP2-Updates                                 | SLES12-SP2-Updates             | No      | ----      | ----    |   99     | rpm-md | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP2/x86_64/update?credentials=SMT-HIDDEN           | SMT-HIDDEN
    16 | SMT-HIDDEN:SLES12-SP3-Debuginfo-Pool                          | SLES12-SP3-Debuginfo-Pool      | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product_debug?credentials=SMT-HIDDEN   | SMT-HIDDEN
    17 | SMT-HIDDEN:SLES12-SP3-Debuginfo-Updates                       | SLES12-SP3-Debuginfo-Updates   | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update_debug?credentials=SMT-HIDDEN     | SMT-HIDDEN
    18 | SMT-HIDDEN:SLES12-SP3-Installer-Updates                       | SLES12-SP3-Installer-Updates   | No      | ----      | ----    |   99     | NONE   | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER-INSTALLER/12-SP3/x86_64/update?credentials=SMT-HIDDEN | SMT-HIDDEN
    19 | SMT-HIDDEN:SLES12-SP3-Pool                                    | SLES12-SP3-Pool                | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://HIDDEN/repo/SUSE/Products/SLE-SERVER/12-SP3/x86_64/product?credentials=SMT-HIDDEN         | SMT-HIDDEN
    20 | SMT-HIDDEN:SLES12-SP3-Updates                                 | SLES12-SP3-Updates             | Yes     | (r ) Yes  | Yes     |   99     | rpm-md | http://HIDDEN/repo/SUSE/Updates/SLE-SERVER/12-SP3/x86_64/update?credentials=SMT-HIDDEN           | SMT-HIDDEN
    21 | network_utilities                                             | Network Utilities (SLE_12_SP1) | No      | ----      | ----    |   99     | rpm-md | http://download.opensuse.org/repositories/network:/utilities/SLE_12_SP1/                          |
    22 | vmware-packages                                               | vmware-packages                | Yes     | (r ) Yes  | No      |   99     | rpm-md | http://packages.vmware.com/packages/sle12/x86_64/


    (i've replace my hostname with HIDDEN)

    zypper patch
    Code:
    Refreshing service 'SMT-HIDDEN'.
    Loading repository data...
    Reading installed packages...
    Resolving package dependencies...
    6 Problems:
    Problem: libsmbclient-raw0-4.2.4-28.14.1.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.2.4_28.14.1_3764_SUSE_SLE_12_X86_64)(64bit), but this requirement cannot be provided
    Problem: libregistry0-4.2.4-28.14.1.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.2.4_28.14.1_3764_SUSE_SLE_12_X86_64)(64bit), but this requirement cannot be provided
    Problem: libgensec0-4.2.4-28.14.1.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.2.4_28.14.1_3764_SUSE_SLE_12_X86_64)(64bit), but this requirement cannot be provided
    Problem: util-linux-2.29.2-3.5.1.x86_64 conflicts with kernel < 4.4 provided by kernel-default-3.12.74-60.64.40.1.x86_64
    Problem: product:sle-module-web-scripting-12-0.x86_64 requires product(SLES) >= 12, but this requirement cannot be provided
    Problem: libini_config3-1.0.0.1-20.3.x86_64 requires libbasicobjects.so.0(DING_1.0.0.1)(64bit), but this requirement cannot be provided
    
    
    Problem: libsmbclient-raw0-4.2.4-28.14.1.x86_64 requires libsamba-debug-samba4.so(SAMBA_4.2.4_28.14.1_3764_SUSE_SLE_12_X86_64)(64bit), but this requirement cannot be provided
     Solution 1: Following actions will be done:
      do not install patch:SUSE-SLE-SERVER-12-SP3-2017-1367-1.noarch
      do not install patch:SUSE-SLE-SERVER-12-SP3-2018-507-1.noarch
     Solution 2: deinstallation of libsmbclient-raw0-4.2.4-28.14.1.x86_64
     Solution 3: break libsmbclient-raw0-4.2.4-28.14.1.x86_64 by ignoring some of its dependencies
    
    
    Choose from above solutions by number or skip, retry or cancel [1/2/3/s/r/c] (c):
    I'm not sure which solutions I should choose...

    zypper up
    Code:
    Refreshing service 'SMT-http_HIDDEN'.
    Loading repository data...
    Reading installed packages...
    
    
    The following 34 package updates will NOT be installed:
      dracut libbasicobjects0 libdcerpc-binding0 libdcerpc0 libdhash1 libndr-krb5pac0 libndr-nbt0 libndr-standard0 libndr0 libnetapi0 libpath_utils1 libref_array1 libsamba-credentials0
      libsamba-hostconfig0 libsamba-passdb0 libsamba-util0 libsamdb0 libsmbclient0 libsmbconf0 libsmbldap0 libsss_sudo libwbclient0 samba-client samba-libs samba-winbind sles-release sssd
      sssd-krb5-common sssd-ldap systemd systemd-sysvinit udev util-linux util-linux-lang
    
    
    The following product update will NOT be installed:
      "SUSE Linux Enterprise Server 12 SP3"
    
    
    Nothing to do.
    zypper dup
    Code:
    Warning: You are about to do a distribution upgrade with all enabled repositories. Make sure these repositories are compatible before you continue. See 'man zypper' for more information about this command.
    Refreshing service 'SMT-HIDDEN'.
    Loading repository data...
    Reading installed packages...
    Computing distribution upgrade...
    
    
    Nothing to do.


    Any ideas? :)

  2. #2
    Join Date
    Jun 2008
    Location
    Auckland, NZ
    Posts
    20,295
    Blog Entries
    1

    Default Re: Can't update SUSE to Service Pack 3

    Hi doppler1088. Since you're using SLES (and not openSUSE), you're best advised to post here...

    https://forums.suse.com/forum.php

  3. #3

    Default Re: Can't update SUSE to Service Pack 3

    up's sorry. My bad.

  4. #4
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Can't update SUSE to Service Pack 3

    Closing this thread.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •