Results 1 to 2 of 2

Thread: Ableton Live 9 Lite crashes mid-install with PlayOnLinux

  1. #1
    Join Date
    Nov 2017
    Somewhere around the middle of Europe.

    Default Ableton Live 9 Lite crashes mid-install with PlayOnLinux

    When I try to install Ableton Live 9 Lite using PlayOnLinux, everything goes smoothly until the installer opens. The installer shows the general "If you want to install click 'Next' ". When I click the 'Next' button, the installer disappears and POL shows a crash message.

    The whole log:
    PlayOnLinux debugging tool (v4.2.12)
    Debugging: Ableton Live 9
    Warning: This is a PlayOnLinux script logfile. It does not contain everything that happened in your program\'s virtual drive (wineprefix)
    Please do not use this logfile on winehq forum, this logfile is not interesting for wine debugging.
    Date: 05/19/18 10:12:41
    > uname -a
      Linux OpenSUSE-WD-Elements-1042 4.16.8-1-default #1 SMP PREEMPT Wed May 9 10:29:52 UTC 2018 (9269cc1) x86_64 x86_64 x86_64 GNU/Linux
    > lsb_release -a
    > wine --version (Be careful; this version might not be the version used
    in the script. Read the content of this file for more information)
    > glxinfo \| grep rendering
    > glxinfo \| grep renderer
    > OpenGL libs
      32bits direct rendering is enabled
      64bits direct rendering is enabled
    > export
      declare -x ALSA_CONFIG_PATH="/etc/alsa-pulse.conf"
    declare -x AMD64_COMPATIBLE="True"
    declare -x ANDROID_HOME="/home/jan/Android"
    declare -x APPLICATION_TITLE="PlayOnLinux"
    declare -x AUDIODRIVER="pulseaudio"
    declare -x COLORFGBG="15;0"
    declare -x COLORTERM="truecolor"
    declare -x CONFIG_SITE="/usr/share/site/x86_64-unknown-linux-gnu"
    declare -x CPU="x86_64"
    declare -x CSHEDIT="emacs"
    declare -x CVS_RSH="ssh"
    declare -x DBUS_SESSION_BUS_ADDRESS="unix:path=/run/user/1000/bus"
    declare -x DEBIAN_PACKAGE="FALSE"
    declare -x DESKTOP="/home/jan/Plocha"
    declare -x DESKTOP_SESSION="/usr/share/xsessions/plasma5"
    declare -x DISPLAY=":0"
    declare -x DONT_MONITOR="1"
    declare -x DYLDPATH_ORIGIN=""
    declare -x DYLD_LIBRARY_PATH=""
    declare -x FROM_HEADER=""
    declare -x GECKO_SITE=""
    declare -x GNUPGHOME="/home/jan/.PlayOnLinux//gpg"
    declare -x GOARCH="amd64"
    declare -x GOOS="linux"
    declare -x GOPATH="/home/jan/Dokumenty/go"
    declare -x GOROOT="/usr/lib64/go/1.9"
    declare -x GPG_TTY="/dev/pts/0"
    declare -x GS_LIB="/home/jan/.fonts"
    declare -x GTK_IM_MODULE="cedilla"
    declare -x GTK_MODULES="canberra-gtk-module"
    declare -x G_BROKEN_FILENAMES="1"
    declare -x G_FILENAME_ENCODING="UTF-8"
    declare -x HISTSIZE="1000"
    declare -x HOME="/home/jan"
    declare -x HOST="OpenSUSE-WD-Elements-1042"
    declare -x HOSTNAME="OpenSUSE-WD-Elements-1042"
    declare -x HOSTTYPE="x86_64"
    declare -x IGNORE_ICON_DIR="false"
    declare -x INPUT_METHOD=""
    declare -x JAVA_BINDIR="/usr/java/latest/bin"
    declare -x JAVA_HOME="/usr/java/jdk1.8.0_151/"
    declare -x JAVA_ROOT="/usr/java/latest"
    declare -x JDK_HOME="/usr/java/latest"
    declare -x JRE_HOME="/usr/lib64/jvm/jre"
    declare -x KDE_FULL_SESSION="true"
    declare -x KDE_SESSION_UID="1000"
    declare -x KDE_SESSION_VERSION="5"
    declare -x KONSOLE_DBUS_SERVICE=":1.26"
    declare -x KONSOLE_DBUS_SESSION="/Sessions/1"
    declare -x KONSOLE_PROFILE_NAME="Profil 1"
    declare -x LANG="C"
    declare -x LANGUAGE="cs_CZ:en"
    declare -x LC_ADDRESS="cs_CZ.UTF-8"
    declare -x LC_CTYPE="cs_CZ.UTF-8"
    declare -x LC_IDENTIFICATION="cs_CZ.UTF-8"
    declare -x LC_MEASUREMENT="cs_CZ.UTF-8"
    declare -x LC_MONETARY="cs_CZ.UTF-8"
    declare -x LC_NAME="cs_CZ.UTF-8"
    declare -x LC_NUMERIC="cs_CZ.UTF-8"
    declare -x LC_PAPER="cs_CZ.UTF-8"
    declare -x LC_TELEPHONE="cs_CZ.UTF-8"
    declare -x LC_TIME="cs_CZ.UTF-8"
    declare -x LD_32_PATH_ORIGIN=""
    declare -x LD_LIBRARY_PATH=""
    declare -x LD_PATH_ORIGIN=""
    declare -x LESS="-M -I -R"
    declare -x LESSCLOSE=" %s %s"
    declare -x LESSKEY="/etc/lesskey.bin"
    declare -x LESSOPEN=" %s"
    declare -x LOGNAME="jan"
    declare -x LS_COLORS="rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=00:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgzdeclare -x LS_OPTIONS="-N --color=tty -T 0"
    declare -x MACHTYPE="x86_64-suse-linux"
    declare -x MAIL="/var/spool/mail/jan"
    declare -x MANPATH="/home/jan/.nvm/versions/node/v7.7.2/share/man:/usr/local/man:/usr/share/man"
    declare -x MD5_COMMAND="md5sum"
    declare -x MINICOM="-c on"
    declare -x MONO_SITE=""
    declare -x MORE="-sl"
    declare -x NNTPSERVER="news"
    declare -x NVM_BIN="/home/jan/.nvm/versions/node/v7.7.2/bin"
    declare -x NVM_CD_FLAGS=""
    declare -x NVM_DIR="/home/jan/.nvm"
    declare -x NVM_IOJS_ORG_MIRROR=""
    declare -x NVM_NODEJS_ORG_MIRROR=""
    declare -x NVM_PATH="/home/jan/.nvm/versions/node/v7.7.2/lib/node"
    declare -x OLDPWD="/home/jan/.PlayOnLinux/configurations/setups/Ableton Live 9"
    declare -x OSTYPE="linux"
    declare -x OS_NAME="linux"
    declare -x OpenGL32="1"
    declare -x OpenGL64="1"
    declare -x PAGER="less"
    declare -x PAM_KWALLET5_LOGIN="/run/user/1000/kwallet5.socket"
    declare -x PAPERSIZE="a4"
    declare -x PATH="/home/jan/.nvm/versions/node/v7.7.2/bin:/usr/games:/usr/local/bin:/usr/bin:/bin:/opt/kde3/bin:/usr/lib/mit/sbin"
    declare -x PATH_ORIGIN="/home/jan/.nvm/versions/node/v7.7.2/bin:/usr/games:/usr/local/bin:/usr/bin:/bin:/opt/kde3/bin:/usr/lib/mit/sbin"
    declare -x PLAYONLINUX="/usr/share/playonlinux"
    declare -x POL_ARCH="x86"
    declare -x POL_COOKIE="6wO9OUDWkSIVCGs8xM3i"
    declare -x POL_CURL="curl"
    declare -x POL_DNS=""
    declare -x POL_HOST=""
    declare -x POL_ID="63391590"
    declare -x POL_LANG="C"
    declare -x POL_OS="Linux"
    declare -x POL_PORT="30000"
    declare -x POL_PYTHON="python"
    declare -x POL_SetupWindow_ID="892"
    declare -x POL_TERM="xterm"
    declare -x POL_UPTODATE="TRUE"
    declare -x POL_USER_ARCH="x86"
    declare -x POL_USER_ROOT="/home/jan/.PlayOnLinux/"
    declare -x POL_WGET="env LD_LIBRARY_PATH=\"\" wget --prefer-family=IPv4 -q"
    declare -x PROFILEHOME=""
    declare -x PROFILEREAD="true"
    declare -x PWD="/usr/share/playonlinux/python"
    declare -x PYTHONSTARTUP="/etc/pythonstart"
    declare -x QEMU_AUDIO_DRV="pa"
    declare -x QT_AUTO_SCREEN_SCALE_FACTOR="0"
    declare -x QT_IM_MODULE="xim"
    declare -x QT_IM_SWITCHER="imsw-multi"
    declare -x QT_SYSTEM_DIR="/usr/share/desktop-data"
    declare -x REPERTOIRE="/home/jan/.PlayOnLinux/"
    declare -x SCRIPTID="Ableton Live 9"
    declare -x SDK_HOME="/usr/java/latest"
    declare -x SDL_AUDIODRIVER="pulse"
    declare -x SED="sed"
    declare -x SESSION_MANAGER="local/OpenSUSE-WD-Elements-1042:@/tmp/.ICE-unix/2045,unix/OpenSUSE-WD-Elements-1042:/tmp/.ICE-unix/2045"
    declare -x SETUPWINDOW_INIT="true"
    declare -x SHELL="/bin/bash"
    declare -x SHELL_SESSION_ID="e02df2a976544e10b6b64e9d59a8326c"
    declare -x SHLVL="5"
    declare -x SITE=""
    declare -x SSH_AGENT_PID="1977"
    declare -x SSH_ASKPASS="/usr/lib/ssh/ssh-askpass"
    declare -x SSH_AUTH_SOCK="/tmp/ssh-GYiW6XRs2JMQ/agent.1914"
    declare -x STARTUP="/usr/bin/startkde"
    declare -x TERM="xterm-256color"
    declare -x TEXTDOMAIN="pol"
    declare -x TEXTDOMAINDIR="/usr/share/playonlinux/lang/locale/"
    declare -x TITLE="Ableton Live 9"
    declare -x TITRE="PlayOnLinux"
    declare -x UBUNTU_MENUPROXY="0"
    declare -x USER="jan"
    declare -x VERSION="4.2.12"
    declare -x WGETRC="/home/jan/.PlayOnLinux//configurations/wgetrc"
    declare -x WINDOWID="37748742"
    declare -x WINDOWMANAGER="/usr/bin/startkde"
    declare -x WINDOW_MANAGER="/usr/bin/startkde"
    declare -x WINEDLLOVERRIDES="winemenubuilder.exe=d"
    declare -x WINEPREFIX="/home/jan/.PlayOnLinux//wineprefix/default"
    declare -x WINE_SITE=""
    declare -x WorkingDirectory="/usr/share/playonlinux"
    declare -x XAUTHLOCALHOSTNAME="OpenSUSE-WD-Elements-1042"
    declare -x XAUTHORITY="/home/jan/.local/share/sddm/.Xauthority"
    declare -x XCURSOR_SIZE="0"
    declare -x XCURSOR_THEME="Breeze_Snow"
    declare -x XDG_CONFIG_DIRS="/etc/xdg"
    declare -x XDG_CURRENT_DESKTOP="KDE"
    declare -x XDG_DATA_DIRS="/home/jan/.local/share/flatpak/exports/share:/var/lib/flatpak/exports/share:/usr/local/share:/usr/share"
    declare -x XDG_RUNTIME_DIR="/run/user/1000"
    declare -x XDG_SEAT="seat0"
    declare -x XDG_SEAT_PATH="/org/freedesktop/DisplayManager/Seat0"
    declare -x XDG_SESSION_CLASS="user"
    declare -x XDG_SESSION_DESKTOP="KDE"
    declare -x XDG_SESSION_ID="2"
    declare -x XDG_SESSION_PATH="/org/freedesktop/DisplayManager/Session1"
    declare -x XDG_SESSION_TYPE="x11"
    declare -x XDG_VTNR="7"
    declare -x XKEYSYMDB="/usr/X11R6/lib/X11/XKeysymDB"
    declare -x XMODIFIERS="@im=local"
    declare -x XNLSPATH="/usr/share/X11/nls"
    declare -x XSESSION_IS_UP="yes"
    05/19/18 10:12:55 - [POL_Wine_SelectPrefix] Message: Selecting prefix: AbletonLive9
    05/19/18 10:12:55 - [POL_System_SetArch] Message: POL_ARCH set to x86
    05/19/18 10:12:55 - [POL_System_SetArch] Message: POL_ARCH set to x86
    05/19/18 10:12:55 - [POL_Wine_PrefixCreate] Message: Setting POL_WINEVERSION to 1.9.22
    05/19/18 10:12:55 - [POL_Wine_PrefixCreate] Message: Creating prefix (1.9.22)...
    05/19/18 10:12:55 - [POL_Wine_PrefixCreate] Message: Prefix already exists
    05/19/18 10:12:57 - [POL_SetupWindow_menu] Message: menu answer: Overwrite (usually works, no guarantee)
    05/19/18 10:12:57 - [POL_Wine_PrefixCreate] Message: Overwrite Prefix
    05/19/18 10:12:57 - [POL_Wine_PrefixCreate] Message: Setting version to 1.9.22
    05/19/18 10:12:57 - [POL_Config_PrefixWrite] Message: Prefix config write: VERSION 1.9.22
    05/19/18 10:12:57 - [POL_LoadVar_PROGRAMFILES] Message: Getting Program Files name
    05/19/18 10:12:57 - [POL_Wine] Message: Running wine-1.9.22 cmd /c echo %ProgramFiles% (Working directory : /usr/share/playonlinux/python)
    05/19/18 10:12:57 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
    C:\Program Files
    05/19/18 10:12:58 - [POL_Wine] Message: Wine return: 0
    05/19/18 10:13:01 - [POL_Call] Message: Calling POL_Install_vcrun2008
    05/19/18 10:13:01 - [POL_Call] Message: ----- Starting function POL_Install_vcrun2008 -----
    05/19/18 10:13:01 - [POL_GPG_auth_script] Message: Checking signature of POL_Install_vcrun2008
    05/19/18 10:13:01 - [POL_GPG_install_key] Message: Importing PlayOnLinux public key
    05/19/18 10:13:01 - [POL_Source] Message: POL GPG : Good signature
    05/19/18 10:13:01 - [POL_Download_Resource] Message: Downloading resource
    05/19/18 10:13:01 - [POL_Download_Resource] Message: Resource already present
    05/19/18 10:13:01 - [POL_System_CheckFS] Message: Checking filesystem for vcredist_x86.exe
    05/19/18 10:13:01 - [POL_Wine] Message: Running wine-1.9.22 start /unix vcredist_x86.exe /q (Working directory : /home/jan/.PlayOnLinux/ressources/vcrun2008)
    05/19/18 10:13:01 - [POL_Wine] Message: Notice: PlayOnLinux deliberately disables winemenubuilder. See
    05/19/18 10:13:02 - [POL_Wine] Message: Wine return: 0
    wine: Unhandled page fault on read access to 0x00000004 at address 0x7eaf78c1 (thread 002b), starting debugger...
    05/19/18 10:13:06 - [POL_Wine_OverrideDLL] Message: Overriding DLLs
    05/19/18 10:13:07 - [POL_Wine] Message: Running wine-1.9.22 regedit /home/jan/.PlayOnLinux//tmp/override-dll.reg (Working directory : /home/jan/.PlayOnLinux/ressources/vcrun2008)
    05/19/18 10:13:07 - [POL_Wine] Message: Wine return: 0
    05/19/18 10:13:07 - [POL_Call] Message: ----- Ending function POL_Install_vcrun2008 -----
    05/19/18 10:13:07 - [POL_Call] Message: Calling POL_Install_corefonts
    05/19/18 10:13:08 - [POL_Call] Message: ----- Starting function POL_Install_corefonts -----
    05/19/18 10:13:08 - [POL_GPG_auth_script] Message: Checking signature of POL_Install_corefonts
    05/19/18 10:13:08 - [POL_GPG_install_key] Message: Importing PlayOnLinux public key
    05/19/18 10:13:08 - [POL_Source] Message: POL GPG : Good signature
    05/19/18 10:13:08 - [POL_Call] Message: Calling POL_Internal_InstallFonts
    05/19/18 10:13:08 - [POL_Call] Message: ----- Starting function POL_Internal_InstallFonts -----
    05/19/18 10:13:08 - [POL_GPG_auth_script] Message: Checking signature of POL_Internal_InstallFonts
    05/19/18 10:13:08 - [POL_GPG_install_key] Message: Importing PlayOnLinux public key
    05/19/18 10:13:08 - [POL_Source] Message: POL GPG : Good signature
    05/19/18 10:13:08 - [POL_Call] Message: ----- Ending function POL_Internal_InstallFonts -----
    05/19/18 10:13:08 - [source] Message: Installing microsoft fonts
    05/19/18 10:13:08 - [POL_Call] Message: ----- Ending function POL_Install_corefonts -----
    05/19/18 10:13:08 - [Set_OS] Message: Setting Windows OS to win7 
    05/19/18 10:13:08 - [POL_Wine] Message: Running wine-1.9.22 regedit /home/jan/.PlayOnLinux//tmp/regkey.reg (Working directory : /home/jan/.PlayOnLinux/tmp)
    05/19/18 10:13:08 - [POL_Wine] Message: Wine return: 0
    05/19/18 10:13:08 - [POL_Wine_Direct3D] Message: Setting wine Direct3D /home/jan/.PlayOnLinux//wineprefix/AbletonLive9 DirectDrawRenderer gdi 
    05/19/18 10:13:08 - [POL_Wine] Message: Running wine-1.9.22 regedit /home/jan/.PlayOnLinux//tmp/regkey.reg (Working directory : /home/jan/.PlayOnLinux/tmp)
    05/19/18 10:13:09 - [POL_Wine] Message: Wine return: 0
    05/19/18 10:13:19 - [POL_SetupWindow_browse] Message: browser answer: /home/jan/Stažené/ablyaton live 9 32-bit/Setup.msi
    05/19/18 10:13:19 - [POL_Wine] Message: Running wine-1.9.22 msiexec /i /home/jan/Stažené/ablyaton live 9 32-bit/Setup.msi (Working directory : /home/jan)
    fixme:ntdll:NtLockFile I/O completion on lock not implemented yet
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    err:mscoree:LoadLibraryShim error reading registry key for installroot
    wine: Unhandled page fault on read access to 0x00000004 at address 0x7e8a58c1 (thread 0009), starting debugger...
    winedbg: Internal crash at 0x7e9d28c1
    05/19/18 10:14:12 - [POL_Wine] Error: Wine seems to have crashed\n\nIf your program is running, just ignore this message
    05/19/18 10:14:15 - [POL_Wine] Message: Wine return: 84
    05/19/18 10:14:16 - [POL_Shortcut] Message: Looking for <Ableton Live 9 Suite.exe>, found <>
    05/19/18 10:14:16 - [POL_Shortcut] Error: Binary not found: Ableton Live 9 Suite.exe\nHave you installed the program to the default location?
    05/19/18 10:14:22 - [POL_Shortcut] Message: Shortcut created:  Ableton Live 9
    05/19/18 10:14:27 - [POL_SetupWindow_Close] Message: Closing window for pid 892
    05/19/18 10:14:31 - [POL_SetupWindow_question] Message: question answer: FALSE

  2. #2
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Ableton Live 9 Lite crashes mid-install with PlayOnLinux

    Based on your error...

    There seems to be an installation error...
    - If the app binary exists, you can try executing it directly. The installer seems to not be able to find it
    - There might be more problems with the installation, so the above might not work (but should be tried)

    The problems seem to be very specific to this one application's Windows installer running in PlayOnLinux, so if the few suggested steps above don't work, you'd probably get better help in PlayOnLinux support.

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts