Results 1 to 8 of 8

Thread: 15 + vnc = no hair

  1. #1

    Default 15 + vnc = no hair

    Hi all: On a fresh install of Leap 15.0, I want to create a VNC server with which I view remotely and interact with the real X display. This sounds so easy, and it was, right up to 15.0. Does anyone have the steps to get this done? My system is stock Leap 15.0 installation using the gnome desktop, not kde. It has the firewall disabled for testing. I have tried vino but with no luck and the stock vnc implementation is meant for virtual sessions, not the real session displayed on the monitor.

    Thanks, much.

  2. #2
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    90

    Default Re: 15 + vnc = no hair

    I got mine working - the -auth file changed in leap 15 from previous versions in gnome - no idea about KDE

    as root on you Leap 15.0 machine you want to remote into:

    cd /etc/xinetd.d

    vi vnc and insert this

    # default: off
    # description: This serves out a VNC connection
    # of Display 0:0 with password
    service vnc
    {
    socket_type = stream
    protocol = tcp
    wait = no
    user = root
    server = /usr/bin/x11vnc
    server_args = -inetd -o /tmp/x11vnc.log -display :0 -auth /run/user/1000/gdm/Xauthority -noxrecord -noxfixes -noxdamage -rfbauth /etc/x11vnc.pass -rfbport 5900
    type = UNLISTED
    port = 5900
    disable = no
    }


    end of insert

    the server_args is one line up to the 5900

    change the 1000 to the id of the screen user ( grep the userid from /etc/passwd ) and /etc/x11vnc.pass is where your password is stored.

    when you have it correct

    chmod 644 vnc

    systemctl restart xinetd

    and try to connect to your Leap 15 computer via vnc

  3. #3

    Default Re: 15 + vnc = no hair

    larryr: Thanks for the replay. I set everything the way you have shown but no joy. tail of /var/log/messages shows the vnc service starting but then an error: "bad operator for attribute: /run/user/1000/gdm/Xauthority". The UID of my user account is 1000; it was the first one I set up. I changed the setting for the password location too and created the passwd file.

    Any idea what I did wrong?

  4. #4
    Join Date
    Jul 2018
    Location
    Loma Linda, Mo
    Posts
    90

    Default Re: 15 + vnc = no hair

    that auth is for gnome or MATE

    you need the one for KDE - it should be in your env not as root

    this is how I found mine

    ~> env | grep -i auth
    XAUTHLOCALHOSTNAME=VM1
    SSH_AUTH_SOCK=/run/user/1000/keyring/ssh
    XAUTHORITY=/run/user/1000/gdm/Xauthority
    ~>


    Hope this helps

  5. #5

    Default Re: 15 + vnc = no hair

    larryr. Thanks again. I am running gnome with SLE Classic. Could that be the issue? I have no problem moving to mate so maybe I should do that and try again.

    Quote Originally Posted by larryr View Post
    that auth is for gnome or MATE

    you need the one for KDE - it should be in your env not as root

    Hope this helps

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,706

    Default Re: 15 + vnc = no hair

    If the DM you have is SSDM it does not like remote logins change the the DM to something else

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,806
    Blog Entries
    14

    Default Re: 15 + vnc = no hair

    Quote Originally Posted by cmosentine View Post
    larryr. Thanks again. I am running gnome with SLE Classic. Could that be the issue? I have no problem moving to mate so maybe I should do that and try again.
    SLE's desktop setup differs from openSUSE, you might be better off in forums.suse.com
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: 15 + vnc = no hair

    Hi all: Thanks for all the replies. After several attempts I decided to start fresh and try a different method and it worked very well. I did this with gnome using the SLE Classic desktop. From a fresh installation:

    1. Install x0vncserver - this is a wrapper for tigervnc and it just shares an existing X server (typically, that one connected to the physical screen)
    2. Logged in as the user who will be always sharing the display, run vncpasswd to create the password file. This file is created at /home/username/.vnc/ and the file name is passwd
    3. Edit the file /home/username/.profile and add this line: x0vncserver -rfbauth /home/username/.vnc/passwd -rfbport 5901 &

    That is it. As long as the user remains logged in the x display will always be available. This works well for my use which is to use a headless computer from which we take the video output and run it into a video extender/replicator to display the same output to 6 TVs in the office. I just need the ability to vnc into the computer to manage it.

    Chris

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •