Results 1 to 4 of 4

Thread: Night Light turns on too early

  1. #1
    Join Date
    Jun 2014
    Location
    Bonn, Germany
    Posts
    67

    Default Night Light turns on too early

    Hi all,

    I just tried out the (not really) new Gnome Night Light, that shall reduce the blue parts in my monitor lights. It does this well, but, imho it turns on extremely early in the evening. I am in Germany, sun-set here today is around 9:30 pm, but Gnome Night Light already dims out the blue light at 5 pm, when the sun is shining brightly through my window. Is this behaviour to be expected? (I cross-checked that my time zone is set to Berlin, and my PC auto-detects the correct time, so this is probably not an issue.)
    If it is expected behaviour, is there a way I could tell Gnome to only switch on Night Light at maybe one hour before sun-set?

    Cheers,

    pbiel

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Night Light turns on too early

    Quote Originally Posted by pbiel View Post
    Hi all,

    I just tried out the (not really) new Gnome Night Light, that shall reduce the blue parts in my monitor lights. It does this well, but, imho it turns on extremely early in the evening. I am in Germany, sun-set here today is around 9:30 pm, but Gnome Night Light already dims out the blue light at 5 pm, when the sun is shining brightly through my window. Is this behaviour to be expected? (I cross-checked that my time zone is set to Berlin, and my PC auto-detects the correct time, so this is probably not an issue.)
    If it is expected behaviour, is there a way I could tell Gnome to only switch on Night Light at maybe one hour before sun-set?

    Cheers,

    pbiel
    Hi
    Is the BIOS (hwclock) time set to UTC? I always use UTC, then set timezone and select the checkbox for UTC. If it's a dual boot with say Windows, there is s registry tweak for UTC time.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3
    Join Date
    Jun 2014
    Location
    Bonn, Germany
    Posts
    67

    Default Re: Night Light turns on too early

    Is the BIOS (hwclock) time set to UTC?
    If I run # hwclock --show, I get the current local time and the correct time zone (CEST). I assume that's correct.

  4. #4
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    27,249
    Blog Entries
    15

    Default Re: Night Light turns on too early

    On Fri 18 May 2018 09:36:03 AM CDT, pbiel wrote:

    > Is the BIOS (hwclock) time set to UTC?

    If I run -# hwclock --show-, I get the current local time and the
    correct time zone (CEST). I assume that's correct.


    Hi
    I'm at CDT here, I have my BIOS set to UTC and ntp running, I see;
    Code:
    hwclock --show
    2018-05-18 08:27:38.888855-0500
    
    hwclock -l
    2018-05-18 13:27:40.670645-0500
    
    hwclock -u
    2018-05-18 08:27:44.435773-0500
    Localtime is UTC..... I tested nigh light last evening and it worked at
    the correct time, TW VERSION="20180516".

    --
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SLES 15 RC4 | GNOME Shell 3.26.2 | 4.12.14-18-default
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •