Results 1 to 2 of 2

Thread: zypper kann nicht auf MozillaFirefox-60.0-95.1.x86_64 updaten

  1. #1

    Default zypper kann nicht auf MozillaFirefox-60.0-95.1.x86_64 updaten

    Hallo zusammen,

    ich versuche derzeit erfolglos per "zypper up MozillaFirefox" den Firefox zu aktualisieren. Leider klappt das partout nicht und bricht mit folgendem Fehler ab:

    Problem: MozillaFirefox-60.0-95.1.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.23)(64bit), but this requirement cannot be provided
    uninstallable providers: libstdc++6-7.1.1+r248970-1.4.x86_64[repo-oss]
    libstdc++6-7.2.1+r253435-3.2.x86_64[repo-update-oss]
    libstdc++6-7.3.1+r258313-6.1.x86_64[repo-update-oss]
    libstdc++6-7.3.1+r258812-10.1.x86_64[repo-update-oss]
    Solution 1: deinstallation of libstdc++6-gcc6-6.2.1+r239768-6.19.x86_64
    Solution 2: do not install MozillaFirefox-60.0-95.1.x86_64
    Solution 3: break MozillaFirefox-60.0-95.1.x86_64 by ignoring some of its dependencies

    "zypper se -s MozillaFirefox" zeigt folgendes:

    S | Name | Type | Version | Arch | Repository
    ---+------------------------------------+------------+-------------+--------+------------------------------
    v | MozillaFirefox | package | 60.0-95.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    i+ | MozillaFirefox | package | 52.8.0-89.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.7.3-86.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.7.2-81.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.7-78.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.6-75.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.5.3-72.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.5.2-69.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.5.0-66.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.4.0-63.2 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.3.0-60.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox | package | 52.2-58.2 | x86_64 | openSUSE-Leap-42.3-Oss
    ...

    i | MozillaFirefox-branding-openSUSE | package | 45-14.1 | x86_64 | openSUSE-Leap-42.3-Oss
    ...

    v | MozillaFirefox-translations-common | package | 60.0-95.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    i+ | MozillaFirefox-translations-common | package | 52.8.0-89.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.7.3-86.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.7.2-81.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.7-78.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.6-75.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.5.3-72.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.5.2-69.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.5.0-66.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.4.0-63.2 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.3.0-60.1 | x86_64 | openSUSE-Leap-42.3-Update-Oss
    v | MozillaFirefox-translations-common | package | 52.2-58.2 | x86_64 | openSUSE-Leap-42.3-Oss
    ...

    "rpm -qa |grep glibc" zeigt folgendes:

    glibc-32bit-2.22-16.3.x86_64
    glibc-extra-2.22-16.3.x86_64
    linux-glibc-devel-4.4-5.4.noarch
    glibc-locale-2.22-16.3.x86_64
    glibc-i18ndata-2.22-16.3.noarch
    glibc-devel-2.22-16.3.x86_64
    glibc-locale-32bit-2.22-16.3.x86_64
    glibc-2.22-16.3.x86_64

    Dasselbe Problem habe ich seit 18.4.2018 auch mit dem Iridium-Browser:

    Problem: iridium-browser-2018.4.66.0-2.10.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.23)(64bit), but this requirement cannot be provided
    uninstallable providers: libstdc++6-7.1.1+r248970-1.4.x86_64[repo-oss]
    libstdc++6-7.2.1+r253435-3.2.x86_64[repo-update-oss]
    libstdc++6-7.3.1+r258313-6.1.x86_64[repo-update-oss]
    libstdc++6-7.3.1+r258812-10.1.x86_64[repo-update-oss]
    Solution 1: deinstallation of libstdc++6-gcc6-6.2.1+r239768-6.19.x86_64
    Solution 2: do not install iridium-browser-2018.4.66.0-2.10.x86_64
    Solution 3: break iridium-browser-2018.4.66.0-2.10.x86_64 by ignoring some of its dependencies

    Siehe https://github.com/iridium-browser/tracker/issues/206

    Was mache ich falsch?

    Danke und Grüße
    Thomas

  2. #2

    Default Re: zypper kann nicht auf MozillaFirefox-60.0-95.1.x86_64 updaten

    Mach das damit die aktuelle libstdc++6 (von gcc7) installiert werden kann:
    Quote Originally Posted by thomasmerz View Post
    Solution 1: deinstallation of libstdc++6-gcc6-6.2.1+r239768-6.19.x86_64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •