Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Firefox 60.0 ESR

  1. #1

    Default Firefox 60.0 ESR

    When doing "zypper lu" I saw only Firefox 52.8 ESR was available, instead of 60.0 ESR.
    For some reason I ended up doing "zypper up" anyways, and keep seeing a message from the Mozilla repository telling "the following packages are available but will not be installed" just before accepting and installing.

    Unfortunately I'm not in front of openSUSE box right now; all I can say and hope it's enough is, I have currently the Mozilla repository enabled:
    Code:
    2 | mozilla                   | mozilla                                 | Si         | (r ) Si          | Si         |   99      | rpm-md | http://download.opensuse.org/repositories/mozilla/openSUSE_Leap_42.3/
    But I thought Firefox ESR was already in openSUSE's repositories.

    Why is 60.0 ESR not available?
    Thanks beforehand.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,609
    Blog Entries
    3

    Default Re: Firefox 60.0 ESR

    I don't know the answer. But it is my impression that Mozilla released 52.8 ESR and 60.0 ESR at about the same time. So the 52.8 ESR is still an up-to-date release.

    I seem to recall that there was a reason to go with the ESR releases rather than the mainline firefox releases. And presumably that same reason applies for staying with the 52.x series for as long as possible.

    In any case, Leap 15.0 will be out soon, and it looks as if that will be using the mainline firefox versions. So I can wait another two weeks.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Firefox 60.0 ESR

    Code:
    zypper up
    does not do vendor changes the official LEAP version is 52.8 from the update repo
    I'm not sure if mozilla will kill the 52 branch or keep supporting it seeing how it was the last build that supports npapi plugins and old style addons also it was the last one that can be build without sse2 support for 32bit cpu's and for windows users the last one that can be installed on XP
    if you want Firefox 60 ESR or not use the versions tab from yast to install it or use the version number (or --from repo switch) to install it from zypper
    I'd say opensuse's future releases will depend on mozilla's decisions to keep 52.x or not

  4. #4

    Default Re: Firefox 60.0 ESR

    I just read ESR will still last until circa August with 52.9, and after that they'll drop the 52 series IIRC.

    Also, in the IRC channel some days ago I saw it was mentioned that Leap supposedly has switched to ESR for good from now on, so Leap 15 will ship with 60.0 ESR (or still the 52 series? No longer sure...).

    Thanks for your comments.

  5. #5
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,551

    Default Re: Firefox 60.0 ESR

    Quote Originally Posted by F_style View Post
    But I thought Firefox ESR was already in openSUSE's repositories.
    It is: <https://software.opensuse.org/package/MozillaFirefox>.

    And, it seems that a new 52.8.0 ESR patch is available for Leap 42.3; from the "Build Results" I'm not absolutely clear if this patch has been released or not:
    <https://build.opensuse.org/package/s...patchinfo.8076> (The "official update" URL at the left hand end of the Leap 42.3 entry.)
    - CVE-2018-5183: Backport critical security fixes in Skia
    - CVE-2018-5154: Use-after-free with SVG animations and clip paths
    - CVE-2018-5155: Use-after-free with SVG animations and text paths
    - CVE-2018-5157: Same-origin bypass of PDF Viewer to view protected PDF files
    - CVE-2018-5158: Malicious PDF can inject JavaScript into PDF Viewer
    - CVE-2018-5159: Integer overflow and out-of-bounds write in Skia
    - CVE-2018-5168: Lightweight themes can be installed without user interaction
    - CVE-2018-5178: Buffer overflow during UTF-8 to Unicode string conversion through legacy extension
    - CVE-2018-5150: Memory safety bugs fixed in Firefox 60 and Firefox ESR 52.8
    Quote Originally Posted by F_style View Post
    Why is 60.0 ESR not available?
    For Leap 42.3, it's in the openSUSE "Mozilla" « experimental packages » repository and, please take a look at the "Build results" at the right hand side of the Web-Page of the 2nd URL:
    <http://download.opensuse.org/reposit...4.2.x86_64.rpm>
    <https://build.opensuse.org/package/s...illa/firefox60> (The "mozilla" URL at the left hand end of the 1st '60.0' entry.)

  6. #6
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,975

    Default AW: Firefox 60.0 ESR

    Firefox 60 is in the Update-Test Repo and someone in IRC has said, it will delivered to the Update Repo on Friday, May 18th.
    http://download.opensuse.org/update/leap/42.3-test/
    Last edited by Sauerland; 16-May-2018 at 08:15.

  7. #7
    Join Date
    Nov 2013
    Location
    Kamloops, BC, Canada
    Posts
    3,974

    Default Re: Firefox 60.0 ESR

    Quote Originally Posted by nrickert View Post
    I don't know the answer. But it is my impression that Mozilla released 52.8 ESR and 60.0 ESR at about the same time. So the 52.8 ESR is still an up-to-date release.

    I seem to recall that there was a reason to go with the ESR releases rather than the mainline firefox releases. And presumably that same reason applies for staying with the 52.x series for as long as possible.

    In any case, Leap 15.0 will be out soon, and it looks as if that will be using the mainline firefox versions. So I can wait another two weeks.
    When they make that jump in ESRs, Mozilla has always overlapped the two versions for awhile. Both are current and supported, for now.
    -Gerry Makaro
    Fraser-Bell Info Tech
    Solving Tech Mysteries since the Olden Days!
    ~~
    If I helped you, consider clicking the Star at the bottom left of my post.

  8. #8
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,551

    Red face Re: Firefox 60.0 ESR

    Quote Originally Posted by dcurtisfra View Post
    For Leap 42.3, it's in the openSUSE "Mozilla" « experimental packages » repository and,
    I feel that, I may have to correct myself: the openSUSE Leap 42.3 "Mozilla" (experimental) repository may very well be the "vanilla" Firefox -- not the ESR version …

  9. #9
    Join Date
    Feb 2010
    Location
    Germany
    Posts
    2,551

    Exclamation Re: Firefox 60.0 ESR

    Please be aware that, today's (just now) openSUSE Leap 42.3 patch "openSUSE-2018-468" installs Mozilla Firefox 60.0 ESR.

    Please also be aware that, there's an incompatibility with the libstdc++6-gcc6 package which the KDE Plasma 5 System Tray "Updates" widget cannot resolve …
    I had to use the YaST "Online Update" dialogue to resolve the issue:
    Code:
    remove |libstdc++6-gcc6|6.2.1+r239768-6.19|x86_64|
    install|libstdc++6|7.3.1+r258812-10.1|x86_64|

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,609
    Blog Entries
    3

    Default Re: Firefox 60.0 ESR

    Quote Originally Posted by dcurtisfra View Post
    Please be aware that, today's (just now) openSUSE Leap 42.3 patch "openSUSE-2018-468" installs Mozilla Firefox 60.0 ESR.
    Interesting. So we are moving to 60 before Leap 15 comes out. Now I will have to see what that does to my extensions.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •