Results 1 to 3 of 3

Thread: Launcher Icon Not Displaying Correctly

  1. #1

    Default Launcher Icon Not Displaying Correctly

    Hi guys I installed texstudio today using yast but the launcher icon displays as the default purple diagonal square rather than the texstudio icon.

    I have tried going to the /usr/share/applications and inspecting the properties of textstudio desktop configuration file however when I select the texstudio.svg it has no effect - the icon does not change to the texstudio one.

    I am using Gnome 3.20.4 with Leap 42.3.

    Any help appreciated.

  2. #2

    Default Re: Launcher Icon Not Displaying Correctly

    I resolved this by uninstalling and reinstalling several times, however I had the same issue when trying to install Mendeley using the tar file provided from the website.

    Upon installation the mendeleydesktop.desktop file was places into .local/share/applications automatically but when I inspected it the icon pointed to an incorrect file.

    The issue was resolved by editing the file in vim so that Icon pointed to the png file that I wanted for the launcher.

    I presume this method will work for the other launchers that do not have the correct image, perhaps with super user for the ones installed to /usr/share/applications.

  3. #3
    Join Date
    Jun 2008
    San Diego, Ca, USA
    Blog Entries

    Default Re: Launcher Icon Not Displaying Correctly

    Don't forget to submit to the appropriate bug tracker for that project or app so that others behind you don't need to discover the fix themselves, and if you ever need to re-install it'll go smoother.

    Beginner Wiki Quickstart -
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts