Results 1 to 10 of 10

Thread: PHP 7.0.7 too old for librenms

  1. #1

    Default PHP 7.0.7 too old for librenms

    Hi,
    I'm a newbie and trying to install librenms. We've choosen OpenSuse LEAP 42.3 as OS for our linux servers. When I run the install for librenms, I get the following error :
    [...] requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.

    Is there a way to install the php version not yet officially released ? Perhaps lile installing another repo or something ?

    Like I said, I'm still learning linux, maybe this is very simple, but I need help

    Thanks,
    Alexandre Chevrier
    CSVT

  2. #2
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: PHP 7.0.7 too old for librenms

    This subforum is for questions about Installing and Booting openSUSE. There is an Applications sub-forum.

    From the LibreNMS documentation (https://docs.librenms.org/Installation/):
    Please note the minimum supported PHP version is 5.6.4
    Try pasting the error message inside CODE tags (use rhe # icon) so that id does not get mangled.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  3. #3

    Default Re: PHP 7.0.7 too old for librenms

    Hi,
    thanks for the fast reply ! The error I mentionned is part of the error message. I think it needs php 5.5.9 or 7.0.8... because of the |>= between the 2 versions. Here is the full error messages :

    #
    Problem 1
    - Installation request for symfony/console v3.4.8 -> satisfiable by symfony/console[v3.4.8].
    - symfony/console v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 2
    - Installation request for symfony/css-selector v3.4.8 -> satisfiable by symfony/css-selector[v3.4.8].
    - symfony/css-selector v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 3
    - Installation request for symfony/debug v3.4.8 -> satisfiable by symfony/debug[v3.4.8].
    - symfony/debug v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 4
    - Installation request for symfony/event-dispatcher v3.4.8 -> satisfiable by symfony/event-dispatcher[v3.4.8].
    - symfony/event-dispatcher v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 5
    - Installation request for symfony/finder v3.4.8 -> satisfiable by symfony/finder[v3.4.8].
    - symfony/finder v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 6
    - Installation request for symfony/http-foundation v3.4.8 -> satisfiable by symfony/http-foundation[v3.4.8].
    - symfony/http-foundation v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 7
    - Installation request for symfony/http-kernel v3.4.8 -> satisfiable by symfony/http-kernel[v3.4.8].
    - symfony/http-kernel v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 8
    - Installation request for symfony/process v3.4.8 -> satisfiable by symfony/process[v3.4.8].
    - symfony/process v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 9
    - Installation request for symfony/var-dumper v3.4.8 -> satisfiable by symfony/var-dumper[v3.4.8].
    - symfony/var-dumper v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    Problem 10
    - symfony/event-dispatcher v3.4.8 requires php ^5.5.9|>=7.0.8 -> your PHP version (7.0.7) does not satisfy that requirement.
    - influxdb/influxdb-php 1.14.5 requires symfony/event-dispatcher ^2.0 || ^3.0 || ^4.0 -> satisfiable by symfony/event-dispatcher[v3.4.8].
    - Installation request for influxdb/influxdb-php 1.14.5 -> satisfiable by influxdb/influxdb-php[1.14.5].
    #

    Since I was trying to install a newer version of php, I thought install forum was a better place, I'll use application next time if I have another "non-OS" post.

    Thanks.

  4. #4
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: PHP 7.0.7 too old for librenms

    Sorry the “|>” is not so common and I thought that the inclusion of “>” had been mangled in the conversion to HTML. you get the CODE tag by selecting some text in the forum composition pane, then clicking on the “#” icon above the edit space.

    Leap-15.0 will be officially released in two weeks and is very stable now. It includes PHP7-7.2.5. I //////////think that you should probably just install it now.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

  5. #5
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: PHP 7.0.7 too old for librenms

    Recommend upgrading your PHP to 5.6.
    You can do this by adding the PHP repo with the following command in an elevated console
    Code:
    zypper ar -f https://download.opensuse.org/repositories/devel:/languages:/php/openSUSE_Leap_42.3/ LEAP_42.3_PHP && zypper --gpg-auto-import-keys ref
    Or,
    You can use the one-click onstall on the following page, click on "Experimental repos" and then the first offering
    https://software.opensuse.org/package/php5

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  6. #6

    Default Re: PHP 7.0.7 too old for librenms

    Thanks, but 5.6 would be a downgrade ? I'll wait 2 weeks for the next release. Only thing I didn't understand is it's version 15.0. Don't know why it's the upgrade of 42.3.

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: PHP 7.0.7 too old for librenms

    Quote Originally Posted by alexchevrier View Post
    Thanks, but 5.6 would be a downgrade ? I'll wait 2 weeks for the next release. Only thing I didn't understand is it's version 15.0. Don't know why it's the upgrade of 42.3.
    The 42.x decision was made to have some way to follow SUSE's versioning, which was 12 at the time it was decided. We couldn't have 12 since we were already past that. The reason for somehow following SUSE's versioning was that SUSE released it's codebase to openSUSE ( which is still the case, Leap is ~⅓ SUSE under the hood ). Last year SUSE decided to skip 13 and 14 for mostly marketing reasons ( 13, in most of the western world is a 'bad' number, 14 in Asia ), so the new SUSE will be 15. After a long and elaborate discussion the devs and packagers suggested it would be easier to synchronize openSUSE's version to SUSE's, the marketing people agreed completely. So from here on we will have Leap 15, where the future Leap 15.3 will mean it shares the codebase with SUSE 15, Service Pack 3.

    Re. Leap 15: You could start to install it on one server, everything's frozen now, only bug-fixes will be added, but a normal update routine should have your server on Leap 15 on the 25th, the release date. I wouldn't hesitate FWIW
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: PHP 7.0.7 too old for librenms

    Thanks for the info, very interetsting. How could I install LEAP 15 on my server for librenms ? I can't find the download... I guess it's normal since it's not released and zypper dup doesn't show it... for the same reason I guess.

    Do I have to register to be a beta tester or something like that ?

  9. #9
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,288

    Default Re: PHP 7.0.7 too old for librenms

    No just download/install/and use

  10. #10
    Join Date
    Jun 2008
    Location
    Belleville, Ontario, Canada
    Posts
    503

    Default Re: PHP 7.0.7 too old for librenms

    Quote Originally Posted by alexchevrier View Post
    Thanks for the info, very interetsting. How could I install LEAP 15 on my server for librenms ? I can't find the download... I guess it's normal since it's not released and zypper dup doesn't show it... for the same reason I guess.

    Do I have to register to be a beta tester or something like that ?
    https://software.opensuse.org/distributions/testing
    "The time is always right to do what's right." Rev. Dr. Martin Luther King, Jr.
    openSUSE 15.3 5.3.18-59.40-default x86_64

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •