Results 1 to 4 of 4

Thread: openSUSE Leap 42.2 intel Atom system freeze with RS485 issue

  1. #1

    Default openSUSE Leap 42.2 intel Atom system freeze with RS485 issue

    I am hoping someone can help me, I have a problem with my baytrail processor and opensuse linux OS where time to time the system will freeze. I have done some research and I do know it is a common problem. I have read that the solution to fix this issue is to add this line into the grub file

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash intel_idle.max_cstate=1"
    I have implemented this line and amazingly it has worked. The only problem I am getting now is that once I have added the new line, a piece of hardware connected to the pc stops working. I have a radar which uses a RS485 com which sends some data to the pc and a program, however once I applied the line the program wouldn’t read any data. The previous line in the grub, before was this

    Code:
    Resume=/dev/sda2 splash=silent quiet showopts
    I’m hoping someone can help me determine why the radar fails when I add the line to fix the bug, or how to help me solve this problem
    Thank you

  2. #2
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    15,748

    Default Re: openSUSE Leap 42.2 intel Atom system freeze with RS485 issue

    You can have more then one option at a time. Why did you remove the old?

  3. #3

    Default Re: openSUSE Leap 42.2 intel Atom system freeze with RS485 issue

    Quote Originally Posted by gogalthorp View Post
    You can have more then one option at a time. Why did you remove the old?
    oh i have tried it like the code below as well as trying this solution http://qsupport.quantum.com/kb/flare...Power_Savi.htm
    however the radar hardware doesnt seem to work, or being read by the qt software. when i take out intel_idle.max_cstate=1 it can read the radar however my system freezes randomly

    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="Resume=/dev/sda2 splash=silent quiet showopts intel_idle.max_cstate=1"

  4. #4
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    11,306
    Blog Entries
    2

    Default Re: openSUSE Leap 42.2 intel Atom system freeze with RS485 issue

    1. Did you check whether power saving can be disabled in the BIOS? If a setting exists there, it should be preferred over a GRUB modification (You'd be managing your power settings at a lower level).

    2. How did you select the commands for disabling power? I did a simple Internet search for "Intel disable power save" and came up with at least a half dozen different recommended configurations(I stopped skimming results).

    3. openSUSE LEAP 42.2 reached EOL awhile ago. You should be installing 42.3 if you want stability, possibly Tumbleweed if you need very late release versions of components... trading off a little bit the stability of LEAP.

    4. You should run something like top to continuously monitor your system, and inspect your system logs (journalctl) to verify your system pauses relate to power saving (ie. is your system truly idling from inactivity when your system pauses?)

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •