Results 1 to 7 of 7

Thread: cannot play aac audio

  1. #1
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default cannot play aac audio

    Hello,

    I try to play a file from a radio station.
    In vlc it is vorking. VLC codec information - MPEG AAC Audio (mp4a).
    But, qmmp not play it. Only buffering and buffering.
    Clementine say that is missing a gstreamer-plugin.
    I installed all the codecs I know.
    It seems there is a codec that I miss it.

    Thank you.

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: cannot play aac audio


  3. #3
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: cannot play aac audio

    Thank you.
    I had installed all codecs except libxine2.
    With libxine2 clementine works now. Qmmp still buffering....

  4. #4
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: cannot play aac audio

    This one also:
    When done. Close the terminal. And open Yast > Software Management and Apply the Package Switcher on Packman.

    KDE: http://paste.opensuse.org/92222495

    Gnome: http://paste.opensuse.org/71856337

    If you encounter dependency errors: You need to accept changes that allow vendor switch to Packman If you can't work it out. Ask in the forum.

  5. #5
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,728

    Default AW: cannot play aac audio

    With libxine2 clementine works now.
    Clementine should not use libxine2.

    Only gstreamer.

  6. #6
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: cannot play aac audio

    I use "zypper dup --from 3". And "3" is packman respository.
    But qmmp is working now. I wait and after few minutes of buferring, buferring... it begin to work.
    Qmmp - not codec is to blame. I started qmmp from console. I think that "buffering" was the time who need to connect.

    Code:
    QmmpPluginCache: loaded plugin libhttp.so
    InputSource: using http transport
    StateHandler: Current state: Buffering; previous state: Stopped
    HttpStreamReader: starting download thread
    HttpStreamReader: starting libcurl
    *   Trying 80.86.106.143...
    * TCP_NODELAY set
    * Connected to 80.86.106.143 (80.86.106.143) port 9128 (#0)
    > GET /rockfm.aacp HTTP/1.0
    Host: 80.86.106.143:9128
    User-Agent: qmmp/1.2.1
    Accept: */*
    Icy-MetaData: 1
    
    * HTTP 1.0, assume close after body
    < HTTP/1.0 200 OK
    HttpStreamReader: header received
    < Server: Icecast 2.4.2
    HttpStreamReader: key=server, value=Icecast 2.4.2
    < Date: Thu, 10 May 2018 16:51:33 GMT
    HttpStreamReader: key=date, value=Thu, 10 May 2018 16:51:33 GMT
    < Content-Type: audio/aac
    HttpStreamReader: key=content-type, value=audio/aac
    < Cache-Control: no-cache
    HttpStreamReader: key=cache-control, value=no-cache
    < Expires: Mon, 26 Jul 1997 05:00:00 GMT
    HttpStreamReader: key=expires, value=Mon, 26 Jul 1997 05:00:00 GMT
    < Pragma: no-cache
    HttpStreamReader: key=pragma, value=no-cache
    < icy-br:32
    HttpStreamReader: key=icy-br, value=32
    < ice-audio-info: ice-bitrate=32;ice-samplerate=44100;ice-channels=2
    HttpStreamReader: key=ice-audio-info, value=ice-bitrate=32;ice-samplerate=44100;ice-channels=2
    < icy-br:32  
    HttpStreamReader: key=icy-br, value=32
    < icy-description:Live Streaming
    HttpStreamReader: key=icy-description, value=Live Streaming
    < icy-genre:Classic Rock
    HttpStreamReader: key=icy-genre, value=Classic Rock
    < icy-name:RockFM Romania
    HttpStreamReader: key=icy-name, value=RockFM Romania
    < icy-pub:0
    HttpStreamReader: key=icy-pub, value=0
    < icy-url:http://www.rockfm.ro  
    HttpStreamReader: key=icy-url, value=http://www.rockfm.ro
    < icy-metaint:16000
    HttpStreamReader: key=icy-metaint, value=16000
    <  
    HttpStreamReader: ready
    ';tpStreamReader: ICY metadata: StreamTitle='RockFM - PUB  
    AACFile: ADTS header found
    QmmpAudioEngine: selected decoder: aac
    AACFile: ADTS header found
    DecoderAAC: header offset = 327 bytes
    Decoder: using internal channel order
    DecoderAAC: initialize succes
    ReplayGain: disabled
    OutputWriter: [pulse] 44100 Hz, {FL,FR}, float ==> 44100 Hz, {FL,FR}, s16le
    Dithering: disabled
    StateHandler: Current state: Playing; previous state: Buffering
    ===== metadata ======
    ARTIST = RockFM
    TITLE = PUB  
    ALBUMARTIST =  
    ALBUM =  
    COMMENT =  
    GENRE = Classic Rock
    
    Sorry, now I see your new post.
    Clementine said that a gstreamer-plugin is missing. After I installed libxine2 it works.

  7. #7

    Default Re: cannot play aac audio

    Quote Originally Posted by another_roadrunner View Post
    Clementine said that a gstreamer-plugin is missing. After I installed libxine2 it works.
    I'm not sure how that's possible—as mentioned upthread, Clementine doesn't use libxine2.

    FWIW, I had the same problem, where M4A audio files with the Apple iTunes ALAC/AAC-LC codec were not playing with Clementine. My zypper was already configured to prefer packages from the Packman repository. Installing libxine2 did not fix the problem. What did fix it was installing gstreamer-plugins-bad-orig-addon from Packman.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •