Results 1 to 5 of 5

Thread: Update dependency missing for Chromium

  1. #1

    Default Update dependency missing for Chromium

    Hi there,

    I have just updated my Leap 42.2 to 42.3 and (having had to manually install the Nvidia drivers again (irritating it couldn't work out I needed to keep that one) I'm getting the following error when I try to do an update:

    chromium-66.0.3359.139-155.1.x86_64 requires libstdc++.so.6(GLIBCXX_3.4.23)(64bit), but this requirement cannot be provided

    Doe anyone know how I can go about getting this (and which repository I need to add using zypper or Yast)

    Many thanks in advance

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    6,727

    Default AW: Update dependency missing for Chromium

    Post:
    Code:
    zypper lr -d

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,676
    Blog Entries
    3

    Default Re: Update dependency missing for Chromium

    I have "chromium" installed, and it is the version you want. So it must be possible.

    You probably have some older software installed, that is incompatible with the latest libstdc++. And that older software is blocking needed updates.

    I suggest that you use Yast Software Management. Search for "libstdc++". Then try to update to the latest version. Yast will probably give a conflict. But the conflict message might tell you what software you have that is blocking the update.

    Note that you can always cancel out of Yast (instead of clicking "Accept"). The idea is to use it to investigate.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  4. #4
    Join Date
    Sep 2012
    Posts
    7,101

    Default Re: Update dependency missing for Chromium

    Code:
    zypper se --provides 'libstdc++.so.6(GLIBCXX_3.4.23)(64bit)'


    It is libstdc++6 which is included in standard repositories for Leap.

  5. #5

    Default Re: Update dependency missing for Chromium

    Thanks everyone.I managed to go online and find a 1click install for Chromium which worked, I had to ad another repo and also uninstall an old version of something

    For the record...here are my repos....anything here I'm missing for updates etc?

    https://paste.opensuse.org/47681473

    Thanks once again for the help guys

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •