Page 1 of 2 12 LastLast
Results 1 to 10 of 11

Thread: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

  1. #1

    Default I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Hello, I am running Leap 15.0 on my PC and I wanted to edit my /etc/mkinitcpio.conf file, in order to enable Early KMS start. Ultimately, I need to add the module i915 for the machine's Intel integrated graphics, via a Kernel mode setting wiki provided by Arch:

    /etc/mkinitcpio.conf

    Code:
    MODULES=(... i915 ...)

    (Then rebuild/regenerate initramfs)


    The problem, here, is that - on a nearly new openSUSE install - I do not have that /etc/mkinitcpio.conf file.

    Please advise!

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    The "mkinitcpio.conf" is part of how Arch systems build their "initrd". Opensuse uses "dracut" for that. Maybe try "/etc/dracut.conf" and "/etc/dracut.conf.d" (that last is a directory where you can put scripts). You may need to check the "dracut" documentation on what you need to enter there.

    (edit) using "lsinitrd" on Leap 42.3, it looks as if "i915.ko" is already there.
    Last edited by nrickert; 05-May-2018 at 13:56.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Hi @nrickert

    Thank you for responding. I will now try and figure out how to do what I am aiming for with the dracut.conf.d setup. I feel quite foolish having spent so much time trying to do it the Arch way. They have such a terrific wiki assortment - and I was thinking my situation, and hence their solution, was a Linux-wide thing.

    Have a good one!

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Start by using "lsinitrd" to see if it is already there.

    And, by the way, I agree that Arch has a great Wiki. I often use it.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Hi again, @nrickert

    Is there another way to see if i915 is there; the lsinitrd command caused a really verbose situation - where the terminal cut off all but the last 150 or so lines. I don't know why it would be altogether missing, but it nevertheless was not in that last part of the terminal output, to make good and sure.

    What the deal is, though, on my new install of Leap 15, I have a kernel/boot message which reads:
    PHP Code:
    systemd "Failed to start Setup Virtual Console." 
    I know that, sometimes, vconsole.conf does not set the keymap or font on a new install - which nearly invariably causes this console output - and indeed my journal says that the font is not set - at first - but then the journal shows it setting the font a second later. My hunch is that the Kernel Mode Setting (KMS) needs tweaking. You may know, KMS is usually initialized after the initramfs stage. However, the Arch wiki was talking about putting a configuration entry in that non-existent file we covered - showing the module i915, etc.

    I merely want to do the same thing with openSUSE via our initrd/dracut way.

    Well, anyhow, if you think I should make a new post, than I will - or maybe you or someone else has the magic answer.

    Either way, thanks for your patience today!
    Last edited by rtlewis1; 05-May-2018 at 19:07. Reason: Typo

  6. #6
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Quote Originally Posted by rtlewis1 View Post
    Is there another way to see if i915 is there; the lsinitrd command caused a really verbose situation - where the terminal cut off all but the last 150 or so lines.
    You can use:

    Code:
    lsinitrd > file
    to redirect the output to a file, and then examine that file.

    Or, use
    Code:
    lsinitrd | less
    which should allow you to scroll up and down or search. This is what I did, but redirecting to a file might be a better choice if you are not familiar with using "less".

    What the deal is, though, on my new install of Leap 15, I have a kernel/boot message which reads:
    PHP Code:
    systemd "Failed to start Setup Virtual Console." 
    You should probably use "CODE" rather than "PHP" in those tags, since it isn't PHP code. (What you used worked anyway).

    There's actually an open bug report for that failure. You can probably do a google search to find it or similar reports.

    I'm not sure whether it is a real problem. I regularly see that with Leap 15 (on my test system). But I mostly see it during shutdown. If I use CTRL-ALT-F1 to get to a virtual console, that seems to be fine.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  7. #7

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    @nrickert, hah, I know, the 10 minute cutoff for editing had already passed when I first noticed it the "PHP" versus "CODE" mistake. Your right, though, using CTRL-ALT-F1 works fine to get to a virtual console, and pressing Esc shows the startup process is muddling through perfectly.

    I first put 15.0 on one of my backup laptops right after it hit Beta stage - now the RC is on four of the family computers. It's wonderful to report back that, in all that time, this harmless kernel/boot annoyance is the only bug we exposed. Aside from having to get clever with a few off packages,15.0 has been our best Leap experience yet (we switched our GNOME and LXDE boxes from Debian-based distros to openSUSE back in the pre-Leap, Harlequin days). Anyway, thanks for the extra pointers - you have proven to be quite spontaneously wise, in the matters at issue. And lastly, so very sorry not to mention the Failed to start Setup Virtual Console thing, in the first place - I plan to leave it as is, now that you've explain it.

    ***PLEASE MARK SOLVED***

  8. #8
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    I agree with you about Leap 15.0. It sure seems to be very good.

    The main reason that I haven't yet switched, is that my main desktop is also a Samba server for the home network. So I have to get all of that setup before I switch.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  9. #9

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Okay, I found the fix:

    Simply do the following with Plymouth enabled:

    - modify /usr/lib/systemd/system/plymouth-start.service in order to have:

    Code:
    Wants=systemd-ask-password-plymouth.path
    IOW remove systemd-vconsole-setup.service from Wants=

    - regenerate the initrd with
    Code:
    mkinitrd
    - reboot and the failure message (along with associated journal fail messages) should be gone (with Plymouth enabled)


    Thank you Franck Bui via 'Comment #20' @ https://bugzilla.opensuse.org/show_bug.cgi?id=1055834

  10. #10
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: I need to enable 'Early KMS start' but do not have a '/etc/mkinitcpio.conf' file to edit

    Thanks for finding that.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •