Results 1 to 3 of 3

Thread: authorization problem with K3b

  1. #1
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Angry authorization problem with K3b

    Hello,

    I tried to burn a DVD today with k3b but it failed every time: the debug windows shows these messages
    Code:
    cdrecord
    -----------------------
    cdrecord: Operation not allowed. Warning: Cannot raise RLIMIT_MEMLOCK limits.
    cdrecord: Can't allocate memory. WARNING: Cannot do mlockall(2).
    cdrecord: WARNING: This causes a high risk for buffer underruns.
    cdrecord: Operation not allowed. WARNING: Cannot set RR-scheduler.
    cdrecord: Permission not granted. WARNING: Cannot set priority using setpriority().
    cdrecord: WARNING: This causes a high risk for buffer underruns.
    cdrecord: Insufficient 'file read' privileges. You will not be able to open all needed devices.
    cdrecord: Insufficient 'file write' privileges. You will not be able to open all needed devices.
    cdrecord: Insufficient 'device' privileges. You may not be able to send all needed SCSI commands, this my cause various unexplainable problems.
    cdrecord: Insufficient 'memlock' privileges. You may get buffer underruns.
    cdrecord: Insufficient 'priocntl' privileges. You may get buffer underruns.
    cdrecord: Insufficient 'network' privileges. You will not be able to do remote SCSI.
    scsidev: '/dev/sr1'
    devname: '/dev/sr1'
    scsibus: -2 target: -2 lun: -2
    my user is member of groups audio, users, lp, cdrom, video, disk and nobody

    If I run k3b from a root console it works without problem. So this seems to be an authorization problem

    apparmor is not running.

    Any idea?
    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

  2. #2
    Join Date
    Mar 2011
    Location
    Sauerland
    Posts
    3,982

    Default AW: authorization problem with K3b

    Post as User:
    Code:
    groups
    Have you changed the Permission as shown in the settings of k3b?

  3. #3
    Join Date
    Aug 2008
    Location
    Belgium
    Posts
    191

    Default Re: AW: authorization problem with K3b

    Thanks,

    Quote Originally Posted by Sauerland View Post
    Post as User:
    Code:
    groups
    Have you changed the Permission as shown in the settings of k3b?
    I forced the of permissions in the settings of K3b and now it works.
    Something has changed since the last time that I burned a DVD because it worked before.
    Don't know what changed but as far as I remember i never changed the K3b settings.
    I will note this for the next time

    Regards
    Philippe
    Tumbleweed (x86_64) Kernel 5.3.5 with KDE plasma

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •