Results 1 to 5 of 5

Thread: SSSD couldn't load the configuration database [22]: Invalid argument.

  1. #1

    Default SSSD couldn't load the configuration database [22]: Invalid argument.

    Hello all,

    I want to join my linux opensuse client to my ldap domain. but i am getting the problem that my sssd.service cannot start. i have looked in my journalctl and it says

    May 05 13:51:15 linux-mn7g systemd[1]: Starting System Security Services Daemon...
    May 05 13:51:15 linux-mn7g sssd[15839]: SSSD couldn't load the configuration database [22]: Invalid argument.
    May 05 13:51:15 linux-mn7g systemd[1]: sssd.service: Control process exited, code=exited status=4
    May 05 13:51:15 linux-mn7g systemd[1]: Failed to start System Security Services Daemon.
    May 05 13:51:15 linux-mn7g systemd[1]: sssd.service: Unit entered failed state.
    May 05 13:51:15 linux-mn7g systemd[1]: sssd.service: Failed with result 'exit-code'.

    how can I fix this?

    I have searched everything on google but that sadly didn't work. Please help me out.

    thanx

  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: SSSD couldn't load the configuration database [22]: Invalid argument.

    Before anything else,
    You should post whatever reference or guide you're following.
    A good starting point is the openSUSE LDAP documentation
    https://doc.opensuse.org/documentati...rity.ldap.html

    Most of the time,
    This error means that your Domain configuration isn't configured properly.

    Before anything else,
    Make sure that the User account already exists, in the Windows AD world supposedly it's possible to create a User on the fly when adding a machine, but I've never found that to be reliable.

    First thing to try...
    If you're manually modifying text files,
    Domains can be described a number of ways. Do not define as "User@Domain.suffix" -- Define as "User/Domain"
    As suggested in the following
    https://lists.fedorahosted.org/archi...SLRSIF426JXMS/

    As described in the following RHEL bug report,
    run "sssd config-check" to verify your config is bug-free.
    You should be able to do this no matter whether you use YaST or manually edit config files.
    https://bugzilla.redhat.com/show_bug.cgi?id=988207

    HTH,
    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Feb 2016
    Location
    Augusta, GA USA
    Posts
    31

    Default Re: SSSD couldn't load the configuration database [22]: Invalid argument.

    transformers1,
    The configuration database referenced could be the daemon configuration database itself (/var/lib/sss/db/config.ldb) or the/a domain database (/var/lib/sss/db/cache_<SSSD_DOMAIN_NAME>.ldb). The first happens rarely, the daemon reads the sssd.conf file and writes it to this db on startup, and the second usually happens when you switch between id mapping and non-id mapping modes for the daemon or have a mis-configured sssd.conf file.

    Shut down the daemon and delete one or all of the *.ldb files in the /var/lib/sss/db/ directory and restart the daemon. Let me know what happens.

    Deleting any or all of the cache files on a busy server in large environments would not be the first attempt at resolution normally, but it sounds like you are just getting started with the daemon, so, meh.

    If you still have issues after deleting the cache files post your sssd.conf and your nsswitch.conf and we'll go from there.


    Hope it helps,


    -- lawrence
    Lawrence Kearney
    http://www.lawrencekearney.com
    https://www.thettp.org

  4. #4

    Default Re: SSSD couldn't load the configuration database [22]: Invalid argument.

    How do you configure your ldap client?

    My experience is to configure ldap client with User Logon Management instead of LDAP and Kerberos Client through YaST.

    But I'm connecting to OpenLDAP server.

  5. #5
    Join Date
    Feb 2016
    Location
    Augusta, GA USA
    Posts
    31

    Default Re: SSSD couldn't load the configuration database [22]: Invalid argument.

    jiunnyik,
    This is considered a thread hijack I think :-) . If the conversation continues it would likely be best for you to start another thread with a subject line that describes the query better.

    The YaST User Logon Module is still how you would access an openLDAP back end, using the SSSD LDAP providers. Provide the same configuration information you would to configure the pam_ldap and/or pam_krb5 modules (as is still done via the
    LDAP and Kerberos Client through YaST). This will configure the NSCD as opposed to the SSSD.

    You cannot run them both of course and I prefer the SSSD myself :-) .


    -- lawrence
    Lawrence Kearney
    http://www.lawrencekearney.com
    https://www.thettp.org

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •