Results 1 to 4 of 4

Thread: Baloo extreme CPU usage

  1. #1

    Default Baloo extreme CPU usage

    Ever so often I get one of these processes utilising 100% of one CPU core:
    baloo_file_extractor
    baloo_file

    There was a baloo_runner as well, but I might have been on openSUSE 42.3 machine and not the TW.

    Kinfo File Indexer Monitor says that indexer is idle, but balooctl says the indexer is running.

    Executing
    Code:
    sudo balooctl stop
    does not kill either process.

    I do want file to be indexed for search purposes, but is there a way to make the indexing less aggressive? Having one core at 100% utilisation heats up the CPU and fan noise (fan doesn't even kick in under normal usage, when indexer is not running) is getting at me.

  2. #2

    Default Re: Baloo extreme CPU usage

    Quote Originally Posted by RaveNBlack View Post
    Executing
    Code:
    sudo balooctl stop
    does not kill either process.
    Baloo runs as the logged in user, not root.

    So do *not* use sudo!

    I do want file to be indexed for search purposes, but is there a way to make the indexing less aggressive?
    It shouldn't be that aggressive normally.
    Maybe it has problem with a certain file. You can exclude specific directories from indexing in its settings.

    OTOH, a corrupt database can cause something like this, a seemingly similar problem has been fixed recently:
    https://cgit.kde.org/baloo.git/commi...0bb531cd8472c6

    So try to delete ~/.local/share/baloo/ to recreate the index from scratch.

  3. #3

    Default Re: Baloo extreme CPU usage

    Hi,

    running
    Code:
    balooctl stop
    without root would kill the processes either.

    Anyway, I've deleted ~/.local/share/baloo/, manualy killed baloo processes, run
    Code:
    balooctl start
    followed by
    Code:
    balooctl monitor
    baloo_file_extractor does jump to 100% utilisation of one CPU core, but it is not constantly at 100%. Also, "balooctl monitor" now show what files it has indexed, whereas before deleting
    ~/.local/share/baloo/ monitoring would not show anything, just say "press ctrl+c to stop monitoring" or something along the lines.

    Will see what happen after it re-indexes my SSD.

  4. #4

    Thumbs up Re: Baloo extreme CPU usage

    Deleting database and re-indexing everything seems to have worked. I've even saved about 3GB of space. Hopefully Baloo DB corruption will not occur every other week as reindexing does take some time to complete.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •