Results 1 to 4 of 4

Thread: XFCE firewall applet asking for root password

  1. #1

    Question XFCE firewall applet asking for root password

    XFCE is asking me for root password each time I login to the desktop environment and on each firewalld restart.

    Is that normal? If not - how can I fix it?

    I suppose it is some kind of policy that needs to be set but I couldn't find any specific documentation.

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: XFCE firewall applet asking for root password

    I just logged into XFCE. I was not prompted for the root password.

    So I guess it is not normal.

    I normally don't restart firewalld, but I'm not surprised that requires root.

    The root prompt is probably from a program that you have running, that is automatically restarted when you login.

    I see thata there's a firewall applet. Perhaps you are running that, and perhaps that is requesting root.
    openSUSE Leap 15.1; KDE Plasma 5;

  3. #3

    Default Re: XFCE firewall applet asking for root password

    Quote Originally Posted by nrickert View Post
    Perhaps you are running that, and perhaps that is requesting root.
    Yes, as per title. And the dialog says:

    System policy prevents getting general firewall information.

    An application is attempting to perform an action that requires privileges. Authentication as the super user is required to perform this action.

    Password for root: ______________

    Details
    Action: org.fedoraproject.FirewallD1.info
    Vendor: FirewallD
    I suppose this may need some kind of policy configuration for this particular action but I have no idea how to do it and what would be the proper way to it.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,370
    Blog Entries
    3

    Default Re: XFCE firewall applet asking for root password

    I installed firewall-applet. I still did not have a problem of XFCE. If I click on firewall-applet, I am asked for root password.

    I did not try clicking on firewall-applet in XFCE. Perhaps it remembers, and wants to do everytime.

    My suggestion: uninstall firewall-applet, and see if the problem goes away. You can reinstall after the test, if you still want it.
    openSUSE Leap 15.1; KDE Plasma 5;

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •