Results 1 to 8 of 8

Thread: NAS share in office network makes long timeout in other networks

  1. #1
    Join Date
    Jul 2010
    Location
    Czech Republic
    Posts
    7

    Default NAS share in office network makes long timeout in other networks

    Hi;

    I am facing problems with long timeout when operating files (even those locally stored) in my home network (no shares, just wifi connection). I guess this might be caused by autofs set to mount NAS share (CIFS) located in my office network (works as a charm in the office network). Is there any chance to shorten timeouts in case autofs cannot find the specified mountpoint? I went through autofs man pages; could --negative-timeout <seconds> be the solution?

    I cannot present openSUSE due to this out of office as anybody might think the system is incredibly slow. So as it is annoying.

    Thanks in advance for any tips

  2. #2

    Default Re: NAS share in office network makes long timeout in other networks

    Look in /etc/auto.master

    For example if you are mounting the shares under /mnt there should be a line like (mnt is probably a bad example directory to use, but I don't generally do this so modify as needed):

    /mnt /etc/auto.misc --timeout 60
    Then your /etc/auto.misc should contain the appropriate line as well.

    Just set the timeout lower (3 or 6 sec depending upon the speed of your office network?)

  3. #3
    Join Date
    Jul 2010
    Location
    Czech Republic
    Posts
    7

    Default Re: NAS share in office network makes long timeout in other networks

    Quote Originally Posted by d3vnull View Post
    Look in /etc/auto.master

    For example if you are mounting the shares under /mnt there should be a line like (mnt is probably a bad example directory to use, but I don't generally do this so modify as needed):

    /mnt /etc/auto.misc --timeout 60
    Then your /etc/auto.misc should contain the appropriate line as well.

    Just set the timeout lower (3 or 6 sec depending upon the speed of your office network?)
    Thank you d3vnull. Isn't the timeout setting meaning the time to umount unused share? My current timeout=10.

  4. #4

    Default Re: NAS share in office network makes long timeout in other networks

    You can try MOUNT_WAIT in /etc/sysconfig/autofs - I got that from:

    Code:
    man auto.master
    Quote Originally Posted by kriskami View Post
    Thank you d3vnull. Isn't the timeout setting meaning the time to umount unused share? My current timeout=10.

  5. #5

    Default Re: NAS share in office network makes long timeout in other networks

    The other question is have you disabled autofs away from the office to determine that is the "real" issue?

    Code:
    systemctl disable autofs.service
    systemctl stop autofs.service

  6. #6
    Join Date
    Jul 2010
    Location
    Czech Republic
    Posts
    7

    Default Re: NAS share in office network makes long timeout in other networks

    Quote Originally Posted by d3vnull View Post
    The other question is have you disabled autofs away from the office to determine that is the "real" issue?

    Code:
    systemctl disable autofs.service
    systemctl stop autofs.service
    Oh no, I haven't. I'll try at home together with --master-wait <seconds> parameter. I'll let you know. Thanks

  7. #7
    Join Date
    Jul 2010
    Location
    Czech Republic
    Posts
    7

    Default Re: NAS share in office network makes long timeout in other networks

    Quote Originally Posted by kriskami View Post
    Oh no, I haven't. I'll try at home together with --master-wait <seconds> parameter. I'll let you know. Thanks
    A) active autofs does that issue
    B) --master_wait=3 does the trick (I can go through local filesystem without lagging now)

    That means big Thank you! for your assistance ...

  8. #8
    Join Date
    Jul 2010
    Location
    Czech Republic
    Posts
    7

    Default Re: NAS share in office network makes long timeout in other networks

    Quote Originally Posted by kriskami View Post
    A) active autofs does that issue
    B) --master_wait=3 does the trick (I can go through local filesystem without lagging now)

    That means big Thank you! for your assistance ...
    Arrrgh; doesn't mount the share in the office network. Seems the only workaround is manually stop autofs in terminal when changing networks ...

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •