Results 1 to 7 of 7

Thread: SSH connection Faild

  1. #1

    Default SSH connection Faild

    Hello There Linux specialists,

    a have set up a linux server with ssh and enabled port 22 by going in to the /etc/ssh/sshd_config file and changed the PasswordAuthorzed form no to yes.

    But when i still try to login from my client computer to the server, the only message i get is this: "Permission denied (Publickey,keyboard-interactive).

    does someone know what is going on.

    Thanx

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: SSH connection Faild

    Quote Originally Posted by transformers1 View Post
    Hello There Linux specialists,

    a have set up a linux server with ssh and enabled port 22 by going in to the /etc/ssh/sshd_config file and changed the PasswordAuthorzed form no to yes.

    But when i still try to login from my client computer to the server, the only message i get is this: "Permission denied (Publickey,keyboard-interactive).

    does someone know what is going on.

    Thanx
    Hi, welcome

    Did you use the YaST module to setup SSH? If not, make sure you use YaST's firewall module to open the SSH port.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: SSH connection Faild

    Let's get some additional output. Clearly your client seems to be able to
    connect (the error is an SSH error) but perhaps something else is not
    working properly. The ssh client can give you a lot of debugging output:

    Code:
    ssh -vvv user@server.goes.here
    Of course, make sure you are not using 'root', or if you are that you also
    change 'PermitRootLogin' to 'yes' (and uncomment it) if it is set to 'no'.
    Better yet, test with a user other than 'root' since you s build really
    not allow direct SSH access via 'root' with a password.

    --
    Good luck.

    If you find this post helpful and are logged into the web interface,
    show your appreciation and click on the star below.

    If you want to send me a private message, please let me know in the
    forum as I do not use the web interface often.

  4. #4
    Join Date
    Jul 2008
    Location
    Seattle, WA
    Posts
    17,317

    Default Re: SSH connection Faild

    On Wed, 02 May 2018 16:06:02 +0000, transformers1 wrote:

    > Hello There Linux specialists,
    >
    > a have set up a linux server with ssh and enabled port 22 by going in to
    > the /etc/ssh/sshd_config file and changed the PasswordAuthorzed form no
    > to yes.
    >
    > But when i still try to login from my client computer to the server, the
    > only message i get is this: "Permission denied
    > (Publickey,keyboard-interactive).
    >
    > does someone know what is going on.


    IIRC, you need to restart sshd in order to have changes to the config
    take effect - did you restart the daemon?



    --
    Jim Henderson
    openSUSE Forums Administrator
    Forum Use Terms & Conditions at http://tinyurl.com/openSUSE-T-C

  5. #5

    Default Re: SSH connection Faild

    Quote Originally Posted by Knurpht View Post
    Hi, welcome

    Did you use the YaST module to setup SSH? If not, make sure you use YaST's firewall module to open the SSH port.
    Hello, and yes i did setup the firewall settings to allow ssh. but it stil give me the same error

  6. #6

    Default Re: SSH connection Faild

    Mine is a default ssh configuration. All I did was:

    Code:
    systemctl enable sshd.service
    systemctl start sshd.service
    I opened the port on the correct interface on the firewall.

    Code:
    kvm:~ # grep 'PasswordAuthentication' /etc/ssh/sshd_config 
    PasswordAuthentication no
    # PasswordAuthentication.  Depending on your PAM configuration,
    # PAM authentication, then enable this but set PasswordAuthentication
    kvm:~ #
    From another system I was able to ssh in as root, asccept the fingerprint, and login with a password.

    I could do the same as root from the localhost:

    Code:
    kvm:~/.ssh # ssh localhost
    The authenticity of host 'localhost (127.0.0.1)' can't be established.
    ECDSA key fingerprint is SHA256:jTjTrRnkeChX/euzbVHrJ7xHJ368VmKGToIVbC8oX2M.
    Are you sure you want to continue connecting (yes/no)? yes
    Warning: Permanently added 'localhost' (ECDSA) to the list of known hosts.
    Password: 
    Last login: Thu May  3 02:37:35 2018 from 10.0.0.1
    Have a lot of fun...
    kvm:~ #
    My guess is following the debug instructions above will show you that you have a host key issue.

    I would change the value back to no and follow these instructions if it is keys:

    http://www.softec.lu/site/Developers...generateNewSsh

  7. #7
    Join Date
    Oct 2008
    Location
    Glasgow, Scotland
    Posts
    1,277

    Default Re: SSH connection Faild

    This is not an Install or Boot issue.

    From a query from the same poster in the Networking sub-forum (which was an installation question) this problem is probably with an MS Windows client. We are given no information about the client configuration -- it could be something like trying to use a deprecated protocol.
    --
    slàinte mhath,
    rayH

    ~ knowing the right answer is easier than knowing the right question.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •