Page 1 of 2 12 LastLast
Results 1 to 10 of 14

Thread: Dolphin not showing free space on samba share

  1. #1
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Dolphin not showing free space on samba share

    Hi all, does anybody know why dolphin does/can not show free space available on samba shares and nautilus and nemo can?
    What does dolphin do differently than nautilus or nemo?
    Do those file managers use different backends to get this information?

    I am running this on tumbleweed, but it is the same in leap 15.


  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: Dolphin not showing free space on samba share

    "Vrije ruimte" . And what if you refresh it a couple of times? Otherwise I'd report a bug at bugzilla.opensuse.org
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by Knurpht View Post
    And what if you refresh it a couple of times?
    Refreshing doesn't change anything.
    Still looking to find how those programs get their information about samba shares.
    I'm not running a samba server on the desktop machine, but samba is installed.

    And i do not see anything on the commandline when i run dolphin from a terminal, so i could file a bug report, but it will be a vague one.
    So i'm still trying to find out more myself first.

  4. #4
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by Knurpht View Post
    Otherwise I'd report a bug at bugzilla.opensuse.org
    OK, i think i'll report a bug, but will the infomation i provided here be enough?

  5. #5

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by Knurpht View Post
    Otherwise I'd report a bug at bugzilla.opensuse.org
    I somehow doubt that this would be an openSUSE specific problem, better report it at bugs.kde.org.

    Actually this is probably more a (missing) upstream "feature".
    KDE Frameworks/Plasma/Dolphin don't actually mount a share (they access it "directly"), and that's the big difference to e.g. Nautilus.
    Last edited by wolfi323; 03-May-2018 at 05:22.

  6. #6

    Default Re: Dolphin not showing free space on samba share

    Hm, dolphin does correctly show the free space for Samba shares here though...
    (Leap 42.3 with latest Qt5/KF5/KDE Applications)

  7. #7
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by wolfi323 View Post
    KDE Frameworks/Plasma/Dolphin don't actually mount a share (they access it "directly"), and that's the big difference to e.g. Nautilus.
    Thank you so much!!
    So now i'm learning how to make a mount entry in fstab for my shares.

    I managed to make it mount at boot and now dolphin can show the free space available!
    But i cannot alter file on the share, only root can.

    This is my fstab entry:
    Code:
    //192.168.1.88/USB_Storage  /mnt/readyshare cifs user=blabla,password=blablabla,users,auto    0 0
    What do i need to change there to allow me on my useraccount to alter files on the share?
    But again, thank you for pointing me in the right direction!

  8. #8
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by Operius View Post
    But i cannot alter file on the share, only root can.

    This is my fstab entry:
    Code:
    //192.168.1.88/USB_Storage  /mnt/readyshare cifs user=blabla,password=blablabla,users,auto    0 0
    What do i need to change there to allow me on my useraccount to alter files on the share?
    First i thought, could it be so simple to change the permissions on /mnt/readyshare?
    No, that didn't work.

    And now i learned that i can change/add/remove files in the root folder of the share, but not in the subfolders.
    I hoped that it would behave like a local folder, but it doesn't

  9. #9

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by Operius View Post
    What do i need to change there to allow me on my useraccount to alter files on the share?
    Maybe the uid mount option would help?
    From "man mount.cifs":
    uid=arg
    sets the uid that will own all files or directories on the mounted
    filesystem when the server does not provide ownership information. It
    may be specified as either a username or a numeric uid. When not
    specified, the default is uid 0. The mount.cifs helper must be at
    version 1.10 or higher to support specifying the uid in non-numeric
    form. See the section on FILE AND DIRECTORY OWNERSHIP AND PERMISSIONS
    below for more information.

    (maybe together with "forceuid"...)

    Or maybe you'd need to mount it as user. You'd need to replace "auto" with "noauto" though.

    Btw, you can also browse and mount shares with smb4k, available in the KDE:Extra repo. IIRC, that can also automatically remount shares on login.

  10. #10
    Join Date
    Sep 2010
    Location
    The Netherlands
    Posts
    114

    Default Re: Dolphin not showing free space on samba share

    Quote Originally Posted by wolfi323 View Post
    Maybe the uid mount option would help?
    Yes that was all i needed to add to the entry!

    Code:
    //192.168.1.88/USB_Storage  /mnt/readyshare cifs user=blabla,password=blablabla,uid=chris,users,auto    0 0

    Thanks everybody for helping me with this!

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •