Results 1 to 6 of 6

Thread: PUTTY and Tumbleweed

  1. #1

    Default PUTTY and Tumbleweed

    Hello.
    My putty not work after dup to VERSION_ID="20180425" of the Tumbleweed now.
    while a connection I see a window with text: Disconnected: No supported authentication methods available (server sent: publickey,keyboard-interactive)

    but I can connect by ssh with my key to any servers.

    nick@STRELKA:~> ssh 172.25.0.222
    Last login: Sun Apr 29 16:11:05 2018 from 172.25.0.225
    Have a lot of fun...
    nick@172.25.0.222~> exit

    nick@STRELKA:~> putty -log log -ssh -i .ssh/id_rsa 172.25.0.222 ; cat log
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2018.04.29 16:50:57 =~=~=~=~=~=~=~=~=~=~=~=
    Unable to use key file ".ssh/id_rsa" (OpenSSH SSH-2 private key (old PEM format))
    Using username "nick".
    nick@STRELKA:~> putty -log log -ssh 172.25.0.222 ; cat log
    =~=~=~=~=~=~=~=~=~=~=~= PuTTY log 2018.04.29 16:51:26 =~=~=~=~=~=~=~=~=~=~=~=
    Using username "nick".

    Please, help.
    Nick

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: PUTTY and Tumbleweed

    Are you trying to use a DSA key for authentication? As far as I know, recent "openssh" releases have deprecated DSA keys.

    I'm assuming that this is PuTTY from Windows (there's also a linux port of PuTTY).
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  3. #3
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: PUTTY and Tumbleweed

    I've just tested this.

    PuTTY running on Windows 7. I used a DSA key. I was able to login to openSUSE Leap 42.3. But I got an authentication failure when I tried to login to openSUSE Tumbleweed (snapshot 20180406).

    I then added an RSA key to PuTTY, and was able to login without a problem.

    This was a relatively recent change to Tumbleweed -- probably within the last 2 months. You can maybe check history to see when "openssh" was last updated.

    Obviously, you will need to create a new key for PuTTY, using an authentication method other than DSA.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  4. #4

    Default Re: PUTTY and Tumbleweed

    Thanks, but I use rsa. Ok, I've made a new keys, but result is the same. I've tryed with different servers, it was Centos7, Tumbleweed. The client is a last Tumbleweed. I've not made any keys by the putty, it has got id-rsa key file from my .ssh dir. But after last update of Tumbleweed the putty is not connect. It was worked yesterday. The problem started after the update. Please check my example, the ssh is work fine now. I will check an update history...
    I think, the putty is nonchanged... Yet, I've got and successfully compiled last putty from it site, the result is the same. :-(

  5. #5
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    12,641
    Blog Entries
    3

    Default Re: PUTTY and Tumbleweed

    My keys are all originally openssh keys, imported to PuTTY. So that's not the issue.

    Check permissions very carefully. And check "sshd_config" on Tumbleweed. In my experience, "sshd" is fussy about permissions. The ".ssh" directory must be owned by either the user (i.e. you) or by root, and must not be group writable or other writable. And the authentication config in "sshd_config" must allow the kind of authentication that you are using.

    There's a log option in Putty. Maybe you can use that to get a better idea on what is going wrong.
    openSUSE Leap 15.1; KDE Plasma 5;
    testing Leap 15.2Alpha

  6. #6

    Default Re: PUTTY and Tumbleweed

    Thank you very much!

    SOLVED! The problem is a changing of /etc/X11/xinit/xinitrc file. Some update rewrite the file to new file with commented

    if test -S "$SSH_AUTH_SOCK" -a -x "$SSH_ASKPASS"; then
    ssh-add < /dev/null
    fi

    strings.

    The update save xinitrc.rpmsave file with uncommented important strings.

    Nick

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •