Page 1 of 2 12 LastLast
Results 1 to 10 of 18

Thread: wpa_passphrade with wicked

  1. #1

    Default wpa_passphrade with wicked

    I need to utilize wicked to manage my wireless, instead of network manager. I know that what I am attempting works under network manager, but fails under the ifcfg-wlan0 file in wicked.

    Let's say I run wpa_passphrase myssid mypassword
    It returns:

    network={
    ssid="myssid"
    #psk="mypassword"
    psk=2f0568b3492812bd56b946dbaf3fd7dd669b9a4602a09aa6462ff057949b025c
    }

    According tyo the manpage for ifcfg-wireless:
    WIRELESS_WPA_PSK
    When using WPA-PSK authentication, you need to specify your pre-
    shared key here. The key is used for authentication and encryp-
    tion purposes. You can enter it in hex digits (needs to be
    exactly 64 digits long) or as passphrase getting hashed (8 to 63
    ASCII characters long).

    If I use this line in my ifcfg-wlan0 it connects correctly:
    WIRELESS_WPA_PSK='mypassword'

    If I use:
    WIRELESS_WPA_PSK='2f0568b3492812bd56b946dbaf3fd7dd669b9a4602a09aa6462ff057949b025c'
    or
    WIRELESS_WPA_PSK=2f0568b3492812bd56b946dbaf3fd7dd669b9a4602a09aa6462ff057949b025c
    the connection fails.

    I am running LEAP 42.3 fully patched.

    Any help is greatly appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: wpa_passphrade with wicked

    Use YaST's Networksettings module. Tick the networkdevice you want to configure and follow the steps, you'll be able to select your SSID, set the security to WPA2 and enter the passphrase.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3

    Default Re: wpa_passphrade with wicked

    Yes, that is how I set it up originally. Duh...I missed where you can put the HEX key in. Thanks for the obvious kick in the right direction.I will try that and respond if it fails.

  4. #4
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: wpa_passphrade with wicked

    Quote Originally Posted by d3vnull View Post
    Yes, that is how I set it up originally. Duh...I missed where you can put the HEX key in. Thanks for the obvious kick in the right direction.I will try that and respond if it fails.
    There's an option to enter HEX instead of passphrase, quite at the bottom part of the screen.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  5. #5

    Default Re: wpa_passphrade with wicked

    So, I tried entering the hex key through yast and it still fails. My syntax in ifcfg-wlan0 was correct. I'm at a loss on why it does not like the hex key generated by wpa_passphrase.

  6. #6

    Default Re: wpa_passphrade with wicked

    Anybody running a laptop with wireless willing to try using wicked to manage their wireless NIC and see if entering the HEX key in yast fails or succeeds for them?

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,664
    Blog Entries
    3

    Default Re: wpa_passphrade with wicked

    Quote Originally Posted by d3vnull View Post
    Anybody running a laptop with wireless willing to try using wicked to manage their wireless NIC and see if entering the HEX key in yast fails or succeeds for them?
    I will try that experiment later today.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: wpa_passphrade with wicked

    Hi, I tested this on my Tumbleweed machine, and the HEX entry works fine, so my guess is that you made a mistake in the passphrase. FWIW, works both in wicked and in Networkmanager.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  9. #9

    Default Re: wpa_passphrade with wicked

    Thank you for testing. I will keep digging now that I know it is on my end.

    Quote Originally Posted by Knurpht View Post
    Hi, I tested this on my Tumbleweed machine, and the HEX entry works fine, so my guess is that you made a mistake in the passphrase. FWIW, works both in wicked and in Networkmanager.

  10. #10
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: wpa_passphrade with wicked

    I have to correct myself here. The file does not contain 'WIRELESS_WPA_PSK', but rather
    Code:
    [wifi-security]
    key-mgmt=wpa-psk
    psk=THE_HEX_NUMBER
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •