Results 1 to 8 of 8

Thread: Unable to boot to Windows after opensuse installation

  1. #1

    Lightbulb Unable to boot to Windows after opensuse installation

    I'm a newbie to Linux. Also its my first thread post.
    I just triple booted my laptop and installed opensuse leap 42.3. Previously had windows 10 and ubuntu running together.
    Now after installing opensuse the grub does not detect windows 10 and hence I am unable to boot into windows.
    all the partitions are safe.

    some important points:

    Ive tried updating grub(using yast).
    In grub.cfg there's no entry for windows.
    There's no /efi directory in /boot.
    Here's what i get after "fdisk -l"

    Code:
    linux-g5l3:/boot/grub2 # fdisk -l
    Disk /dev/sda: 1.8 TiB, 2000398934016 bytes, 3907029168 sectors
    Units: sectors of 1 * 512 = 512 bytes
    Sector size (logical/physical): 512 bytes / 4096 bytes
    I/O size (minimum/optimal): 4096 bytes / 4096 bytes
    Disklabel type: gpt
    Disk identifier: 1AC56D18-7CC8-45DD-819C-C9C274F02673                                                                                
                                                                                                                                         
    Device          Start        End    Sectors   Size Type                                                                              
    /dev/sda1        2048    1026047    1024000   500M BIOS boot                                                                         
    /dev/sda2     1026048    1107967      81920    40M unknown                                                                           
    /dev/sda3     1107968    1370111     262144   128M Microsoft reserved                                                                
    /dev/sda4     1370112    2906111    1536000   750M Windows recovery environment                                                      
    /dev/sda5     2906112  735097341  732191230 349.1G Microsoft basic data                                                              
    /dev/sda6   735098880  736923647    1824768   891M Windows recovery environment                                                      
    /dev/sda7   736923648 1788129279 1051205632 501.3G Microsoft basic data                                                              
    /dev/sda8  1788129280 2734473215  946343936 451.3G Microsoft basic data                                                              
    /dev/sda9  2839332864 3741638655  902305792 430.3G Microsoft basic data                                                              
    /dev/sda10 3890538496 3907027119   16488624   7.9G Windows recovery environment                                                      
    /dev/sda11 2734473216 2764472319   29999104  14.3G Linux filesystem                                                                  
    /dev/sda12 2764472320 2780473343   16001024   7.6G Linux swap                                                                        
    /dev/sda13 2780473344 2839332863   58859520  28.1G Linux filesystem                                                                  
    /dev/sda14 3741638656 3741667327      28672    14M BIOS boot                                                                         
    /dev/sda15 3741667328 3801219071   59551744  28.4G Microsoft basic data                                                              
    /dev/sda16 3801219072 3890538495   89319424  42.6G Microsoft basic data                                                              
                                                                                                                                 
    Partition table entries are not in disk order.
    after comparing the o/p with partitioner it was found that sda2 is of type fat and is the Win95 FAT32 LBA.

    Also I've installed opensuse in Legacy mode.

    Please help as i do not want to get into procedure of backing up whole of 2tb data and reinstalling windows-->ubuntu-->opensuse all over again.

  2. #2
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Unable to boot to Windows after opensuse installation

    Please, show lsblk command.

    At first view, there are 2xBios boot. I think one is enough.

  3. #3

    Default Re: Unable to boot to Windows after opensuse installation

    Quote Originally Posted by another_roadrunner View Post
    Please, show lsblk command.

    At first view, there are 2xBios boot. I think one is enough.
    Code:
    linux-g5l3:/etc # lsblk -a
    NAME    MAJ:MIN RM   SIZE RO TYPE MOUNTPOINT
    sda       8:0    0   1.8T  0 disk 
    ├─sda1    8:1    0   500M  0 part 
    ├─sda2    8:2    0    40M  0 part 
    ├─sda3    8:3    0   128M  0 part 
    ├─sda4    8:4    0   750M  0 part 
    ├─sda5    8:5    0 349.1G  0 part 
    ├─sda6    8:6    0   891M  0 part 
    ├─sda7    8:7    0 501.3G  0 part 
    ├─sda8    8:8    0 451.3G  0 part 
    ├─sda9    8:9    0 430.3G  0 part 
    ├─sda10   8:10   0   7.9G  0 part 
    ├─sda11   8:11   0  14.3G  0 part 
    ├─sda12   8:12   0   7.6G  0 part [SWAP]
    ├─sda13   8:13   0  28.1G  0 part 
    ├─sda14   8:14   0    14M  0 part 
    ├─sda15   8:15   0  28.4G  0 part /var/opt
    └─sda16 259:0    0  42.6G  0 part /home
    sr0      11:0    1  1024M  0 rom  
    linux-g5l3:/etc # lsblk -f
    NAME    FSTYPE LABEL       UUID                                 MOUNTPOINT
    sda                                                             
    ├─sda1                                                          
    ├─sda2  vfat   DIAGS       F45A-19E1                            
    ├─sda3                                                          
    ├─sda4  ntfs   WINRETOOLS  ACD65BAED65B7812                     
    ├─sda5  ntfs   OS          6CE85FB6E85F7CF0                     
    ├─sda6  ntfs               A4202F8E202F6710                     
    ├─sda7  ntfs   Luminous    FCF663DBF66394A4                     
    ├─sda8  ntfs   Sagacious   2E6A998F6A995485                     
    ├─sda9  ntfs   Scintillate D8F09088F0906F0E                     
    ├─sda10 ntfs   PBR Image   E2CA2D6ECA2D4061                     
    ├─sda11 ext4               b144147b-903b-4381-9f51-5c1192fa1fd6 
    ├─sda12 swap               a5700b8c-ad41-4b54-b6de-944d2d1aea99 [SWAP]
    ├─sda13 ext4               09d05fae-ce46-4c4f-b80a-40dee90d9fc4 
    ├─sda14                                                         
    ├─sda15 btrfs              901317fd-2ec8-48c3-bc8f-a076b8a215b9 /var/opt
    └─sda16 xfs                dcf1274d-a90b-496d-a065-5123782b4b4f /home

  4. #4
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: Unable to boot to Windows after opensuse installation

    Are you sure you installed openSUSE in EFI mode and not in MBR mode? You can not chain between OS that boot in different modes

  5. #5
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Unable to boot to Windows after opensuse installation

    It appears that is a gpt/mbr install not gpt/uefi. I not see efi partition.
    I did not see root partition (/). In fact 2 root partitions (Ubuntu and oS).
    How did you install openSUSE?

  6. #6

    Question Re: Unable to boot to Windows after opensuse installation

    Quote Originally Posted by gogalthorp View Post
    Are you sure you installed openSUSE in EFI mode and not in MBR mode? You can not chain between OS that boot in different modes
    Quote Originally Posted by another_roadrunner View Post
    It appears that is a gpt/mbr install not gpt/uefi. I not see efi partition.
    I did not see root partition (/). In fact 2 root partitions (Ubuntu and oS).
    How did you install openSUSE?
    you're right I must've probably messed that thing up.
    So now even if i decide to install windows back and then openSUSE, I am unable to see any options in my bios for UEFI mode, to boot from.
    In short when i turn to UEFI mode, there is no boot device.(not even hdd).
    How do i deal with it?
    my windows being a genuine one the dell team asked me to install windows in uefi mode.

    Thanks a lot for your replies.

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,671
    Blog Entries
    3

    Default Re: Unable to boot to Windows after opensuse installation

    With Windows, you can only use GPT partitioning in UEFI mode.

    Maybe best is to start all over, with installing Windows first. If you cannot get your BIOS to use UEFI mode, check whether the pmbr_boot flag is set. For some BIOS versions, if pmbr_boot is set, the BIOS will only use legacy booting.

    Google for "pmbr_boot" for more information on changing this.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: Unable to boot to Windows after opensuse installation

    If you have uefi from bios, choose it.
    Install windows with uefi.
    Then openSUSE.
    Make partiton /boot/efi - the same with windows. Do NOT format it.
    Another partitions: swap if you want, root, and home.
    It must works.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •