Page 1 of 4 123 ... LastLast
Results 1 to 10 of 31

Thread: sddm not starting

  1. #1

    Default sddm not starting

    I installed latest tumbleweed. after installing i saw that the resolution in X/KDE5 is set to 640x480 and i can not incrase the resolution in Controllcenter. I found out, that i have to install the openchrome driver for my graphiccard. Now i get a blinking courser after restarting. If i start X manual, using startx i get a screen with higher resolutions available.

    i set kernel parameters to disable vesafb and nomodeset.

    If i start normal i do not get a X.org-log.

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,720

    Default Re: sddm not starting

    Hello and welcome here.

    As you are talking about your graphics card, may we please now what graphics card you use?
    Henk van Velden

  3. #3

    Default Re: sddm not starting

    lspci tells me the graphic card is Via P4M890 [S3 UniChrome Pro] (rev 02)

  4. #4

    Unhappy Re: sddm not starting

    Its a little bit frustrating. No i tried a GeForce 7600GS. Also failed. See https://forums.opensuse.org/showthre...54#post2863854 .

    Thanks for your help!

  5. #5

    Question Re: sddm not starting

    Is there a logfile of systemd, sddm which is created if it is started through systemd? Please help me....

  6. #6

    Default Re: sddm not starting

    Now i uninstalled sddm 0.17 and installed 0.14 from latest Leap. After that i reenabled ( systemctl enable sddm.service ) sddm. After that i blocked updating sddm. Works now for me. Hope there will be a fixed version of sddm in the future.

  7. #7
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    20,925
    Blog Entries
    14

    Default Re: sddm not starting

    Quote Originally Posted by wishmasterf View Post
    Now i uninstalled sddm 0.17 and installed 0.14 from latest Leap. After that i reenabled ( systemctl enable sddm.service ) sddm. After that i blocked updating sddm. Works now for me. Hope there will be a fixed version of sddm in the future.
    Good that it works for you now, but remember that you break the integrity of the system.
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  8. #8

    Default Re: sddm not starting

    Quote Originally Posted by Knurpht View Post
    Good that it works for you now, but remember that you break the integrity of the system.
    I know. But i do not know whats excatly my problem is. I read that version 0.16 has a problem with the order of starts by systemd. Some graphic parts are started too late or something like that.

    If you have a i solution idea, feel free to tell me.

  9. #9

    Default Re: sddm not starting

    Quote Originally Posted by wishmasterf View Post
    I know. But i do not know whats excatly my problem is. I read that version 0.16 has a problem with the order of starts by systemd. Some graphic parts are started too late or something like that.
    That should be irrelevant in openSUSE, as sddm is normally started via a generic display-manager.service specific to our distribution.

    sddm 0.17.0 is definitely not broken in general, it is of course tested by openQA, and it works fine here on all my 42.3 systems.

    Maybe you could provide the /var/log/Xorg.0.log from a failed start?
    And/or the output from "sudo systemctl status display-manager.service".

  10. #10

    Default Re: sddm not starting

    Quote Originally Posted by wolfi323 View Post
    That should be irrelevant in openSUSE, as sddm is normally started via a generic display-manager.service specific to our distribution.

    sddm 0.17.0 is definitely not broken in general, it is of course tested by openQA, and it works fine here on all my 42.3 systems.

    Maybe you could provide the /var/log/Xorg.0.log from a failed start?
    And/or the output from "sudo systemctl status display-manager.service".
    Thanks for your reply. I also do not think sddm is broken. But i searched alot and read on different websites that many users have problems with sddm 0.16 and up.

    If it helps i will post /var/log/Xorg.0.log and the status of displaymanager with sddm 0.17 later.

Page 1 of 4 123 ... LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •