Results 1 to 6 of 6

Thread: Intel CPU doesn't idle on minimal frequency.

  1. #1

    Default Intel CPU doesn't idle on minimal frequency.

    I've recently installed OpenSUSE Leap 42.3, and I've noticed that my CPU (Intel Core i5-4260u @ 1.4 GHz) works at 2.4 GHz all the time, even when CPU is not loaded.
    Kernel is
    4.4.126-48-default, and I've tried kernel-vanilla, and it worked at 800-900 MHz as it should. Is it possible to fix without changing kernel?
    Beforehand I've tried tumbleweed with
    4.16 kernel and everything worked just fine as well.
    UPD: Also it doesn't want to boost to full 2.7 GHz.


  2. #2
    Join Date
    Jun 2008
    Location
    San Diego, Ca, USA
    Posts
    13,295
    Blog Entries
    2

    Default Re: Intel CPU doesn't idle on minimal frequency.

    You might like to take a look at this Forum thread from the past few days...

    https://forums.opensuse.org/showthre...with_dipm-quot

    It isn't exactly what you're asking about, but somewhat related.

    TSU
    Beginner Wiki Quickstart - https://en.opensuse.org/User:Tsu2/Quickstart_Wiki
    Solved a problem recently? Create a wiki page for future personal reference!
    Learn something new?
    Attended a computing event?
    Post and Share!

  3. #3
    Join Date
    Jul 2014
    Location
    Pennsylvania, USA
    Posts
    103

    Default Re: Intel CPU doesn't idle on minimal frequency.

    Hello,
    If I'm understanding you correctly, I have had a similar problem.

    I did this and have had no problem since.

    Good luck!

    https://forums.opensuse.org/showthre...not-so-in-42-1

  4. #4

    Default Re: Intel CPU doesn't idle on minimal frequency.

    Hi nicomunet123

    Install cpu_freq in gnome applets..

    then in terminal in root

    Code:
    ls -1 /lib/modules/`uname -r`/kernel/drivers/cpufreq/
    Code:
    modprobe cpufreq_conservative
    Code:
    modprobe amd_freq_sensitivity
    (or Intel according to your configuration in the command - ls -1 /lib/modules/`uname -r`/kernel/drivers/cpufreq/ -)
    Code:
    modprobe cpufreq_powersave
    Code:
    modprobe cpufreq_userspace
    Code:
    modprobe cpufreq_stats


    in your applet cpu_freq

    click on install

    then : Disable service : "irq_balance" on your system

    @+

  5. #5

    Default Re: Intel CPU doesn't idle on minimal frequency.

    Quote Originally Posted by nicomunet123 View Post
    Kernel is 4.4.126-48-default, and I've tried kernel-vanilla, and it worked at 800-900 MHz as it should. Is it possible to fix without changing kernel?
    My i7 4790K has this problem with 42.3 as well, always bobbing around 4.3 GHz.

    I can make it behave more as expected by adding intel_pstate=disable to the "Optional Kernel Command Line Parameter" in the YAST Boot Loader control panel.

    My understanding is that it's a bug related to Intel p-state that is fixed in kernel 4.5. I've since been just accepting it as a bug while waiting for 42.3 to reach kernel 4.5

  6. #6

    Default Re: Intel CPU doesn't idle on minimal frequency.

    Quote Originally Posted by yomane View Post
    Hi nicomunet123

    Install cpu_freq in gnome applets..

    then in terminal in root
    Your screen pics are of Debian 8.9 running kernel 4.9. Probably not a good comparative reference.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •