Results 1 to 4 of 4

Thread: Problem: nothing provides libcrypto.so.1.1

  1. #1

    Question Problem: nothing provides libcrypto.so.1.1

    I did search for 'libcrypto.so.1.1' and 'libcrypto.so' and found no helpful threads. Unless I botched the search process.

    Here's is my problem:

    Code:
    Problem: nothing provides libcrypto.so.1.1()(64bit) needed by kernel-default-devel-4.16.2-2.1.ge881e16.x86_64
    I've been getting this error for a while, since kernel 4.15.X.

    Not sure what to do to resolve. For one am I searching correctly:

    Code:
    # zypper -v wp libcrypto.so.1.1
    Verbosity: 1
    Non-option program arguments: 'libcrypto.so.1.1' 
    Command 'what-provides' is replaced by 'search --provides --match-exact'.
    See 'help search' for all available options.
    Initializing Target
    Checking whether to refresh metadata for Kernel:/stable/standard
    Checking whether to refresh metadata for Leap-42.3-NON-OSS
    Checking whether to refresh metadata for Leap-42.3-NON-OSS-update
    Checking whether to refresh metadata for Leap-42.3-OSS
    Checking whether to refresh metadata for Leap-42.3-OSS-update
    Checking whether to refresh metadata for Packman/suse/openSUSE_Leap_42.3
    Loading repository data...
    Reading installed packages...
    Force resolution: No
    No matching items found.
    Code:
    # rpm -q --whatprovides libcrypto.so.1.1
    no package provides libcrypto.so.1.1
    
    l# rpm -q --whatprovides libcrypto.so
    no package provides libcrypto.so
    I would like to know if there is a better way to search this type of thing with zypper? Or rpm? (Or dnf for that matter.)

    So how to resolve this? Do I need another repository? Need to manually download a package and install? Am I using the wrong kernel repo to have most recent stable kernel version for Leap 42.3? Or do I just install the kernel-default-devel and not worry about it? Do developers need to correct this dependency to one that actually exists in repos? Or otherwise make some provision to provide this dependency? (Do I need to file a, gasp, bug report?)

  2. #2

    Default Re: Problem: nothing provides libcrypto.so.1.1

    Code:
    # zypper -v wp libcrypto
    also returns no matching items found. That can't be right...

  3. #3
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,842
    Blog Entries
    15

    Default Re: Problem: nothing provides libcrypto.so.1.1

    Hi and welcome to the Forum
    Correct, openSUSE 42.3 only has libopenssl1_0_0 (zypper se --file-list libcrypto.so.1) openSUSE Leap 15 has libopenssl1_1.

    You need to add the Kernel:tools repository as well if wanting to run the later kernels.

    Code:
    zypper ar -f -g -n "repo-Kernel:Tools" https://download.opensuse.org/repositories/Kernel:/tools/openSUSE_Leap_42.3/ openSUSE-Leap-42.3-Kernel:Tools
    Last edited by malcolmlewis; 18-Apr-2018 at 19:03.
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  4. #4

    Thumbs up Re: Problem: nothing provides libcrypto.so.1.1

    Thanks for the reply Malcolm. I added the Kernel Tools repo and libopenssl1_1 is installing along with other updates.

    Just noticed I got a reply so need to check my notifications!

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •