Results 1 to 6 of 6

Thread: Persistent Skype

  1. #1
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Persistent Skype

    Using Xfce. I can't stop Skype from starting after logging into Xfce. It's icon shows up on my one panel and starts ahead of anything else. I close Skype properly from its menu or from the panel icon, the icon disappears but it all repeats at the next boot. I right-click on the panel and get to Panel Preferences > Items, find the launcher that applies and delete it. The icon disappears but then reappears on the next boot.

    I think there must be another launcher in some autostart file I am missing. Any suggestions will be appreciated.

  2. #2
    Join Date
    Jun 2008
    Location
    Groningen, Netherlands
    Posts
    19,868
    Blog Entries
    14

    Default Re: Persistent Skype

    Have a look at what's in /etc/xdg/autostart
    ° Appreciate my reply? Click the star and let me know why.

    ° Perfection is not gonna happen. No way.

    https://en.opensuse.org/openSUSE:Board#Members
    http://en.opensuse.org/User:Knurpht
    http://nl.opensuse.org/Gebruiker:Knurpht

  3. #3
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Persistent Skype

    Quote Originally Posted by Knurpht View Post
    Have a look at what's in /etc/xdg/autostart
    Thanks for the speedy response. No filenames with "skype" in them in /etc/xdg/autostart. I opened a few suspicious ones with an editor and looked for Skype. This is the list of files.

    Code:
    ion@linux-hdyq:~> ls /etc/xdg/autostart
    
    at-spi-dbus-bus.desktop                      tracker-miner-apps.desktop
    gnome-keyring-pkcs11.desktop                 tracker-miner-fs.desktop
    gnome-keyring-secrets.desktop                tracker-miner-user-guides.desktop
    gnome-keyring-ssh.desktop                    tracker-store.desktop
    gsettings-data-convert.desktop               user-dirs-update-gtk.desktop
    nm-applet.desktop                            xfce4-notes-autostart.desktop
    pk-update-icon.desktop                       xfce4-power-manager.desktop
    polkit-gnome-authentication-agent-1.desktop  xfsettingsd.desktop
    print-applet.desktop                         xscreensaver.desktop
    tracker-extract.desktop
    ion@linux-hdyq:~>

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Persistent Skype

    have you tried the user's autostart dir
    Code:
    ~/.config/autostart
    does disabling autostart in skype have no effect?

  5. #5
    Join Date
    Sep 2010
    Location
    Poland
    Posts
    181

    Default Re: Persistent Skype

    In Skype go to Tools->Settings and disable Automatically start Skype.
    Linux 4.12.14
    openSUSE Leap 15.0 - 64 bit
    KDE Plasma 5.12.15
    KDE Framework 5.44.0
    Qt - 5.9.4

  6. #6
    Join Date
    Aug 2008
    Location
    Mexico and Sweden
    Posts
    1,288

    Default Re: Persistent Skype

    Quote Originally Posted by I_A View Post
    have you tried the user's autostart dir
    Code:
    ~/.config/autostart
    does disabling autostart in skype have no effect?
    Yes, disabling autostart in skype had no effect. But editing ~/.config/autostart did the trick. I was looking for a ~/.autostart file which of course wasn't there. Many thanks.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •