Results 1 to 7 of 7

Thread: Plasma5 black desktop with cursor after login

  1. #1

    Default Plasma5 black desktop with cursor after login

    Hey all,

    I'm running into an issue where I can successfully reach the logon screen (sddm) in tumbleweed and upon logging in all I get is a black screen with a mouse cursor. No shortcuts to launch KDE apps work, ctrl+alt+backspace+backspace sends me back to the logon screen. I can successfully log into IceWM.

    This is a fresh install of tumbleweed, though I hit the same issue by installing Leap and upgrading to Tumbleweed. I did not have this issue on Leap 42.3. I downloaded the tumbleweed network image yesterday.

    I have a GTX 1050ti, this issue reproduces BOTH with nouveau and the official nvidia drivers. The Nvidia drivers are properly loaded, I can see that through lsmod. This is most probably not an nvidia issue.

    I couldn't find any kde errors in journalctl. I've also nuked the kde and sddm caches and deleted the kde configuration. I have reinstalled tumbleweed and the issue persists. I've ran 'zypper up' as well as dup and patch, and they all state I'm up to date.

    Any ideas would be much appreciated.
    Cheers,

    PS. This is a single display driven through displayport, kernel 4.16.

  2. #2

    Default Re: Plasma5 black desktop with cursor after login

    Nevermind, I couldn't figure it out so I installed Arch instead.

    Cheers,

  3. #3

    Default Re: Plasma5 black desktop with cursor after login

    I'm attaching to this thread since I seem to be experiencing the same thing. It was all good until 20180419, now with 20180420 and 20180424 I get a black screen at login and just the cursor. I can do CTRL+ALT+2 and get into a terminal and reboot.

    I just restored a snapshot from 20180419 and for now I'm waiting for an upgrade that fixes it... or some advice on what to do. By the way, whoever came up with snapper (and btrfs) is my hero.

    These are the error messages I get on the journal:

    Code:
    Apr 26 22:46:48 host.home sddm-greeter[1569]: High-DPI autoscaling not Enabled
    Apr 26 22:46:48 host.home sddm-greeter[1569]: QXcbConnection: Could not connect to display :0
    Apr 26 22:46:48 host.home sddm-greeter[1569]: Could not connect to any X display.
    Apr 26 22:46:48 host.home sddm-helper[1553]: [PAM] Closing session
    Apr 26 22:46:48 host.home sddm-helper[1553]: pam_unix(sddm-greeter:session): session closed for user sddm
    Apr 26 22:46:48 host.home sddm-helper[1553]: [PAM] Ended.
    Anything I should look into?

    Thanks!

  4. #4

    Default Re: Plasma5 black desktop with cursor after login

    It looks exactly like the problem in my thread https://forums.opensuse.org/showthre...ical-Interface. I tried out other display managers and all worked. After an update which included SDDM I tried that again and again I had the black screen with the cursor only. So since then I went back to KDM and it works since.
    Cheers
    Uli

  5. #5

    Default Re: Plasma5 black desktop with cursor after login

    ok, but so the solution here is not to use SDDM at all?

    I guess I have to hope for an update...

  6. #6

    Default Re: Plasma5 black desktop with cursor after login

    Quote Originally Posted by eiboaa View Post
    ok, but so the solution here is not to use SDDM at all?

    I guess I have to hope for an update...
    Just try with another display manager - you can always go back. Just go into command line and type:
    Code:
    update-alternatives --config default-displaymanager
    You get a list of display manager with a number at the front - select a number and reboot. If it is not working or if an update to sddm comes and you want to try again just use the same code and select sddm again.
    Cheers
    Uli

  7. #7

    Default Re: Plasma5 black desktop with cursor after login

    Quote Originally Posted by fuerstu View Post
    Just try with another display manager - you can always go back. Just go into command line and type:
    [...]
    thank you! This is very useful. It seems to have been fixed in 20180425, but I'll definitely keep this in mind because it's not the first time I got the weird black screen.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •