Results 1 to 8 of 8

Thread: Connecting to second display switch off keyboard

  1. #1
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Question Connecting to second display switch off keyboard

    Dear all,

    I'm using a laptop (Thinkpad Carbon) with Opensuse Tumbleweed.
    This week I tried to connect a projector by HDMI to my laptop. The second screen appeared, but the keyboard was switched off (only the trackpad was working = moving the pointer, but not the key of the trackpad = you can't click on something). This is very bad when you would give a presentation . I also tried an external mouse and keyboard. They were also switched off. The same problem occurred with a further projector.
    Everyday, I have the laptop connected to a second monitor by HDMI. Here, the problem does not occur.
    I renamed the "./local/share/kscreen" folder to "delete" potential problems in this configuration file. The result was, that also my everyday second display was turning of the keyboard. Subsequently, I used my old "kscreen" folder and my display was working agin with keyboard. It seems, that the switching off keyboard problem only occurs with new devices plugged into HDMI.

    The last time a new external display was working when I used the laptop around two month ago with Opensuse Leap 42.3.

    Has anybody an idea how to run a second display with a working keyboard? What could be the reason? MESA version? Kernel (I don't believe, because I also used always the latest kernel with Leap 42.3)?

    Best,

    Michael

  2. #2
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Default Re: Connecting to second display switch off keyboard

    Short question:
    Did somebody try a new (not registered in kscreen before) external display/projector... with a current Tumbleweed installation in the last weeks?

    Best,

    Michael

  3. #3
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Default Re: Connecting to second display switch off keyboard

    Update:
    I played a little bit around (using my TV screen as second display for tests). I found out, that the keyboard (and touchpad click) is only deactivated on the laptop display. When moving the pointer to the TV screen clicking and typing is working. Therefore, it's not an error in the way, that some data from the second display are not fully read. Problems with KDE?
    In some cases, the typing and clicking is working on the laptop but then not on the second screen.
    When playing around in the "display and monitor" menu with the point "primary display" there are the points "laptop display", the name of the second screen (im my case Sony...) and "kein Hauptbildschirm" (no main display/ no main screen) (my desktop is German, therefore the names of the menus are translations by myself). With "no main display" in some cases, I had a working keyboard/touchpad click on both screens.

    Has somebody else observed this strange behavior?

    Best,

    Michael

  4. #4
    Join Date
    Dec 2008
    Location
    FL, USA
    Posts
    3,371
    Blog Entries
    1

    Default Re: Connecting to second display switch off keyboard

    Do you get expected behavior if you login to an IceWM session instead of Plasma?

    Does Plasma work as expected if you create a new user and login to Plasma with it?

    Does changing your locale to en_US impact the behavior?

    These should tell you whether the problem is with localization, Plasma, user config, or basesystem.

  5. #5
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Default Re: Connecting to second display switch off keyboard

    Dear mrmazda,

    first: thanks for your answers !

    I followed your suggestions:
    - IceWM session: no signal was delivered to second screen (do you have to start in manually? Normally, I start a session without the second screen and when KDE is started, I plug in the second screen)
    - new user: same behavior
    - US English in KDE seetings: same behavior
    - US English in YAST settings: same behavior

    One new observation:
    When connecting the second screen, I can't click anything on the laptop screen, but on the second screen. Now I have observed, when I click on the laptop screen, I can start programs/files... but can't see it (I saw it, when I unplugged the second screen). When I try to move a window from the second screen to the laptop (first) screen the moved window will not shown on the laptop screen.
    > the keyboard + click is still working on the first screen, but the screen itself is "dead" (not reacting = the desktop freezes). Therefore, it's not a keyboard/touchpad problem, the desktop is frozen on the laptop screen.

    Best,

    Michael

  6. #6
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Default Re: Connecting to second display switch off keyboard

    Now, I had a closer look on the kscreen files.

    The older kscreen files which contains data for both screens (before I moved from Leap 42.3 to Tumbleweed) are showing for my laptop screen:
    "fullname": "xrandr-unknown",
    "name": "eDP-1"

    The newer kscreen files (with Tumbleweed):
    "fullname": "xrandr-AU Optronics",
    "name": "eDP1"

    > the hardware detection of my primary laptop screen changed!

    I tried to replace the "new" data in the file for the test second screen with the "old" data. But this was not working, the system overwrote the modified data.

    Michael

  7. #7
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Default Re: Connecting to second display switch off keyboard

    Also others had this problem (but were more clever and directly recognized that the freezing of the display is the problem, not the keyboard ;-)):
    https://lists.opensuse.org/opensuse-.../msg00053.html

  8. #8
    Join Date
    Dec 2008
    Location
    Braunschweig (Germany)
    Posts
    296

    Lightbulb Re: Connecting to second display switch off keyboard

    "Solved":
    I tried the way in the opensuse mailing list. When connecting the second screen, the first screen freeze. You can wake up the first screen by "Crtl+Alt+F1" (> command line) followed by "Crtl+Alt+F7" (> back to KDE). Now, both display are working.

    Best,

    Michael

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •