Page 1 of 3 123 LastLast
Results 1 to 10 of 22

Thread: GRUB Menu Does Not Load

  1. #1

    Default GRUB Menu Does Not Load

    I received a new hard drive for my notebook and first installed Windows 10.. went smooth, no issues at all. Then I popped in OpenSuse and went through the installation fine. I did change some of the partitions, but here is what I did:

    40GB for /
    100GB for /home
    7GB /Swap
    50GB /VMS (Partition for my to-be virtual machines)

    Installed OpenSuse, went fine, it rebooted at the end, but went to directly in my windows. What happened to the menu that allows me to select which OS to boot into? I have no way (I think) to get back in to OpenSuse. Please help with any advice possible.

    When I start up my notebook and bring up the boot menu, all it brings up in the boot manager is 'Windows Boot Manager.' This doesn't even look like a grub boot menu.

    I don't mind deleting all the partitions I created when installing OpenSuse but I don't even know what I did wrong so I know what not to do or to do to make it right. Your help is much appreciated in advance.

    Thank you,
    AJ

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: GRUB Menu Does Not Load

    Is this a UEFI box, or an older legacy box?

    I'm guessing it is probably UEFI. Just about anything purchased since 2012 will be UEFI.

    Is Windows installed to boot with UEFI or is it set for legacy booting?
    Is openSUSE installed to boot with UEFI or is it set for legacy booting?

    The thing is, either you must use UEFI booting for both, or you must use legacy booting for both. Mix and match doesn't work and is really "mix and mismatch". I don't know if that is your problem. But it is the first place to look.

    How to tell? Easiest will be to boot into linux. Yes, I know you can't do that. But you can boot the installer to rescue mode and login as root. Then run:
    Code:
    fdisk -l /dev/sda
    This assumes that your main hard drive is "/dev/sda". Or you can just use "fdisk -l" and not specify a disk.

    Then look for the line that begins "Disklabel type:".

    If it says that the disklabel type is "gpt", then Windows is using UEFI booting. If it says that the disklabel type is "dos", then Windows is using legacy booting.

    To find out about your openSUSE install, you would need to mount the root partition somewhere. Then check "/etc/fstab" (relative to mount point) and see if there is an entry for "/boot/efi".
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: GRUB Menu Does Not Load

    Quote Originally Posted by nrickert View Post
    Is this a UEFI box, or an older legacy box?

    I'm guessing it is probably UEFI. Just about anything purchased since 2012 will be UEFI.

    Is Windows installed to boot with UEFI or is it set for legacy booting?
    Is openSUSE installed to boot with UEFI or is it set for legacy booting?

    The thing is, either you must use UEFI booting for both, or you must use legacy booting for both. Mix and match doesn't work and is really "mix and mismatch". I don't know if that is your problem. But it is the first place to look.

    How to tell? Easiest will be to boot into linux. Yes, I know you can't do that. But you can boot the installer to rescue mode and login as root. Then run:
    Code:
    fdisk -l /dev/sda
    This assumes that your main hard drive is "/dev/sda". Or you can just use "fdisk -l" and not specify a disk.

    Then look for the line that begins "Disklabel type:".

    If it says that the disklabel type is "gpt", then Windows is using UEFI booting. If it says that the disklabel type is "dos", then Windows is using legacy booting.

    To find out about your openSUSE install, you would need to mount the root partition somewhere. Then check "/etc/fstab" (relative to mount point) and see if there is an entry for "/boot/efi".

    Thanks, and I get most of it what to do, but I'm uncertain how to do the last part and mount (then unmount) the root partition. Can you provide some guidelines around this? Thanks.

  4. #4
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: GRUB Menu Does Not Load

    Quote Originally Posted by aj_suse View Post
    Thanks, and I get most of it what to do, but I'm uncertain how to do the last part and mount (then unmount) the root partition. Can you provide some guidelines around this? Thanks.
    You have to know what is the root partition. I'll call it "/dev/sdaX" here (partition number X).

    Code:
    mount /dev/sdaX /mnt
    grep boot /mnt/etc/fstab
    Look to see if there is a "/boot/efi". There might not be anything at all.

    While you are about it:
    Code:
    ls /mnt/boot/grub2
    If you installed using UEFI, there will be a directory "x86_64-efi". If you installed using legacy booting, there will be a directory "i386-pc".
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  5. #5
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: GRUB Menu Does Not Load

    If you only can boot in Windows:
    From disk management, what partitions do you see?
    Or from command line, with diskpart: diskpart, list disk, list partition, detail disk (partition).
    Find if you format disk with gpt, what partitions you have.

  6. #6

    Default Re: GRUB Menu Does Not Load

    When I go into my bios at system startup, it is 'OS Mode Selection' is set to 'CSM and UEFI OS' and the 'Fast BIOS Mode' is disabled. After seeing this I have set the OS Mode Selection to 'UEFI' only to avoid any confusion.

    As mentioned, I have 1 hard drive with ~500GB. Here is what Windows Disk Management shows:
    https://paste.opensuse.org/64249081

    Based on this image above, the partitions I created in Linux were the following:
    Partition 10: SWAP
    Partition 9: VMS (for my virtual machines)
    Partition 8: 100GB (/home directory)
    Partition 7: 40GB (/ root)
    Storage D: 146GB is a storage I created to share between windows and linux
    Partition 1, 2 and 6 I did not create but were created by the system automatically.
    C: Windows



    When I hook up my external DVD drive to boot from opensuse disk and then press F10 to get into the boot menu, I will get this: http://paste.opensuse.org/58439671
    Interesting thing to notice in this image is why is it listing my dvd drive multiple times?? I have no clue.

    Here is what I see when I run fdisk -l --> http://paste.opensuse.org/74407110
    As you will see here the disk label type is gpt.

    Here is the output of : http://paste.opensuse.org/50528080
    mount /dev/sdaX /mnt
    grep boot /mnt/etc/fstab
    ls /mnt/boot/grub2

    I am providing all these images to help explain the issue as well as since I'm still new, providing as much information helps me as well. Hope this helps and I can get this working sooner than later. I have installed opensuse a few times before, but never ran into this issue before.

    Thanks in advance again.

    - AJ

  7. #7
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,685
    Blog Entries
    3

    Default Re: GRUB Menu Does Not Load

    Those images give what we need.

    Yes, Windows is installed for UEFI booting. And openSUSE is installed for legacy booting. And that mismatch is why you are having problems.

    This can be repaired. However, in all honesty, it will be easier to just reinstall openSUSE. Now that you have set your system to UEFI mode only, this should work without problems.

    The first boot screen for the installer should look like a grub menu. If there are notations for function keys F1, F2 etc on the bottom of the screen, then you booted the DVD in legacy mode. If there are no such notations, then you should be in UEFI mode. You should be able to use all of the same partitions as before.

    When you see a screen with proposed partitions, click "Create partitioning". On the next screen, click "Expert Partitioner". At the bottom of that screen, there should be an option "Import Mount Points" (or similar wording). Use that, and you will get back the exact partition setup that you had before.

    Now you will need to make one change. Look for the line showing "/dev/sda2". That should be your 100M EFI partition. Right click on that, and select "Edit". Then set to mount at "/boot/efi". (DO NOT FORMAT -- it should already be set to not format, so leave that as it is).

    Quickly check if everything else looks good. If it does, accept the partitioning and proceed to the reinstall.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  8. #8

    Default Re: GRUB Menu Does Not Load

    So I think i got this correct, I am going to just format the partitions anyway since there really isn't anything on them. I do have a question is that the installer is saying that the /boot/efi needs to be 256 mb. I can ignore this message and move forward, but want to be sure it will be okay.

    Here is the updated partition listing in the installer. . http://paste.opensuse.org/53325362


    Thanks again for your help.

    -AJ

  9. #9
    Join Date
    Feb 2018
    Location
    Romania
    Posts
    484

    Default Re: GRUB Menu Does Not Load

    /dev/sda2 is an UEFI partition.
    /dev/sda6 is a bios_boot partition.
    Windows is installed in uefi/gpt and oS in bios/gpt
    You need to install oS in uefi/gpt like nrickerd said.
    You need to boot from your DVD in uefi mode and do what nrickerd said.
    What is strange to me: your boot is windows boot and a lot of uefi. In this case how you installed in bios/gpt? Or this is the boot menu after you change the bios only in Uefi mode?
    PS. You don't need the bios_boot partition.

  10. #10

    Default Re: GRUB Menu Does Not Load

    Hi, so I'm following (I think) exactly what nrickert suggested.

    1. Should I delete the 'Bio Boot Partition?' I didn't touch it because I wasn't sure if that was created by windows or what.
    2. I have booted the installation by DVD in UEFI Mode. See previous post image to show that I am in UEFI mode of the installer.

    Am I missing something here?


    What should I do about this --> http://paste.opensuse.org/53325362

    Sorry if I missed something, kinda new here and still learning this stuff.

    Thanks,
    AJ

Page 1 of 3 123 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •