Results 1 to 7 of 7

Thread: The GUI fails to Start. Tumbleweed boots to CLI

  1. #1

    Default The GUI fails to Start. Tumbleweed boots to CLI

    Hi, I recently installed OpenSUSE Tumbleweed (KDE Plasma) and it worked fine for the first time. However, second time I start it, it stucked. The animated Tumbleweed logo appears and then it freezes to a CLI, asking me to log in.

    I have seen other threads that are generally related to Graphics card. But in my case I am not using any Graphic card. In my notebook, there are Intel Graphics built in. I have run the system ugrade, nothng happened. And I tried "zypper in -f xorg-x11*" as was mentioned o StackExchange but the problem still persists.

    Here is the /var/log/Xorg.0.log.old file: https://paste.ee/p/GINJz

    I am new to Linux and so I don't know what to do next.



    Help wanted...

  2. #2
    Join Date
    Aug 2010
    Location
    Chicago suburbs
    Posts
    15,684
    Blog Entries
    3

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    Quote Originally Posted by suleman11 View Post
    I have run the system ugrade, nothng happened.
    I'm not sure what you mean by that.

    From the command line, run (as root):
    Code:
    zypper dup
    and see if that changes anything.
    openSUSE Leap 15.3; KDE Plasma 5.18.6;

  3. #3

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    The problem is this:
    Code:
    [   211.520] (II) LoadModule: "intel"
    [   211.520] (WW) Warning, couldn't open module intel
    [   211.520] (II) UnloadModule: "intel"
    [   211.520] (II) Unloading intel
    [   211.520] (EE) Failed to load module "intel" (module does not exist, 0)
    [   211.520] (EE) No drivers available.


    I.e. Xorg cannot load the intel driver.
    Normally not a problem as it just use another one then, but apparently you told it to use intel somewhere? (it doesn't even try to load a different driver although it should)

    What does "grep intel /etc/X11/xorg.conf.d/*" say?

    In case you don't feel confortable working in text mode, choose one of the "(recovery mode)" entries in "Advanced Options" in the boot menu (as already mentioned in the other thread), this should at least give you a graphical system.

    Installing the intel driver would probably fix it as well (if it supports your graphics chip):
    Code:
    sudo zypper in xf86-video-intel
    But unless you have a good reason, you should probably remove that manual config.
    Last edited by wolfi323; 14-Apr-2018 at 06:21.

  4. #4

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    Quote Originally Posted by wolfi323 View Post
    The problem is this:
    Code:
    [   211.520] (II) LoadModule: "intel"
    [   211.520] (WW) Warning, couldn't open module intel
    [   211.520] (II) UnloadModule: "intel"
    [   211.520] (II) Unloading intel
    [   211.520] (EE) Failed to load module "intel" (module does not exist, 0)
    [   211.520] (EE) No drivers available.


    I.e. Xorg cannot load the intel driver.
    Normally not a problem as it just use another one then, but apparently you told it to use intel somewhere? (it doesn't even try to load a different driver although it should)

    What does "grep intel /etc/X11/xorg.conf.d/*" say?

    In case you don't feel confortable working in text mode, choose one of the "(recovery mode)" entries in "Advanced Options" in the boot menu (as already mentioned in the other thread), this should at least give you a graphical system.

    Installing the intel driver would probably fix it as well (if it supports your graphics chip):
    Code:
    sudo zypper in xf86-video-intel
    But unless you have a good reason, you should probably remove that manual config.

    For the word "Intel" I have truly understood what was actually causing this whole mess. It is "the /usr/share/X11/xorg.conf.d/20-intel.conf" file. Actually prior to openSUSE, I was using Manjaro Linux, Kubuntu, etc. And there was a problem with with changing the brightness of the screen. I found the solution that pasting the following code in the "/usr/share/X11/xorg.conf.d/20-intel.conf" file will fix that and it did.

    Code:
    Section "Device"        Identifier  "card0"
            Driver      "intel"
            Option      "Backlight"  "intel_backlight"
            BusID       "PCI:0:2:0"
    EndSection
    Now, in Tumbleweed I had the same problem of changing the brightness so I applied the same fix and it caused the aforementioned problem. Now, I have deleted the "/usr/share/X11/xorg.conf.d/20-intel.conf" file and everything is working fine now. I have reached the login screen and desktop. However, the problem of changing the brightness is there

  5. #5

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    The brightness problem also fixed !!!!

  6. #6

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    Quote Originally Posted by suleman11 View Post
    Now, in Tumbleweed I had the same problem of changing the brightness so I applied the same fix and it caused the aforementioned problem. Now, I have deleted the "/usr/share/X11/xorg.conf.d/20-intel.conf" file and everything is working fine now.
    As already indicated, the "problem" with this is that it forces the use of the intel driver.
    But Tumbleweed nowadays prefers the "modesetting" driver for (most?) intel chips, because of the ongoing instability of intel in the last couple of years (especially on newer chips, which it might not even support).

    IOW, xf86-video-intel is no longer installed by default. For this 20-intel.conf file to "work", you'd need to install it manually (it is in the standard repos).

    I cannot tell you which of the two drivers would work better for you though, it's highly dependent on the specific chipset. (for some people, "modesetting" is apparently even faster than intel)

    Quote Originally Posted by suleman11 View Post
    The brightness problem also fixed !!!!
    And how?
    Just out of curiosity... (and it may help other people with a similar problem )

  7. #7

    Default Re: The GUI fails to Start. Tumbleweed boots to CLI

    Quote Originally Posted by wolfi323 View Post
    And how?
    Just out of curiosity... (and it may help other people with a similar problem )

    Actually this thread an the "sudo zypper in xf86-video-intel" (you suggested earlier) helped a lot. I re-created the 20-Intel.conf file with the same code and then ran that command. And after that I re-login again and brightness control is working like a charm.
    Last edited by Fraser_Bell; 15-Apr-2018 at 13:39. Reason: Fix quote tags for readability.

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •