Results 1 to 3 of 3

Thread: Install QGIS in LEAP 42.3

  1. #1

    Default Install QGIS in LEAP 42.3

    I can not install qgis on openSUSE Leap 42.3, it asks for the file libgrass_dbmiclient.7.2.2.so, but I can not install it.
    Carlos Filho
    http://opensusebr.blogspot.com.br

  2. #2
    Join Date
    Jun 2008
    Location
    Podunk
    Posts
    26,865
    Blog Entries
    15

    Default Re: Install QGIS in LEAP 42.3

    Quote Originally Posted by caffilhobr View Post
    I can not install qgis on openSUSE Leap 42.3, it asks for the file libgrass_dbmiclient.7.2.2.so, but I can not install it.
    Hi
    By the looks the current version is not building (unresolvable) for Leap 42.3 anymore since it's been disabled (but the binaries remain);
    https://build.opensuse.org/package/s...ation:Geo/qgis

    You would need to follow up with the maintainers, or a bug report...
    Cheers Malcolm °¿° SUSE Knowledge Partner (Linux Counter #276890)
    SUSE SLE, openSUSE Leap/Tumbleweed (x86_64) | GNOME DE
    If you find this post helpful and are logged into the web interface,
    please show your appreciation and click on the star below... Thanks!

  3. #3

    Default Re: Install QGIS in LEAP 42.3

    Quote Originally Posted by malcolmlewis View Post
    Hi
    By the looks the current version is not building (unresolvable) for Leap 42.3 anymore since it's been disabled (but the binaries remain);
    https://build.opensuse.org/package/s...ation:Geo/qgis

    You would need to follow up with the maintainers, or a bug report...
    The latest version cannot be built for Leap 42.3 because the included system libraries are too old.
    The OBS project contains this comment from the maintainer:
    Build fro 42.x has been disabled has we need too never package Qt5, sip, python3 to build Qgis3.0 If you're looking for the qgis 2x version check now qgis-ltr
    There still is qgis-ltr (Long-Term-Release) for Leap 42.3 though, the previous Qt4 based version that is still being maintained upstream as well and still gets bugfix releases.

    The currently available qgis binaries are in fact this LTR release from a point when it wasn't LTR yet, but as indicated they won't get updates (or even rebuilds to be adjusted to other updates like grass) anymore, so just use qgis-ltr on Leap 42.3.
    Probably the "broken" qgis binaries should better be removed completely though, that would be the only thing worth reporting here.
    Last edited by wolfi323; 10-Apr-2018 at 23:16.

Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •