Results 1 to 7 of 7

Thread: No fonts on Win10 subsystem for Leap 42.3

  1. #1

    Default No fonts on Win10 subsystem for Leap 42.3

    Firefox, gedit... do not display some text on Win10 subsystem for Leap 42.3. What rpm do install additionaly?

  2. #2
    Join Date
    Jun 2008
    Location
    Netherlands
    Posts
    29,788

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    I think you have to explain better:
    • what you do;
    • what you get;
    • what you expected to get.

    I assume Win10 points to MS windows, thus explain what a problem in Windows 10 has to do with openSUSE.
    Henk van Velden

  3. #3

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    I've install Windows_Subsystem_for_Linux on Win10.
    WSL uses fewer resources than a fully virtualized machine.
    https://en.wikipedia.org/wiki/Window...stem_for_Linux
    It is possible to run some (Linux) graphical applications by installing an X11 server within the Windows environment.

    I use Ubuntu on Win10 for some moths before. And linux firefox particulary.
    apt-get install firefox is enough to use firefox correctly

    Then i have install openSuse and linux firefox: zypper in firefox
    And lack some fonts in firefox screen
    https://banga.tv3.lt/lt/2club.club_f...1-=(1225671978
    How get correctly text view? What zypper should I need rpm additionaly?


    PS
    Before use graphical applications run:
    export DISPLAY=:0

  4. #4

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    Should be installed
    zipper in xorg-x11-fonts

  5. #5

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    Quote Originally Posted by makauskas View Post
    Should be installed
    zipper in xorg-x11-fonts
    sorry, not enough

  6. #6
    Join Date
    Nov 2009
    Location
    West Virginia Sector 13
    Posts
    16,287

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    Do you have a X11 desktop installed?

    As I understand it the Windows image is pretty much just enough OS so is a command line version. You need a GUI interface to run GUI programs

  7. #7

    Default Re: No fonts on Win10 subsystem for Leap 42.3

    Quote Originally Posted by gogalthorp View Post
    Do you have a X11 desktop installed?

    As I understand it the Windows image is pretty much just enough OS so is a command line version. You need a GUI interface to run GUI programs
    I have install Xming server within the Windows environment as recommend
    https://en.wikipedia.org/wiki/Window...stem_for_Linux
    It is possible to run some (Linux) graphical applications by installing an X11 server within the Windows environment.

    PS

    vidas@HP450G2:~> rpm -qa | grep font
    fontconfig-2.11.1-4.3.x86_64
    gnu-unifont-bitmap-fonts-20080123-88.3.noarch
    fonts-config-20150424-6.3.noarch
    xorg-x11-fonts-7.6-34.16.noarch
    intlfonts-euro-bitmap-fonts-1.2.1-17.16.noarch
    xorg-x11-fonts-core-7.6-34.16.noarch
    dejavu-fonts-2.34-8.3.noarch
    -
    It seems enough to browse with firefox and some packages more than enough


Tags for this Thread

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •