Page 1 of 2 12 LastLast
Results 1 to 10 of 17

Thread: Looks like H/W acceleration isn't working in Firefox

  1. #1

    Exclamation Looks like H/W acceleration isn't working in Firefox

    Hello,
    Just installed OpenSuse 42.3, and looks like hardware acceleration is not working in firefox.
    The IGP is Intel HD Graphics on Celeron 3215U (In Windows, the driver that works is the one designed for HD Graphics 5500).
    Everything else is working, including desktop 3D effects (like Glide, Wobbly Windows, etc).
    Here's what's displayed in firefox troubleshooting page:




    The problem I'm facing is that parts of firefox flicker. When I start typing in the "search" box beside the url bar, firefox shows a list of suggestions- this suggestions list part constantly flickers (goes black, shows suggestions, goes black, shows suggestions,.....). The same happens when I click on the the three "--" bars to open the firefox menu- the menu flickers like the search suggestions. This laptop was running firefox in Windows just a while back before i formatted the hard disk, and these problems were not present there- hardware acceleration was working in Windows and nothing was flickering.

    This is a fresh install, and so far all I've done is:
    1. Installed multimedia codecs and switched system to 'pacman'.
    2. Updated opensuse.
    3. Installed VLC from pacman using yast
    4. Changed the theme as you can see
    5. Enabled some desktop effects (Glide, Wobbly)
    6. Installed three firefox add-ons (Ghostery, Ad-block plus, KProxy) all from the official firefox add-on page. (The flickering persists even if I disable all three add-ons and restart firefox).

    Is there a way to fix this? Perhaps enabling H/W acceleration will do the trick?
    Any help will be greatly appreciated. I'm no Linux expert so please don't use hi-tech words in the reply...
    Thanks..

  2. #2
    Join Date
    Aug 2008
    Location
    Brazil
    Posts
    2,908

    Post Re: Looks like H/W acceleration isn't working in Firefox

    Leap 42.3, FF Quantum 58.0.1 from http://download.opensuse.org/reposit...USE_Leap_42.3/

    Compositing is the same as yours, basic. Further down on about:support I see:

    Code:
    HW_COMPOSITING                    blocked by default: Acceleration blocked by platform
    OPENGL_COMPOSITING                        unavailable by default: Hardware compositing is disabled
    WEBRENDER                                        opt-in by default: WebRender is an opt-in feature unavailable by runtime: Build doesn't include WebRender
    OMTP                                                   disabled by default: Disabled by default
    By hardware accel you mean H264 support? about:support doen't show this line. Only references to the codec appear in the Important Modified Settings section:

    Code:
    media.gmp-gmpopenh264.abi    x86_64-gcc3
    media.gmp-gmpopenh264.lastUpdate    1471468143
    media.gmp-gmpopenh264.version         1.6
    I'd try:

    0) see what compositing you're using in system-settings>Display>Compositing. It should preferably be OpenGL (version 2.0 works better for me). Note that my GPU is Nvidia, that AFAIU replaces Mesa opengl libs, so different from yours that use Mesa's.

    1) rename FF config folder to something else, see if it makes a difference (alternatively you can create a new user and see if it works, then you'll now the problem is in your config).

    2) Try Quantum from the repo above. You can easily revert to the updates repo version if you wish.

    Good luck.

  3. #3

    Default Re: Looks like H/W acceleration isn't working in Firefox

    Hello Brunomcl,

    Here's what I did after reading your post.

    1> Installed the latest Firefox (non- ESR) from the repository you gave, looks like the latest version is 59.0.2



    2> Changed compositing to 3.1 (it was 2.0 by default).
    3> Changed back to 2.0

    Problem persists.
    Parts of firefox go black and come back- like the search suggestions when I type in the search box on top of firefox, the firefox menu that slides down when I click on the three "--" on the top right corner, they kind of flicker at about 5 to 10Hz, constantly disappearing and re-appearing.

    To top it off, while experimenting with the compositor (changing between 2.0, 3.1, changing vSync settings, etc) I encountered a crash:


    I have re-enabled OpenGL and this crash hasn't repeated since.

    But my laptop refuses to resume from hibernate - this is a well known failure in MS Windows systems when you use a bad video driver - and the above screengrab complains about the driver as well- I'm beginning to think there's perhaps something wrong with the display driver that came with Leap 42.3? Perhaps it doesn't properly support the HD Graphics chip in Intel Celeron 3215U CPU? Assuming the driver was written by Intel and not by the open-source community, I fail to understand why Intel would make a bad driver- the HD Graphics driver from Intel worked just perfect in Windows 10 running on this same laptop - I could even play old video-games like Diablo 2, Age of Empires, Rise of Nations, etc.

    And I have no idea how to play with drivers in Linux. In Windows you just open device manager, uninstall the old driver, download the new driver.exe from intel.com, run this .exe, the driver installs and the computer re-starts. In Linux, it looks like I have to re-compile the kernel or something, and I'm really not very good with computers, I am pretty sure I will end up causing even more problems if I go down that route...

    Anyway, I have installed Google Chrome (not chromium), and chrome seems to be working fine- no flickering anywhere.
    I will keep using Chrome- but it's a bit disappointing that this laptop can't run Firefox anymore- I have used Firefox exclusively for the last 5 years
    And I still can't fix the hibernation issue- openSuse hibernates fine, but crashes while resuming- I have to press and hold the power button to force a re-start..

    I'd really hate to re-install Windows at this point, I will just keep using it without hibernate I guess..

    If you've got any more things I can try, I'm game..

    Thank you for your help \m/

  4. #4
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Looks like H/W acceleration isn't working in Firefox

    did you try enabling tearing prevention as from your screen shot Tearing Prevention ("vsync") is set to never

  5. #5

    Default Re: Looks like H/W acceleration isn't working in Firefox

    Quote Originally Posted by I_A View Post
    did you try enabling tearing prevention as from your screen shot Tearing Prevention ("vsync") is set to never
    Hi I_A,

    Just tried other settings for vSync once again, but the issue still persists.

    I've installed this dictionary called "Artha" and parts of this software are flickering as well, but it's still usable, not as bad as firefox.

    Interestingly, the problem is instantly solved if I select 'XRender' for "Rendering backend". But the moment I select XRender, most of my desktop effects get disabled- KDE starts to look UGLY like Windows 10.

    Being a moderator, you must be very experienced- what do you think is going on here?

  6. #6

    Default Re: Looks like H/W acceleration isn't working in Firefox



    ^^^^ This solves the flickering as well, but compositing is globally disabled as long as firefox is running.

  7. #7
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Looks like H/W acceleration isn't working in Firefox

    this could be a firefox bug as firefox has issues with some intel chips and disables hardware acceleration on some of them
    you could and disable hardware acceleration from within firefox
    hit the hamburger bar (the 3 horizontal lines)-> preferences -> General -> Performance uncheck Use Recommended Settings -> uncheck Use Hardware Acceleration
    I really don't use Chrome it could be that Chrome does not use hardware acceleration and that's why you're not noticing issues
    Or it could be something plasma 5 (kwin5) related, do you have another desktop to test it out, if not install openbox and openbox-kde (or lxqt as it's a small desktop) and login to an openbox plasma 5 session and see if the issue persists
    the thing is openbox does not use any compositing but it's light as a feather
    I don't have an intel gpu box maybe some other intel users can confirm this as it might be kernel related (the intel drivers come with the kernel) and you should open a bug report

  8. #8
    Join Date
    Sep 2008
    Posts
    2,997

    Default Re: Looks like H/W acceleration isn't working in Firefox

    Quote Originally Posted by johnwinchester View Post
    Hello,
    Just installed OpenSuse 42.3, and looks like hardware acceleration is not working in firefox.
    The IGP is Intel HD Graphics on Celeron 3215U (In Windows, the driver that works is the one designed for HD Graphics 5500).
    Everything else is working, including desktop 3D effects (like Glide, Wobbly Windows, etc).
    Here's what's displayed in firefox troubleshooting page:




    The problem I'm facing is that parts of firefox flicker. When I start typing in the "search" box beside the url bar, firefox shows a list of suggestions- this suggestions list part constantly flickers (goes black, shows suggestions, goes black, shows suggestions,.....). The same happens when I click on the the three "--" bars to open the firefox menu- the menu flickers like the search suggestions. This laptop was running firefox in Windows just a while back before i formatted the hard disk, and these problems were not present there- hardware acceleration was working in Windows and nothing was flickering.

    This is a fresh install, and so far all I've done is:
    1. Installed multimedia codecs and switched system to 'pacman'.
    2. Updated opensuse.
    3. Installed VLC from pacman using yast
    4. Changed the theme as you can see
    5. Enabled some desktop effects (Glide, Wobbly)
    6. Installed three firefox add-ons (Ghostery, Ad-block plus, KProxy) all from the official firefox add-on page. (The flickering persists even if I disable all three add-ons and restart firefox).

    Is there a way to fix this? Perhaps enabling H/W acceleration will do the trick?
    Any help will be greatly appreciated. I'm no Linux expert so please don't use hi-tech words in the reply...
    Thanks..
    a few things from the post above need consideration
    #3 while not a cause for your issue installing packages from packman is not enough you need to do a full vendor change to packman as you probobly have mixed packages what's your repo list
    Code:
    zypper lr -d
    #5 your cpu is under-powered to run extra effects it's a celeron dualcore @1.7 GHz running an under-powered integrated intel graphic I'd say disable all extra effects
    https://ark.intel.com/products/84810...Cache-1_70-GHz
    to make sure it's not your current profile test Firefox with a fresh user account and see if the issue persists

    try disabling smooth scrolling
    hit the hamburger bar (the 3 horizontal lines)-> preferences -> General -> Browsing uncheck "Use Smooth Scrolling" restart Firefox

  9. #9

    Default Re: Looks like H/W acceleration isn't working in Firefox

    Hello I_A,
    I know the CPU is pretty basic, was hoping if it could run games in Windows, it would be able to run desktop effects as well.
    But anyway, disabling the desktop effects doesn't solve the firefox problem- what solves the problem is disabling OpenGL and falling back to XRender.
    If I use XRender instead of OpenGL, firefox behaves normally- no flickering..

    I've set up Google Chrome pretty much the way I have Firefox set up in my other computer, and everything seems to be working as expected- Chrome doesn't flicker and I am gettinng the general 'feel' that it's even faster than firefox.

    I will keep using google chrome till I get a bit more used to the system I guess, in case I try something drastic and the GUI breaks, and OpenSuse brings me to a shell prompt on startup, I will be completely lost. My shell skills are limited to copy/pasting commands and without a GUI I wouldn't be able to launch a browser to get in here.

    I really need to find a way to reduce CPU frequency when I'm running on battery power. I watch movies in battery, and the CPU constantly runs at near full speed, this causes the fans to spin up, and a continuous spinning fan takes a large bite out of my battery runtime- so much so I could watch videos for almost 6.5 to 7.00 hours (brightness set to minimum, CPU clocking at 0.80 GHz (fixed), and the fan completely turned off). This is a different topic altogether, so I will be starting a new thread to avoid mixing up two topics in one.

    Thank you, and if possible, please take a look at the nre thread about power management

  10. #10

    Default Re: Looks like H/W acceleration isn't working in Firefox

    Quote Originally Posted by I_A View Post
    Code:
    zypper lr -d
    **** I forgot to post the screenshot of this command. Here's what I get:




    I did a "switch system to pacman" using yast.


    If I do a su zypper dup, this is what I get:




    It wants to download 1.2 gb of data, doesn't look right, does it?

Page 1 of 2 12 LastLast

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •